ID do artigo: 177321 - Última revisão: terça-feira, 2 de março de 2004 - Revisão: 3.0

Arquivos .pdf do Adobe Acrobat aparecem como uma janela ou um quadro em branco

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar exibir um arquivo .pdf (Portable Document Format) no Internet Explorer, você poderá ver uma janela ou um quadro em branco em vez do arquivo .pdf. Isso pode ocorrer mesmo se o programa Adobe Acrobat Reader, e você conseguir normalmente exibir arquivos .pdf nesse programa.

Causa

Esse comportamento pode ser causado por uma das seguintes condições:

  • É necessário ter uma versão atualizada do Adobe Acrobat Reader para usar a ativação in-loco. A ativação in-loco é uma função que abre um arquivo de programa no Internet Explorer e exibe as barras de ferramentas a partir do programa associado.
  • O nível de segurança dessa zona é configurado para Alto no Internet Explorer 4.0, 4.01 ou 5. Para obter informações sobre as zonas de segurança no Internet Explorer, consulte o seguinte artigo na Base de Dados de Conhecimento da Microsoft:
    174360  (http://support.microsoft.com/kb/174360/PT-BR/ ) Como Utilizar Zonas de Segurança no Internet Explorer
  • As classificações estão ativadas no Internet Explorer 3.02, ou o nível de segurança está configurado para Alto.
  • O arquivo .pdf é mantido a partir de uma versão anterior de alguns servidores da Web (como o Microsoft Internet Information Server versão 2.0).
  • Isso pode estar relacionado a uma conexão lenta, o servidor pode ter uma carga alta ou o arquivo .pdf é muito grande.
  • Você está executando uma versão do Internet Explorer anterior ao Internet Explorer 5.5.
Esse problema pode ser causado por um controle ActiveX corrompido. Para que o Adobe Acrobat Reader 4 use a ativação in-loco com o Internet Explorer, o arquivo Pdf.ocx e Pdf.tlb devem estar presentes na pasta x:\Arquivos de Programas\Adobe\Acrobat 4.0\Acrobat\ActiveX\ em que x é a letra da unidade em que o Adobe Acrobat Reader foi instalado. Se algum desses arquivos estiver faltando, o Internet Explorer irá mostrar uma janela em branco ao abrir um arquivo .pdf.

Para obter mais informações sobre esse problema, visite o site do Adobe na Web:
http://www.adobe.com/support/techdocs/98fe.htm (http://www.adobe.com/support/techdocs/98fe.htm)

Resolução

Para resolver esse problema, execute as etapas na seção apropriada abaixo:

Atualizar para Internet Explorer 5.5

O Internet Explorer 5.5 resolveu o problema de exibição de uma página em branco ao recuperar um arquivo PDF usando o método POST. Se a atualização para o Internet Explorer versão 5.5 resolver esse problema, visite o seguinte site da Microsoft na Web:
http://www.microsoft.com/windows/ie (http://www.microsoft.com/windows/ie)

Internet Explorer 4.0, 4.01 e 5

Se você estiver usando o Adobe Acrobat Reader versão 3.0 ou anterior, atualize para a versão 4,0 ou posterior. Se você já estiver usando a versão 4.0 ou anterior, execute as seguintes etapas:
  1. Altere o nível de segurança usado pelo Internet Explorer para médio ou baixo. para exibir os arquivos .pdf no Internet Explorer 4.0, 4.01 ou 5, a segurança deve ser configurada para média ou baixa. Para alterar o nível de segurança, use as seguintes etapas.

    OBSERVAÇÃO: Se você não quiser reduzir o nível de segurança para essa zona, vá à etapa 2.
    1. Inicie o Internet Explorer e clique em Opções da Internet no menu Exibir. No Internet Explorer 5.5, clique em Opções da Internet no menu Ferramentas.
    2. Clique na guia Segurança, clique em Zona da Internet na caixa Zona, clique em Médio (Mais seguro) ou Baixo e em OK.
  2. Faça o download do arquivo .pdf e abra-o usando o programa Adobe Acrobat Reader.

Internet Explorer 3,02

Se você estiver usando o Adobe Acrobat Reader versão 3.0 ou anterior, atualize para a versão 3.01 ou posterior. Se você já estiver usando a versão 3.01 ou posterior, use um ou mais dos seguintes métodos:

Desativar as classificações no Internet Explorer

Para desativar as classificações no Internet Explorer, execute as seguintes etapas:
  1. Inicie o Internet Explorer e clique em Opções no menu Exibir.
  2. Na guia Segurança, clique Desativar classificações e em OK.
  3. Feche o Internet Explorer.
  4. Faça o download do arquivo .pdf e abra-o usando o programa Adobe Acrobat Reader.

Diminuir o nível de segurança

Altere o nível de segurança usado pelo Internet Explorer para médio ou baixo. Para fazer isso, execute as seguintes etapas:
  1. No menu Exibir, clique em Opções.
  2. Na guia Segurança, clique em Nível de segurança.
  3. Clique em Médio, em OK e novamente em OK.
  4. Feche o Internet Explorer.
  5. Faça o download do arquivo .pdf e abra-o usando o programa Adobe Acrobat Reader.

Conexão lenta

Se a sua conexão estiver lenta, o seu servidor estiver ocupado ou se você estiver tentando fazer o download de uma imagem grande, espere até que o download do arquivo seja concluído para que você possa exibi-lo.

Instalar e reinstalar o Adobe Acrobat Reader 4

  1. No Painel de controle, clique duas vezes em Adicionar/remover programas.
  2. Clique duas vezes no Adobe Acrobat Reader 4 para desinstalar o programa. Siga as instruções do assistente para desinstalar o programa.
  3. Se necessário, faça o download do Adobe Acrobat Reader 4 no site do Adobe na Web.
  4. Procure o arquivo Rs405eng.exe e clique duas vezes nele para reinstalar o programa.
  5. Embora você não precise reiniciar o computador durante a instalação, desligue-o e reinicie-o.
  6. O arquivo .pdf deverá ser exibido no Internet Explorer quando você clicar em um link para o arquivo .pdf na Internet.

Solução alternativa

  1. Abra o Adobe Acrobat Reader 4, no menu Arquivo, clique em Preferências e em Geral.
  2. Desmarque a caixa de seleção Integração do navegador da Web e clique em OK.
  3. Ao clicar em um link para um arquivo .pdf, você será solicitado a salvar o arquivo na caixa de diálogo Download do arquivo. Você pode salvar o arquivo e clicar duas vezes nele para abri-lo, o que irá abrir o arquivo no Adobe Acrobat Reader.

    Se você escolher Abrir arquivo do local atual, ele deverá abrir o arquivo no Adobe Acrobat Reader 4 e não no Internet Explorer.

Mais Informações

O Internet Explorer possibilita o uso do visualizador do Adobe Acrobat como um controle. Devido a uma alteração no modelo de objeto no Internet Explorer 3.0 para o Internet Explorer 4.0, o Adobe precisava atualizar seu visualizador para que funcionasse com o modelo de objeto do Internet Explorer 4.0. Para obter uma versão atualizada do Adobe Acrobat, entre em contato com a Adobe.

Para obter informações adicionais, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:
253213  (http://support.microsoft.com/kb/253213/PT-BR/ ) Incorrect Address Passed When Using POST Versus GET Method
Os produtos de terceiros mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, com relação ao desempenho ou à confiabilidade desses produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Edição de 128 Bits
  • Microsoft Internet Explorer 4.0 Edição de 128 Bits
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Edição de 128 Bits
  • Microsoft Internet Explorer 4.0 Edição de 128 Bits
  • Microsoft Internet Explorer 3.02
Palavras-chave: 
kbenv kbui KB177321
Retired KB ArticleAviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.