Adobe Acrobat PDF-filer visas som tomt fönster eller tom ram

Artikelöversättning Artikelöversättning
Artikel-id: 177321 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

På den här sidan

Symptom

Vid försök att visa en PDF-fil (Portable Document Format) i Internet Explorer syns ett tomt fönster eller en tom ram i stället för PDF-filen. Detta kan inträffa även om Adobe Acrobat Reader är installerat och PDF-filer vanligen kan visas i detta program.

Orsak

Problemet kan bero på något av följande:

  • En uppdaterad version av Adobe Acrobat Reader krävs för direktaktivering. Direktaktivering är en funktion för öppnande av programfiler i Internet Explorer och visning av verktygsfälten från ett associerat program.
  • Säkerhetsnivån för zonen har ställts in på Hög i Internet Explorer 4.0, 4.01 eller 5. Information om säkerhetszoner i Internet Explorer finns i följande artikel i Microsoft Knowledge Base:
    174360 Använda säkerhetszoner i Internet Explorer 4.0 (Länken kan leda till en webbplats som är helt eller delvis på engelska)
  • Klassificering har aktiverats i Internet Explorer 3.02, eller säkerhetsnivån har ställts in på Hög.
  • PDF-filen kommer från en tidig version av vissa webbservrar (t.ex. Microsoft Internet Information Server version 2.0).
  • Detta kan bero på att anslutningen är långsam, servern har hög arbetsbelastning eller att PDF-filen är mycket stor.
  • En tidigare version av Internet Explorer än 5.5 används.
Problemet kan orsakas av en skadad ActiveX-kontroll. För att direktaktivering ska kunna användas för Adobe Acrobat Reader 4 med Internet Explorer måste filerna Pdf.ocx och Pdf.tlb finnas i mappen x:\Program\Adobe\Acrobat 4.0\Acrobat\ActiveX\ där x är enhetsbeteckningen för enheten där Adobe Acrobat Reader har installerats. Om någon av de här filerna saknas kan ett tomt fönster visas i Internet Explorer när en PDF-fil öppnas.

Lösning

Lös problemet genom att följa anvisningarna i lämpligt avsnitt nedan:

Uppgradera till Internet Explorer 5.5

I Internet Explorer 5.5 förekommer inte problemet att en tom sida visas vid hämtning av en PDF-fil med POST-metoden. Uppgradering till Internet Explorer version 5.5 löser problemet. Besök följande Microsoft-webbplats:
http://www.microsoft.com/sverige/windows/ie/default.mspx

Internet Explorer 4.0, 4.01 och 5

Om du använder Adobe Acrobat Reader version 3.0 eller tidigare uppgraderar du till version 4.0 eller senare. Gör så här om du redan använder version 4.0 eller senare:
  1. Ändra säkerhetsnivån i Internet Explorer till normal eller lägre. För att PDF-filer ska kunna visas i Internet Explorer 4.0, 4.01 eller 5 måste säkerhetsnivån vara normal eller lägre. Ändra säkerhetsnivån så här:

    Obs! Om du inte vill sänka säkerhetsnivån för den här zonen går du till steg 2.
    1. Starta Internet Explorer och klicka sedan på Internet-alternativ på Visa-menyn. I Internet Explorer 5.0 klickar du på Internet-alternativ på Verktyg-menyn.
    2. Klicka på fliken Säkerhet, Zonen Internet i rutan Zon, Normal eller Låg och sedan på OK.
  2. Hämta PDF-filen och öppna den sedan med Adobe Acrobat Reader.

Internet Explorer 3.02

Om du använder Adobe Acrobat Reader version 3.0 eller tidigare uppgraderar du till version 3.01 eller senare. Använd en av följande metoder eller båda om du redan använder version 3.01 eller senare:

Inaktivera klassificering i Internet Explorer

Så här inaktiverar du klassificering i Internet Explorer:
  1. Starta Internet Explorer och klicka sedan på Alternativ på Visa-menyn.
  2. Klicka på Inaktivera klassificering på fliken Säkerhet och på OK.
  3. Avsluta Internet Explorer.
  4. Hämta PDF-filen och öppna den sedan med Adobe Acrobat Reader.

Sänk säkerhetsnivån

Ändra säkerhetsnivån i Internet Explorer till normal eller lägre så här:
  1. Klicka på Alternativ på Visa-menyn.
  2. Klicka på Säkerhetsnivå på fliken Säkerhet.
  3. Klicka på Normal, OK och sedan på OK igen.
  4. Avsluta Internet Explorer.
  5. Hämta PDF-filen och öppna den sedan med Adobe Acrobat Reader.

Långsam anslutning

Om du har en långsam anslutning, en upptagen server eller försöker hämta en stor fil väntar du tills filen har hämtats innan du visar den.

Avinstallera och installera om Adobe Acrobat Reader 4

  1. Dubbelklicka på Lägg till/ta bort program på Kontrollpanelen.
  2. Avinstallera programmet genom att dubbelklicka på Adobe Acrobat Reader 4. Följ anvisningarna i guiden.
  3. Hämta vid behov Adobe Acrobat Reader 4 från Adobes webbplats.
  4. Sök efter filen Rs405eng.exe, och installera sedan om programmet genom att dubbelklicka på den.
  5. Även om du inte uppmanas att starta om datorn under installationen stänger du av och startar om den.
  6. PDF-filen ska visas i Internet Explorer när du klickar på en länk till PDF-filen på Internet.

Lösning

  1. Öppna Adobe Acrobat Reader 4, klicka på PreferencesFile-menyn och klicka sedan på General.
  2. Avmarkera kryssrutan Web Browser Integration och klicka sedan på OK.
  3. När du klickar på en länk till en PDF-fil uppmanas du att spara filen i dialogrutan Filhämtning. Du kan spara filen och sedan öppna den i Adobe Acrobat Reader genom att dubbelklicka på den.

    Om du väljer Kör den här filen från dess aktuella plats ska den öppnas i Adobe Acrobat Reader 4, inte Internet Explorer.

Mer Information

Internet Explorer gör det möjligt att använda Adobe Acrobat-visningsprogrammet som en kontroll. På grund av en förändring av objektmodellen från Internet Explorer 3.0 till Internet Explorer 4.0 krävdes en uppdatering av Adobes visningsprogram för att det skulle fungera tillsammans med objektmodellen i Internet Explorer 4.0. Kontakta Adobe om du vill ha en uppdaterad version av Adobe Acrobat.

Om du vill veta mer klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
253213 Fel adress överförs vid användning av POST- i stället för GET-metoden (Länken kan leda till en webbplats som är helt eller delvis på engelska)
De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.

Egenskaper

Artikel-id: 177321 - Senaste granskning: den 22 januari 2007 - Revision: 4.0
Informationen i denna artikel gäller:
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 128-bitarsversion
  • Microsoft Internet Explorer 4.0 128-bitarsversion
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 128-bitarsversion
  • Microsoft Internet Explorer 4.0 128-bitarsversion
  • Microsoft Internet Explorer 3.02
Nyckelord: 
kbenv kbui KB177321
Ansvarsfriskrivning för KB-innehåll som inte uppdateras
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com