Artikel-ID: 177943 - Geändert am: Samstag, 21. Januar 2006 - Version: 4.4

ActiveX-Fehler beim Ausführen von Microsoft Internet Explorer 4.0

Dieser Artikel wurde zuvor veröffentlicht unter D39081
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
177943  (http://support.microsoft.com/kb/177943/EN-US/ ) OFF97: ActiveX Errors When You Run Internet Explorer
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie Internet Explorer starten, wird möglicherweise die folgende Fehlermeldung angezeigt:
Die von dieser Seite für ein ActiveX-Steuerelement bereitgestellte Information ist möglicherweise nicht sicher. Die aktuellen Sicherheitseinstellungen verhindern eine derartige Ausführung von Steuerelementen. Möglicherweise wird die Seite nicht richtig angezeigt.
Außerdem kann sinngemäß die folgende Fehlermeldung erscheinen, wenn Sie auf eines der Laufwerke des Arbeitsplatzes oder im Microsoft Windows-Explorer klicken:
Microsoft Internet Explorer

Ein ActiveX-Steuerelement auf dieser Seite ist nicht sicher. Die aktuellen Sicherheitseinstellungen unterbinden, nicht sichere Steuerelemente auf dieser Seite auszuführen. Deshalb wird diese Seite möglicherweise nicht wie beabsichtigt angezeigt.
Wenn Sie auf OK klicken, wird die folgende Fehlermeldung angezeigt:
Internet Explorer-Skriptfehler

In dem Skript auf dieser Seite ist ein Fehler aufgetreten.

Zeile: 78
Zeichen: 1

Fehler: Die Eigenschaft oder Methode wird vom Objekt nicht unterstützt.
Code: 0

Sollen Skripte auf dieser Seite weiter ausgeführt werden?
Wenn Sie auf JA oder NEIN klicken, können Sie ein beliebiges Laufwerk öffnen. Wenn Sie jedoch Ordner auf den Laufwerken öffnen möchten, erscheinen weiterhin ähnliche Fehlermeldungen.

Hinweis: Wenn Sie Ihren Computer neu starten, werden diese Fehlermeldungen erneut angezeigt. Weitere Informationen zu diesen Fehlermeldungen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
201364  (http://support.microsoft.com/kb/201364/DE/ ) PRB: nicht übereinstimmen Ole32.dll und Comcat.dll

Ursache

Dieses Problem kann auftreten, wenn Sie das Office 97-Dienstprogramm zum Löschen von Dateien und der Registrierung ausführen und Microsoft Windows NT Version 4.0 sowie den Internet Explorer 4.0 verwenden.

Lösung

Installieren Sie die Datei Comcat.dll neu, um dieses Problem zu beheben.
  1. Klicken Sie im Windows-Explorer im Ordner \Os\System Ihrer Microsoft Office 97-CD-ROM auf die Datei Comcat.dll, um diese auszuwählen.
  2. Klicken Sie im Menü Bearbeiten auf Kopieren. Gehen Sie zum Ordner System32 von Windows NT. Standardmäßig ist dies C:\Winnt\System32. Klicken Sie im Menü BEARBEITEN auf EINFÜGEN.
  3. Klicken Sie auf Start und auf Ausführen, und führen Sie anschließend den folgenden Befehl aus:
    Regsvr32 c:\winnt\system32\comcat.dll
    Klicken Sie auf OK. Die folgende Meldung wird angezeigt:
    DllRegisterServer in c:\winnt\system32\comcat.dll erfolgreich.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Eine aktualisierte Version des Office 97-Dienstprogramms zum Löschen von Dateien und der Registrierung (Eraser97.exe) ist verfügbar.

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
Bild minimierenBild vergrößern
Download
Eraser97.exe jetzt downloaden (http://download.microsoft.com/download/office97std/utility/4.0/win98mexp/en-us/eraser97.exe)
Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/DE/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden. Das Office 97-Dienstprogramm zum Löschen von Dateien und der Registrierung entfernt die meisten Dateien und Einstellungen der Windows-Registrierung, die auf dem Computer vorhanden sind, nachdem Sie Microsoft Office 97 entfernt haben. Dieses Dienstprogramm muss nach dem Setup-Programm von Office 97 und dem Bestätigen der Option ALLE ENTFERNEN ausgeführt werden. Wenn Sie dieses Dienstprogramm ausführen, werden gemeinsam benutzte Systemkomponenten entfernt. Der Active Desktop des Microsoft Internet Explorers benötigt diese Komponenten und arbeitet daher nicht mehr fehlerfrei, nachdem diese Dateien entfernt wurden. Um den Active Desktop wiederherzustellen, müssen Sie die Datei Comcat.dll erneut installieren. Weitere Informationen zum Dienstprogramm "Office 97 File and Registry Eraser" finden Sie im folgenden Artikel der Microsoft Knowledge Base:
176823  (http://support.microsoft.com/kb/176823/DE/ ) OFF97: Dienstprogramm zum vollständigen Entfernen verbleibender Office 97-Dateien und -Registrierungseinträge

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office 97 Standard Edition, wenn verwendet mit:
    • Microsoft Windows NT 4.0
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
Keywords: 
kbdownload kbenv kberrmsg kbgraphxlinkcritical kbinterop kbprb KB177943
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
 

SPRACHE AUSWÄHLEN

 

Related Support Centers