Como criar um arquivo de .dll de recurso que contém um arquivo AVI

Traduções deste artigo Traduções deste artigo
ID do artigo: 178199 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sumário

Este artigo mostra como adicionar um arquivo AVI para um arquivo de recurso e compila esse arquivo em um arquivo .dll. Outros programas, como o Visual Basic, podem acessar o arquivo .dll.

Mais Informações

  1. Iniciar Visual C. No menu Arquivo, clique em Novo e vá para a guia projetos. Clique em biblioteca de vínculo dinâmico do Win32 e digite o nome do seu projeto na caixa de texto Nome do projeto. Clique em OK para fechar a caixa de diálogo. Clique na guia Exibir arquivos.
  2. Crie o arquivo de script de recurso, executando as seguintes etapas:
    1. No menu Inserir, clique em recurso para exibir a caixa de diálogo do recurso.
    2. Clique no botão Importar para abrir a caixa de diálogo Importar recurso. Escolha o arquivo AVI e clique no botão Importar para fechar a caixa de diálogo. A caixa de diálogo tipo de recurso personalizado exibe.
    3. Digite AVI na caixa de diálogo tipo de recurso e clique em OK para fechar a caixa de diálogo tipo de recurso. Um despejo hexadecimal do arquivo de script de recurso Script1 exibe em uma janela. Feche esta janela.
    4. Salve o arquivo de script de recurso com uma extensão de nome de arquivo .rc.
  3. No menu Project, clique em Adicionar ao projeto e clique em arquivos. Adicione o arquivo de script de recurso para o projeto.
  4. Adicione o parâmetro /NOENTRY para as configurações de projeto completando as seguintes etapas:
    1. No menu Project, clique em configurações. A caixa de diálogo de configuração do Project exibirá.
    2. Clique na guia link e digite /NOENTRY para a caixa de texto Project Options. Clique em OK para fechar a caixa de diálogo.
  5. Crie o arquivo .dll. No menu Build, clique em Build <projectname>.dll.
(c) 1997 Microsoft Corporation, todos os direitos reservados. Contribuições por Arsenio Locsin, Microsoft Corporation

Referências

Para obter um exemplo de como acessar um arquivo .dll compilado que contém um arquivo AVI, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft:
173668EXEMPLO: Avirsce.exe desempenha um AVI armazenado em um arquivo .dll de recurso

Propriedades

ID do artigo: 178199 - Última revisão: sábado, 22 de fevereiro de 2014 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Visual C++ 5.0 Enterprise Edition
  • Microsoft Visual C++ 6.0 Enterprise Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual C++, 32-bit Learning Edition 6.0
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhowto KB178199 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 178199

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com