Article ID: 178378 - Last Review: October 28, 2006 - Revision: 3.3

XFOR: IMS Does Not Send NDR for Messages Passed From a Custom Routing .Dll File with DISP_NDR_ORIG

This article was previously published under Q178378
Expand all | Collapse all

SYMPTOMS

The Microsoft Exchange Server Internet Mail Service does not send a non- delivery report (NDR) on a message it has passed from a custom routing .Dll file with DISP_NDR_ORIG. The message may be delivered to the mailbox and the following event ID recorded:
   Event id 2078 from MSExchangeIS Private
   Category: Transfer Out Of Gateway
   Description: Unable to submit, send or transfer out a message. Check
   PR_DELIVERY_TIME, PR_NDR_REASON, PR_NON_DELIVERY_DIAGNOSTIC.
				

CAUSE

The Microsoft Exchange Server Internet Mail Service will attempt to resolve the name and deliver the message if a valid address is available in the message. If the address in the recipient list is not valid, the message transfer agent (MTA) will send an NDR. If the address is resolved, then the MTA will attempt to deliver the message.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Serverversion 5.0. This problem has been corrected in Microsoft Exchange Server version 5.0 Service Pack 2.

Microsoft has confirmed that this is a problem in Microsoft Exchange Serverversion 5.5. This problem has been corrected in Microsoft Exchange Server version 5.5 Service Pack 1.

For information on obtaining Service Packs, query on the following word in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K

APPLIES TO
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbbug kbfix KB178378
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations