오류 8004010F "MAPI_E_NOT_FOUND" CDO 1.x 함께

기술 자료 번역 기술 자료 번역
기술 자료: 179639 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

다음과 같은 오류 메시지가 나타날 수 있습니다.
공동 작업 데이터 개체
[공동 작업 데이터 개체 [MAPI_E_NOT_FOUND(8004010F)]]
여러 가지 이유로 이 오류 메시지가 나타날 수 있습니다. 이 문서에서는 몇 가지 원인과 오류 해결 방법을 설명합니다.

원인

다음 오류의 원인 목록입니다.
  1. ASP (Active Server Pages) 페이지에서 코드를 실행하는 경우 사용자가 프로필 이름을 로그온 방법의 프로필을 Microsoft 인터넷 정보 서버 (IIS)가 실행되는 컴퓨터에 존재하지 않는 전달하는 수 있습니다.
  2. 존재하지 않는 리소스를 사용할 시도하는 것일 수 있습니다. 이 문제는 서버를 사용하려고 또는 존재하지 않는 사서함에 로그온을 시도할 때 발생합니다. 이 문제의 일반적인 원인은 복사하여 서버 및 사서함 변수를 수정하지 않고 샘플 코드를 붙여넣는.
  3. 존재하지 않는 받는 사람을 확인할 시도하는 것일 수 있습니다.
  4. Folders.Item(searchValue) 문을 통해 폴더 컬렉션에서 요소를 검색할 때 이전 항목을 검색할 시도하는 것일 수 있습니다.
  5. Exchange Server에 대해 GetFreeBusy 메서드를 사용하여 해당 데이터를 아직 기록되었습니다 없습니다 또는 있는 모든 약속을 일정에 없는 사서함.
  6. Groupwise에 대한 메일을 보내는 동안 보낼 편지함에 액세스할 때 또는 Send 메서드를 호출할 때 이 오류 메시지가 나타날 수 있습니다.
  7. (속성) 필드에 존재하지 않는 공동 작업 데이터 개체 (1.1, 1.2, 1.21) 개체에서 (속성) 필드 값을 설정할 시도하는 것일 수 있습니다.

해결 방법

다음 해결 방법 원인 절에 나열된 원인은 일치합니다.
  1. 특정 프로필 이름 대신 로그온 메서드에 호출을 ProfileInfo 매개 변수를 사용해야 합니다. ASP 페이지에서 사용자의 프로필을 프로그래밍 방식으로 만들 수 있습니다.

    사용자가 일반적으로 프로필은 서버에 없는 프로필을 CDO (1.1, 1.2, 1.21) 찾을 수 있도록 데이터를 HKEY_CURRENT_USER 로드할 것인지 것 때문에 수행합니다.
  2. 세션 개체의 로그온 메서드가 사용되는 변수에 대한 코드를 확인하십시오. 대부분의 ASP 예제 코드에서는 strProfileInfo 라는 변수를 포함합니다. 이 변수는 서버 이름, 줄 바꿈, 및 사서함 이름을 조합입니다. 서버 및 사서함, 정의 변수에 대해 살펴보고 리소스를 네트워크에서 Exchange Server를 실행하는 컴퓨터에 있는지 확인하십시오.
  3. 같이 받는 사람이 있는지 확인하십시오 지정된. ASP 페이지에서 CDO (1.1, 1.2, 1.21) 잘못된 받는 사람에게 전달하는 경우 문제를 해결할 수 있는 유일한 방법은 받는 다시 입력해야 합니다. 주소록 클라이언트에서 호출할 수 없습니다.
  4. Folders.Item(searchValue) 문을 통해 폴더 컬렉션에서 요소를 검색할 때 이전 항목을 검색해 봅니다.

    Folders.Item(searchValue) 문을 정방향 검색을 수행합니다. 따라서 해당 문을 사용하여 두 (2) 폴더 컬렉션의 항목을 검색할 시작한 다음 나중에 사용자가 이전 항목에 동일한 컬렉션에 액세스할 경우에는 오류가 나타납니다.

    이 문제를 해결하려면 인덱스 매개 변수를 Folders.Item 문을 사용하십시오. 컬렉션의 지정된 위치에 폴더 개체 Item(index) 구문 반환.

    또는 GetFirst 메서드, GetPrevious 메서드, GetNext 메서드 및 FoldersCollection 개체의 GetLast 메서드를 사용할 수 있습니다.
  5. 사서함에 메일 클라이언트를 사용하여 기록되었습니다 사서함에 대한 일정이 적어도 하나의 약속 존재합니다 때까지 약속 있음/없음 정보를 사서함을 사용할 수 없습니다.

    이 문제에 대한 세 가지 해결 방법을 다음과 같습니다.
    • 일부 약속 있음/없음 정보를 사용하여 사서함에 작성된 하려면 Outlook 클라이언트를 사용하여 사서함에 로그온하십시오. 메일에 처음 로그온할 때 Outlook 약속 있음/없음 정보를 차례로 만듭니다 약속 항목을 만듭니다.
    • Exchange 클라이언트를 사용하여 사서함에 로그온할 및 Schedule+, 시작 또는 Schedule+ 자체적으로 시작하십시오. 약속 있음/없음 정보를 해당 사서함을 만듭니다. 실제로 약속을 만들 필요가 없습니다.
    • CDO를 (1.2, 1.21) 약속 있음/없음 정보를 해당 사서함에 대해 만든 새 테스트 약속을 만들 수 있습니다.
  6. Groupwise에 대한 메일을 보내는 동안 보낼 편지함에 액세스할 때 또는 Send 메서드를 호출할 때 이 오류 메시지가 나타날 수 있습니다.

    이 오류를 해결하려면 다음을 수행하십시오.
    • 지정한 NoMail: = True세션 개체의 로그온 메서드 호출에서.
    • MAPI 스풀러 이미 GroupWise 메시지 저장소 (예: Outlook으로 연결된 필요 후 실행 중인지 확인하십시오.
    참고 또한 이러한 해결 방법은 다음 해결할 수 GroupWise 계정에서 CDO (1.1, 1.2, 1.21)를 사용하여 메일을 보내는 다른 문제:
    • 메시지를 보냈지만 텍스트와 첨부 파일이 없습니다.
    • 메시지가 보낸된 항목을 나타나지만 받는 사람에게 배달되지 않음
  7. 방금 필드 값을 설정하는 대신 필드에 존재하지 않는 가정하십시오. 필드Add 메서드를 사용하여 컬렉션에. Add 메서드를 사용하여 모두 필드를 추가하고 있습니다 값을 다음과 같이 설정합니다.
    objMsg.Fields.Add &H00150040, 234
    이전 코드 예제를 추가하고 PR_EXPIRY_LIMIT에 대한 값을 설정하는 방법을 보여 줍니다 (& H00150040) 필드. 속성이 이미 있으면 오류가 발생합니다.

참조

자세한 내용은 Microsoft 기술 자료에 있는 문서를 보려면 다음 문서 번호를 클릭하시기 바랍니다:
183094CDO (1.x) MAPI_E_NOT_FOUND 속성 값 설정하는 동안 오류가 발생했습니다
183250CDO (1.x) 오류: GetFreeBusy 런타임 오류 '-2147221233'
195662ProfileInfo 매개 변수를 사용하여 Exchange에 로그온하는 방법

속성

기술 자료: 179639 - 마지막 검토: 2005년 10월 5일 수요일 - 수정: 3.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Collaboration Data Objects 1.21
  • Microsoft Collaboration Data Objects 1.1
  • Microsoft Collaboration Data Objects 1.2
키워드:?
kbmt kbcode kbfaq kbgrpdsmsg kbmsg kbole kbpending kbprb KB179639 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
더 이상 지원되지 않는 제품의 KB 내용에 대한 고지 사항
이 문서에서는 Microsoft에서 더 이상 지원하지 않는 제품에 대해 설명합니다. 따라서 이 문서는 "있는 그대로" 제공되며 업데이트되지 않습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com