V aplikaci Internet Explorer nelze použít příkaz Otevřít v novém okně

Překlady článku Překlady článku
ID článku: 180176 - Produkty, které se vztahují k tomuto článku.
Verzi tohoto článku pro aplikace Internet Explorer 5 a 6 naleznete pod číslem 281679Nelze otevřít nové okno aplikace Internet Explorer nebo po klepnutí na odkaz nedojde k žádné akci .
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Můžete zaznamenat některý z následujících příznaků:
  • Jestliže klepnete na webovou adresu nebo stránku pravým tlačítkem myši a potom klepnete na příkaz Otevřít v novém okně, požadovaná stránka nebude otevřena v novém okně.
  • Jestliže klepnete na odkaz na webové stránce, který používá skript pro otevření nového okna, nové okno se neotevře nebo se zobrazí následující chybová zpráva:
    Chyba skriptu aplikace Internet Explorer
    Ve skriptu na této stránce došlo k chybě.

    Řádek:
    Znak:
    Chyba: Neznámé rozhraní
    Kód: 0

    Chcete na této stránce i nadále spouštět skripty?

Příčina

K tomuto problému může dojít, pokud platí některá z následujících podmínek:
  • Nainstalovali jste program, který nesprávně registruje rozhraní v následujícím klíči registru:
    HKEY_CLASSES_ROOT\Interface
  • Odebrali jste aplikaci Visual Basic 5.0 poté, co byla použita k vytvoření programu, který používá ovládací prvek WebBrowser poskytnutý souborem Shdocvw.dll.
  • V registru aplikace Internet Explorer chybí některé informace nebo jsou poškozeny.

Řešení

Chcete-li tento problém vyřešit, postupujte následovně:
  1. Klepněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz regsvr32 actxprxy.dll.
  3. Klepněte na tlačítko OK a po zobrazení následující zprávy znovu klepněte na tlačítko OK:
    Provedení DllRegisterServer v actxprxy.dll se zdařilo.
  4. Klepněte na tlačítko Start a potom na příkaz Spustit.
  5. Do pole Otevřít zadejte příkaz regsvr32 shdocvw.dll.
  6. Klepněte na tlačítko OK a po zobrazení následující zprávy znovu klepněte na tlačítko OK:
    Provedení DllRegisterServer v shdocvw.dll se zdařilo.
  7. Restartujte počítač.
K tomuto problému může docházet také v případě, že pro některé soubory systému Windows nebo aplikace Internet Explorer chybí informace v registru nebo jsou poškozeny. Pokud postup uvedený výše v tomto článku není funkční, zopakujte kroky pro registraci některých dalších souborů systému Windows a aplikace Internet Explorer. Použijte následující příkazy:
  • regsvr32 oleaut32.dll,
  • regsvr32 shdocvw.dll,
  • regsvr32 actxproxy.dll,
  • regsvr32 mshtml.dll,
  • regsvr32 pdm32.dll.
K těmto potížím nedochází v aplikaci Internet Explorer 4.01 s aktualizací Service Pack 1 nebo vyšší. Chcete-li získat nejnovější verzi aplikace Internet Explorer, přejděte na následující web společnosti Microsoft:
http:/www.microsoft.com/windows/ie

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku.

Vlastnosti

ID článku: 180176 - Poslední aktualizace: 2. prosince 2005 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
Klíčová slova: 
kberrmsg kbprb kbui KB180176
Právní omezení pro obsah znalostní báze týkající se produktů, jejichž podpora byla ukončena
Tento článek byl napsán o produktech, pro které společnost Microsoft již neposkytuje nadále podporu. Článek je tedy nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com