Polecenie „Otwórz w nowym oknie” nie działa w programie Internet Explorer

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 180176 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Wersja tego artykułu dla programu Internet Explorer w wersji 5 i 6: 281679.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Może pojawić się jeden z następujących symptomów:
  • Po kliknięciu prawym przyciskiem myszy adresu sieci Web na stronie sieci Web i kliknięciu polecenia Otwórz w nowym oknie strona sieci Web może się nie otworzyć w nowym oknie.
  • Po kliknięciu łącza na stronie sieci Web, na której do otwarcia nowego okna używany jest skrypt, nowe okno może nie zostać otwarte lub może pojawić się następujący komunikat o błędzie:
    Błąd skryptu programu Internet Explorer
    Wystąpił błąd w skrypcie na tej stronie.

    Wiersz:
    Znak:
    Błąd: Taki interfejs nie jest obsługiwany
    Kod: 0

    Czy chcesz kontynuować uruchamianie skryptów na tej stronie?

Przyczyna

Ten problem może wystąpić, jeśli jest spełniony przynajmniej jeden z poniższych warunków:
  • Zainstalowano program, który niepoprawnie rejestruje interfejsy w następującym kluczu rejestru:
    HKEY_CLASSES_ROOT\Interface
  • Usunięto program Microsoft Visual Basic 5.0 po utworzeniu za jego pomocą aplikacji, która korzysta z formantu Webbrowser obecnego w pliku Shdocvw.dll.
  • Brak niektórych informacji w rejestrze dotyczących programu Internet Explorer lub są one uszkodzone.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie regsvr32 actxprxy.dll.
  3. Kliknij przycisk OK, a następnie po pojawieniu się następującego komunikatu ponownie kliknij przycisk OK:
    Polecenie DllRegisterServer w pliku actxprxy.dll powiodło się.
  4. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  5. W polu Otwórz wpisz polecenie regsvr32 shdocvw.dll.
  6. Kliknij przycisk OK, a następnie po pojawieniu się następującego komunikatu ponownie kliknij przycisk OK:
    DllRegisterServer in shdocvw.dll succeeded.
  7. Ponownie uruchom komputer.
Ten problem może również wystąpić w przypadku braku lub uszkodzenia informacji dotyczących rejestracji niektórych plików systemu Windows lub programu Internet Explorer. Jeśli kroki podane wcześniej w tym artykule nie przynoszą efektu, powtórz kroki dotyczące rejestrowania niektórych dodatkowych plików systemu Windows i programu Internet Explorer. W tym celu wykonaj następujące polecenia:
  • regsvr32 oleaut32.dll
  • regsvr32 shdocvw.dll
  • regsvr32 actxproxy.dll
  • regsvr32 mshtml.dll
  • regsvr32 pdm32.dll
Ten problem nie występuje w programie Internet Explorer 4.01 z dodatkiem Service Pack 1 lub nowszym. Aby uzyskać najnowszą wersję programu Internet Explorer, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/windows/ie_intl/pl/

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Właściwości

Numer ID artykułu: 180176 - Ostatnia weryfikacja: 14 czerwca 2004 - Weryfikacja: 4.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 4.0 (128-bitowy)
Słowa kluczowe: 
kberrmsg kbprb kbui KB180176
Zastrzeżenie dotyczące artykułów z bazy wiedzy o produktach wycofanych
Ten artykuł dotyczy produktów, dla których firma Microsoft nie oferuje już pomocy technicznej. Dlatego jest on oferowany w obecnej wersji i nie będzie już aktualizowany.

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com