Article ID: 181050 - Last Review: November 17, 2009 - Revision: 13.0

Internet Explorer error "connection timed out" when server does not respond

This article was previously published under Q181050
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SYMPTOMS

When you connect to a Web site that runs for a while before it returns information to Internet Explorer, you may receive one of the following error messages.

Message 1
Microsoft Internet Explorer error 10060 connection timed out.
Message 2
Internet Explorer cannot open the Internet site <Web address>. The operation timed out.
Message 3
The page cannot be displayed. Cannot find server or DNS Error.

CAUSE

Internet Explorer imposes a time-out limit for the server to return data. By default, the time-out limit is as follows:
Collapse this tableExpand this table
Internet Explorer 4.0 and Internet Explorer 4.015 minutes
Internet Explorer 5.x and Internet Explorer 6.x60 minutes
Internet Explorer 7 and Internet Explorer 860 minutes

Internet Explorer does not wait endlessly for the server to come back with data when the server has a problem.

RESOLUTION

If a page does not return within a few minutes, many users perceive that a problem has occurred and stop the process. Therefore, design your server processes to return data within 5 minutes so that users do not have to wait for a long time.

You can usually break down long processes into smaller pieces. Or, the server can return status data to update users about the process. In addition, you can create a long server process with a messages-based or asynchronous approach so that it returns immediately to the client after the job is submitted and notifies users when the long process is finished.

MORE INFORMATION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
Although Microsoft does not encourage this approach, you can change the default time-out setting for Internet Explorer. To do this in Internet Explorer 4.01 Service Pack 1 or a later version of Internet Explorer, follow these steps:
  1. Add a ReceiveTimeout DWORD entry with a value of (<number of seconds>)*1000 in the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    For example, if you want the time-out duration to be 8 minutes, set the value of the ReceiveTimeout entry to 480000 (<480>*1000).
  2. Restart the computer.
Note This setting does not work on versions of Internet Explorer that are earlier than Internet Explorer 4.0 SP1.

REFERENCES

For more information about how to develop Web-based solutions for Internet Explorer, visit the following Microsoft Web sites:
http://msdn.microsoft.com/ie/ (http://msdn.microsoft.com/ie/)

http://support.microsoft.com/iep (http://support.microsoft.com/iep)

APPLIES TO
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
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kbenv kberrmsg kbnavigation kbprb KB181050
 

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