معرف المقالة: 181050 - عرض المنتجات التي تنطبق عليها هذه المقالة.
توسيع الكل | طي الكل

الأعراض

عندما تقوم بالاتصال بموقع ويب يقوم يعمل لفترة قبل أن يقوم بإرجاع المعلومات لـ Internet Explorer، قد تتلقى إحدى رسائل الخطأ التالية.

رسالة الخطأ الأولى
انتهت مهلة الاتصال خطأ 10060 Microsoft Internet Explorer.
رسالة الخطأ الثانية
لا يستطيع Internet Explorer فتح موقع إنترنت <عنوان الويب>. انتهت مهلة التشغيل.
رسالة الخطأ الثالثة
لا يمكن عرض الصفحة. لا يمكن العثور على ملقم أو خطأ DNS.

السبب

يفرض Internet Explorer حدًا للمهلة ليقوم خلالها الخادم بإرجاع البيانات. بشكل افتراضي، يكون حد المهلة كما يلي:
طي هذا الجدولتوسيع هذا الجدول
برنامج Internet Explorer 4.0 وInternet Explorer 4.015 دقائق
Internet Explorer 5.x وInternet Explorer 6.x60 دقيقة
برنامج Internet Explorer 7 وInternet Explorer 860 دقيقة

عندما يواجه الخادم مشكلة، فلا يظل Internet Explorer ينتظر الخادم دون توقف لإرجاع البيانات.



سوف تواجه التطبيقات التي تستخدم WinINet API مباشرة قيم التالية الخاصة باستلام انتهاء المهلة:

طي هذا الجدولتوسيع هذا الجدول
الإصدار 4.x من WinINet.dll5 دقائق
الإصدار 5.x و6.x من WinINet.dll60 دقيقة
الإصدار 7.x و8.x من WinINet.dll30 ثانية

يمكنك تحديد موقع إصدار WinINet.dll في الدليل %windir%\system32.




الحل

إذا لم تقم الصفحة بالإرجاع خلال بضع دقائق، فقد يتخيل الكثير من المستخدمين أن هناك مشكلة حدثت، ومن ثم يقومون بإيقاف العملية. لذا، ينبغي عليك تصميم عمليات خادمك لإرجاع البيانات خلال خمس دقائق تقريبًا بحيث لا يضطر المستخدمون إلى الانتظار لمدة طويلة.

عادةً ما يمكنك تقسيم عمليات طويلة إلى أجزاء أصغر. أو يمكن أن يقوم الخادم بإرجاع بيانات الحالة لتحديث المستخدمين بشأن العملية. بالإضافة إلى ذلك، يمكنك إنشاء عملية خادم طويلة مستندة إلى رسائل أو أسلوب غير متزامن لذلك فإنها تقوم بالإرجاع فورًا إلى المستخدم بعد إرسال المهمة، ثم تقوم بإخطار المستخدم بعد انتهاء العملية الطويلة.

معلومات أخرى

هام يحتوي هذا القسم أو الطريقة أو المهمة على الخطوات التي توضح كيفية تعديل السجل. ومع ذلك، قد تحدث مشكلات خطيرة في حالة تعديل السجل بطريقة غير صحيحة. ولذلك، يجب التأكد من اتباع الخطوات التالية بعناية. للحماية الإضافية، قم بعمل نسخة احتياطية من السجل قبل تعديله. يمكنك بعد ذلك استعادة السجل في حالة حدوث أية مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft" :
322756 كيفية عمل نسخة احتياطية من السجل واستعادته في نظام التشغيل Windows XP
على الرغم من أن Microsoft لا تشجع هذا الأسلوب، يمكنك تغيير إعداد المهلة الافتراضية لبرنامج Internet Explorer.

لنقوم بتغيير إعداد المهلة الافتراضية لمدة 5 دقائق لبرنامج Internet Explorer، انتقل إلى القسم "إصلاح المشكلة بالإنابة عني". إذا كنت تفضل إصلاحها بنفسك، انتقل إلى القسم "إصلاح هذه المشكلة بنفسي".

إصلاح المشكلة بالإنابة عني



لإصلاح هذه المشكلة تلقائيًا، انقر فوق زر أو ارتباط Fix it. انقر فوق تشغيل في مربع الحوار تنزيل ملف، واتبع الخطوات الموجودة في معالج "إصلاح هذه المشكلة".


إصلاح هذه المشكلة
Microsoft Fix it 50600

ملاحظات
  • سيقوم هذا الإصلاح التلقائي بتغيير إعداد المهلة الافتراضية إلى 5 دقائق لبرنامج Internet Explorer.
  • قد لا يكون هذا المعالج متوفرًا إلا باللغة الإنجليزية. ومع ذلك، يعمل الإصلاح التلقائي أيضًا مع إصدارات اللغات الأخرى من Windows.
  • إذا كنت لا تعمل على الكمبيوتر الذي توجد به المشكلة، فيمكنك حفظ حل "Fix it" على محرك أقراص محمول أو قرص مضغوط ثم تشغيله على الكمبيوتر الذي توجد به المشكلة.

وبعد ذلك، انتقل إلى القسم "هل عمل ذلك على إصلاح المشكلة؟".



دعني أقوم بتصليحها بنفسي

لتغيير إعداد المهلة الافتراضية لبرنامج Internet Explorer في Internet Explorer 4.0 Service Pack 1 (SP1) أو إصدار حديث، اتبع تلك الخطوات:
  1. ابدأ تشغيل "محرر التسجيل".
  2. حدد موقع المفتاح الفرعي التالي:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. في هذا المفتاح الافتراضي، قم بإضافةاستلام انتهاء المهلة إدخال DWORD به قيمة (<عدد الثواني>)*1000. علي سبيل المثال، إذا كنت تريد مدة انتهاء المهلة أن تكون 8 دقائق، قم بضبط قيمة إدخال استلام انتهاء المهلة إلى 480000 (<480>*1000).
  4. قم بإعادة تشغيل جهاز الكمبيوتر.
ملحوظة يصبح هذا الإعداد مهلة انتهاء عامة تنطبق على كلاً من Internet Explorer وأي تطبيق WinINet.

هل عمل ذلك على إصلاح المشكلة؟

  • تحقق مما إذا كان قد تم إصلاح المشكلة أم لا. في حالة إصلاح المشكلة، فلا يتطلب الأمر إكمال قراءة هذا القسم. في حالة عدم إصلاح المشكلة، يمكنك الاتصال بالدعم.
  • نحن نقدّر إرسالك لأية ملاحظات. لتقديم ملاحظات أو الإبلاغ عن المشكلات التي تحدث مع هذا الحل، الرجاء كتابة تعليق بالمدوّنة "إصلاح المشكلة بالإنابة عني" أو إرسال رسالة بريد إلكتروني إلينا.

مراجع

لمزيد من المعلومات حول كيفية تطوير الحلول التي تستند إلى ويب لبرنامج Internet Explorer، قم بزيارة مواقع Microsoft التالية على الويب:
http://msdn.microsoft.com/ie/

http://support.microsoft.com/iep

الخصائص

معرف المقالة: 181050 - تاريخ آخر مراجعة: 08/ربيع الثاني/1433 - مراجعة: 5.0
تنطبق على
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
كلمات أساسية: 
kbenv kberrmsg kbnavigation kbprb kbmsifixme kbfixme KB181050

إرسال ملاحظات

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com