Id. de artículo: 181050 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E181050
Expandir todo | Contraer todo

Síntomas

Cuando se conecta a un sitio web que se ejecuta durante un momento antes de devolver información a Internet Explorer, puede recibir un mensaje de error similar a los siguientes.

Mensaje de error 1
Error de Microsoft Internet Explorer 10060 agotado el tiempo de espera de la conexión.
Mensaje de error 2
Internet Explorer no puede abrir el sitio de Internet <dirección web>. Se ha superado el tiempo de espera para la operación.
Mensaje de error 3
No se puede mostrar la página. No se pudo encontrar el servidor o error DNS.

Causa

Internet Explorer impone un límite de tiempo de espera para que el servidor devuelva los datos. De manera predeterminada, el límite de tiempo de espera es el siguiente:
Contraer esta tablaAmpliar esta tabla
Internet Explorer 4.0 e Internet Explorer 4.015 minutos
Internet Explorer 5.x e Internet Explorer 6.x60 minutos
Internet Explorer 7 e Internet Explorer 860 minutos

Internet Explorer no espera eternamente a que aquellos servidores que experimentan problemas devuelvan datos.



Las aplicaciones que utilizan la API de WinINet experimentarán directamente los siguientes valores para ReceiveTimeout:

Contraer esta tablaAmpliar esta tabla
WinINet.dll versión 4.x5 minutos
WinINet.dll versiones 5.x y 6.x60 minutos
WinINet.dll versiones 7.x y 8.x30 segundos

Puede encontrar la versión de WinINet.dll en el directorio %windir%\system32.




Solución

Si una página no devuelve datos en unos minutos, muchos usuarios perciben que se ha producido un problema y detienen el proceso. Por tanto, debería diseñar sus procesos de servidor para devolver los datos en un plazo aproximado de cinco minutos para que los usuarios no tengan que esperar mucho tiempo.

Normalmente, puede dividir los procesos largos en partes más pequeñas. O el servidor puede devolver datos de estado para proporcionar información actualizada a los usuarios acerca del proceso. Además, puede crear un proceso de servidor largo con un enfoque basado en mensajes o asincrónico de modo que devuelva datos inmediatamente al cliente una vez enviado el trabajo e informe a los usuarios cuando el proceso largo haya finalizado.

Más información

Importante Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, la modificación incorrecta del Registro puede producir graves problemas. Por tanto, asegúrese de seguir estos pasos cuidadosamente. Para obtener mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera, puede restaurar el Registro si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad del Registro y restaurarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows
Aunque Microsoft no aconseja esta solución, puede cambiar la configuración de tiempo de espera predeterminada para Internet Explorer.

Para que cambiemos el valor de tiempo de espera predeterminado a 5 minutos para Internet Explorer, vaya a la sección "Solucionarlo en mi lugar" Si prefiere solucionar este problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar



Para solucionar el problema de forma automática, haga clic en el vínculo o en el botón gráfico Fix it. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente Fix it.


Solucionar este problema
Microsoft Fix it 50600

Notas
  • Esta corrección automática cambiará el valor de tiempo de espera predeterminado a 5 minutos para Internet Explorer.
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con otras versiones de idioma de Windows. 
  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarla en el equipo con el problema.

A continuación, vaya a la sección "¿Esta información le ayudó a resolver su problema?".



Solucionarlo por mí mismo

Para cambiar el valor de tiempo de espera predeterminado para Internet Explorer en Internet Explorer 4.0 Service Pack 1 (SP1) o una versión posterior, siga estos pasos:
  1. Inicie el Editor del Registro.
  2. Busque la subclave siguiente:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. En esta subclave, agregue una entrada DWORD ReceiveTimeout que tenga un valor de (<número de segundos>)*1000. Por ejemplo, si desea que el tiempo de espera sea de 8 minutos, establezca el valor de la entrada ReceiveTimeout en 480000 (<480>*1000).
  4. Reinicie el equipo.
Nota: este valor pasará a ser el nuevo tiempo de espera global que se aplicará a Internet Explorer y a cualquier aplicación de WinINet.

¿Esta información le ayudó a resolver el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.
  • Valoramos sus comentarios. Para realizar algún comentario o informar de cualquier problema con esta solución, deje su comentario en el blog "Solucionarlo en mi lugar" o envíenos un correo electrónico.

Referencias

Para obtener más información acerca de cómo desarrollar soluciones basadas en web para Internet Explorer, visite los siguientes sitios web de Microsoft:
http://msdn.microsoft.com/es-es/ie/

http://support.microsoft.com/iep

Propiedades

Id. de artículo: 181050 - Última revisión: jueves, 1 de marzo de 2012 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Palabras clave: 
kbenv kberrmsg kbnavigation kbprb kbmsifixme kbfixme KB181050

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com