ข้อผิดพลาดของ Internet Explorer "หมดเวลาเชื่อมต่อ" เมื่อเซิร์ฟเวอร์ไม่ตอบสนอง

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 181050 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณเชื่อมต่อกับเว็บไซต์ที่เรียกใช้ได้เพียงครู่หนึ่งก่อนส่งคืนข้อมูลไปยัง Internet Explorer คุณอาจได้รับข้อความแสดงข้อผิดพลาดข้อความใดข้อความหนึ่งต่อไปนี้

ข้อความแสดงข้อผิดพลาด 1
ข้อผิดพลาดของ Microsoft Internet Explorer 10060 หมดเวลาการเชื่อมต่อ
ข้อความแสดงข้อผิดพลาด 2
Internet Explorer ไม่สามารถเปิด <ที่อยู่เว็บ> ในไซต์อินเทอร์เน็ต การดำเนินการหมดเวลา
ข้อความแสดงข้อผิดพลาด 3
ไม่สามารถแสดงเพจได้ ไม่พบเซิร์ฟเวอร์หรือข้อผิดพลาดของ DNS

สาเหตุ

Internet Explorer จำกัดการหมดเวลาของเซิร์ฟเวอร์ในการส่งคืนข้อมูล โดยค่าเริ่มต้น ขีดจำกัดการหมดเวลาถูกกำหนดไว้ดังนี้:
ยุบตารางนี้ขยายตารางนี้
Internet Explorer 4.0 และ Internet Explorer 4.015 นาที
Internet Explorer 5.x และ Internet Explorer 6.x60 นาที
Internet Explorer 7 และ Internet Explorer 860 นาที

เมื่อเซิร์ฟเวอร์ประสบปัญหา Internet Explorer ไม่รอจนเซิร์ฟเวอร์ส่งคืนข้อมูลเสร็จสิ้น



โปรแกรมประยุกต์ที่ใช้ WinINet API โดยตรงจะพบค่า ReceiveTimeout ดังนี้:

ยุบตารางนี้ขยายตารางนี้
WinINet.dll รุ่น 4.x5 นาที
WinINet.dll versions 5.x และ 6.x60 นาที
WinINet.dll รุ่น 7.x และ 8.x30 วินาที

คุณสามารถค้นหารุ่น WinINet.dll ได้ในไดเรกทอรี %windir%\system32




การแก้ไข

หากเพจไม่แสดงภายในสองสามนาที ผู้ใช้หลายรายอาจรับรู้ว่าเกิดปัญหาขึ้นและหยุดการดำเนินการ ดังนั้น คุณควรออกแบบกระบวนการเซิร์ฟเวอร์ให้ส่งคืนข้อมูลภายในเวลาประมาณห้านาทีเพื่อไม่ให้ผู้ใช้รอนาน

โดยทั่วไป คุณสามารถแบ่งกระบวนการเป็นกระบวนการย่อยหลายกระบวนการได้ หรือเซิร์ฟเวอร์สามารถส่งคืนข้อมูลสถานะเพื่อปรับปรุงผู้ใช้เกี่ยวกับกระบวนการ นอกจากนี้ คุณยังสามารถสร้างกระบวนการเซิร์ฟเวอร์ที่ใช้เวลานานโดยใช้วิธีแสดงข้อความหรือตรวจสอบความไม่สอดคล้อง เพื่อให้เซิร์ฟเวอร์ส่งคืนข้อมูลไปยังผู้ใช้ทันทีหลังจากส่งงานและแจ้งให้ผู้ใช้ทราบหลังจากกระบวนการนี้เสร็จสิ้น

ข้อมูลเพิ่มเติม

ข้อสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนต่างๆ เกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม อาจเกิดปัญหาร้ายแรงได้หากคุณแก้ไขรีจิสทรีไม่ถูกต้อง ดังนั้น ตรวจสอบว่าคุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง เพื่อเพิ่มการป้องกัน ให้สำรองข้อมูลรีจิสทรีก่อนแก้ไข จากนั้น คุณอาจกู้คืนรีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองและกู้คืนรีจิสทรี คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
322756 วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows
ถึงแม้ว่า Microsoft จะไม่สนับสนุนวิธีการนี้ แต่คุณสามารถเปลี่ยนแปลงการตั้งค่าหมดเวลาเริ่มต้นสำหรับ Internet Explorer ได้

ถ้าต้องการให้เราเปลี่ยนแปลงการตั้งค่าหมดเวลาเริ่มต้นของ Internet Explorer เป็น 5 นาที ไปที่ส่วน "แก้ไขปัญหาให้ฉัน" ถ้าคุณต้องการแก้ไขปัญหานี้ด้วยตนเอง โปรดไปที่ส่วน "ให้ฉันแก้ไขปัญหาด้วยตนเอง"

แก้ไขปัญหาให้ฉัน



เมื่อต้องการแก้ไขปัญหานี้โดยอัตโนมัติ ให้คลิกที่ปุ่มหรือการเชื่อมโยง แก้ไขปัญหา คลิก เรียกใช้ ในกล่องโต้ตอบ ดาวน์โหลดแฟ้ม และปฏิบัติตามขั้นตอนในตัวช่วยสร้างแก้ไขปัญหา


แก้ไขปัญหานี้
Microsoft Fix it 50600

หมายเหตุ
  • การแก้ไขอัตโนมัตินี้จะเปลี่ยนแปลงการตั้งค่าหมดเวลาเริ่มต้นเป็น 5 นาทีสำหรับ Internet Explorer
  • ตัวช่วยสร้างนี้อาจมีเฉพาะภาษาอังกฤษ อย่างไรก็ตาม การแก้ไขอัตโนมัติจะทำงานกับ Windows รุ่นภาษาอื่นด้วย
  • ถ้าคุณไม่ได้อยู่ที่เครื่องคอมพิวเตอร์ที่เกิดปัญหา ให้บันทึกวิธีการ แก้ไขปัญหา ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้บนคอมพิวเตอร์ที่เกิดปัญหา

จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



ให้ฉันแก้ไขด้วยตนเอง

ถ้าต้องการเปลี่ยนแปลงการตั้งค่าหมดเวลาเริ่มต้นของ Internet Explorer ใน Internet Explorer 4.0 Service Pack 1 (SP1) ขึ้นไป ให้ทำตามขั้นตอนต่อไปนี้:
  1. เริ่มตัวแก้ไขรีจิสทรี
  2. ค้นหาคีย์ย่อยต่อไปนี้:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. ในคีย์ย่อยนี้ เพิ่มข้อมูล ReceiveTimeout DWORD ที่มีค่า (<จำนวนวินาที>)*1000 เช่น ถ้าคุณต้องการเปลี่ยนแปลงการตั้งค่าหมดเวลาเป็น 8 นาที ตั้งค่าข้อมูล ReceiveTimeout เป็น 480000 (<480>*1000)
  4. รีสตาร์ทคอมพิวเตอร์
หมายเหตุ การตั้งค่านี้จะส่งผลให้ค่าหมดเวลาที่ใช้กับ Internet Explorer และแอพพลิเคชันของ WinINet ทั้งหมดเปลี่ยนเป็นค่าหมดเวลาใหม่

วิธีนี้แก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่าปัญหาได้รับการแก้ไขแล้วหรือไม่ ถ้าปัญหาได้รับการแก้ไขแล้ว คุณดำเนินการส่วนนี้เสร็จสิ้นแล้ว ถ้าปัญหาไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน
  • เรายินดีรับคำติชมของคุณ หากต้องการส่งคำติชม หรือรายงานปัญหาใดๆ พร้อมกับการแก้ไขปัญหานี้ โปรดเขียนข้อคิดเห็นไว้ที่บล็อก "แก้ไขปัญหาให้ฉัน" หรือส่ง อีเมล มาให้เรา

ข้อมูลอ้างอิง

หากต้องการข้อมูลเพิ่มเติมเกี่ยวกับวิธีการพัฒนาการแก้ไขปัญหาบนเว็บสำหรับ Internet Explorer เยี่ยมชมเว็บไซต์ Microsoft ต่อไปนี้:
http://msdn.microsoft.com/ie/

http://support.microsoft.com/iep

คุณสมบัติ

หมายเลขบทความ (Article ID): 181050 - รีวิวครั้งสุดท้าย: 27 กุมภาพันธ์ 2555 - Revision: 4.0
ใช้กับ
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Keywords: 
kbenv kberrmsg kbnavigation kbprb kbmsifixme kbfixme KB181050

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com