WD97: Was zu erledigen, wenn ein Makrovirus ist

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 181079 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Der erste Makrovirus wurde im Sommer 1995 entdeckt. Seit diesem Zeitpunkt haben andere Makroviren angezeigt. Dieser Artikel beschreibt Maßnahmen, wenn Sie denken möglicherweise haben Sie einen Word-Makrovirus, oder wenn Sie, dass sicherstellen möchten Ihre Dokumente nie werden infiziert mit einem.

Im folgenden werden einige Symptome von Word-Makrovirus, die bekanntermaßen Auswirkungen auf Word und Word-Dokumenten:

  • Wenn Sie versuchen, ein Dokument zu speichern, kann Word nur das Dokument als eine Vorlage speichern.
    -oder-
  • Das Symbol für die Datei sieht wie ein Dokument, sondern ein Vorlage.
    -oder-
  • Wenn Sie ein Dokument öffnen, wird ein Dialogfeld mit die Nummer 1.
    -oder-
  • Die Befehle von Makros und Anpassen nicht mehr angezeigt, auf die Tools im Menü.
    -oder-
  • Neue Makros in der Liste der Makros angezeigt. AutoOpen und FileSaveAs Makros möglicherweise auch angezeigt, wenn Sie bereits über Makros durch diese Namen hatten, deren Inhalt möglicherweise geändert wurden durch den Makrovirus.
    -oder-
  • Beim Öffnen eines Word ungewöhnlichen oder unerwartete Meldungen angezeigt Dokument oder Vorlage.
NOTES :

  • In Word 97 besteht eine Option Makrovirusschutz (mit den Tools klicken, klicken Sie auf Optionen, und auf die Registerkarte Allgemein) soll Sie warnen, wenn Sie eine Datei, Makros öffnen, unabhängig davon, was, die Makros tun enthält. Für eine dauerhafte Lösung müssen Sie Antivirus-Software verwenden, die speziell für erkennen und verhindern von Makroviren.

  • Word nicht suchen oder entfernen Sie alle Makroviren aus vorhandenen Dokumente und Vorlagen. Es wird einfach Sie gewarnt, die Wenn das Dokument öffnen, Makros enthält. Die Warnung können Sie entweder das Dokument mit den aktiven Makros öffnen oder mit deaktivierten Makros öffnen. Sie sollten ein Dokument nicht mit dem aktiven Makros öffnen, wenn Sie absolut sicher sind, dass das Dokument keine schädigenden Makroviren enthält.
Installieren Sie für eine langfristige Lösung zu Makroviren Anti-Virus Software, die speziell für die Makroviren erkennen. Weitere Informationen zu Anti-Virus Software von Drittanbietern erhältlich folgendem Artikel der Microsoft Knowledge Base:
49500Liste von Antivirussoftware-Herstellern

Abhilfe

Verwenden Sie die folgenden Problemumgehungen als nur interim-Lösungen.

Methode 1: Drücken Sie UMSCHALT, wenn Sie eine Datei öffnen

Wenn Sie nicht die in diesem Artikel beschriebenen Symptome besitzen, aber nicht durch ein Makrovirus beeinflusst werden möchten, halten Sie die UMSCHALTTASTE gedrückt, wenn Sie eine Datei öffnen, die durch ein Makrovirus betroffen sein könnten. Durch Drücken der UMSCHALTTASTE verhindert alle Makros automatisch ausgeführt wird, wenn ein Makrovirus vorhanden ist, wird nicht geladen.

Methode 2: Löschen Sie das Makro und Wiederherstellen Sie des Dokuments

Wenn Sie die in diesem Artikel aufgelisteten Symptome festgestellt haben oder wenn Sie vermuten, dass Sie einen Makrovirus verfügen, die hier nicht beschrieben wird, verwenden Sie die folgenden Schritte aus, um die problematische Makros und die richtige betroffenen Dokumente entfernen. (Denken Sie daran, dass dies nur eine temporäre Lösung ist, da neue Makros erstellt werden, diese Schritte funktionieren möglicherweise nicht):

  1. Schließen Sie Word und benennen Sie die Datei "Normal.dot" in Name.dot.
  2. Erstellen Sie eine Sicherungskopie von Kopie eine betroffene Datei.
  3. Öffnen Sie Word, und klicken Sie im Menü Datei auf Öffnen.
  4. Navigieren Sie zu dem Ordner mit der betroffene Datei.
  5. Klicken Sie auf die betroffene Datei.
  6. Drücken Sie und halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie auf Öffnen.

    Die UMSCHALTTASTE gedrückt halten weiter, bis die betroffene Datei in Word geöffnet ist.

    Hinweis : die UMSCHALTTASTE beim Öffnen einer Datei Holding verhindert Wörter automatische Makros ausgeführt.
  7. Um verdächtige Virus mit Makros zu entfernen, folgendermaßen Sie vor:
    1. Zeigen Sie im Menü Extras auf Makro, und klicken Sie auf Makros.
    2. Klicken Sie in der Liste Makros in auf alle Active Dokumentvorlagen und Dokumenten.
    3. Wählen Sie das fehlerverdächtige Makro, und klicken Sie auf Löschen. Klicken Sie auf Ja, wenn Sie gefragt, ob Sie das Makro löschen möchten.
    4. Wiederholen Sie die Schritt c für alle verdächtigen Makros.
    5. Klicken Sie auf Abbrechen oder die X, um das Dialogfeld Makros zu schließen.
  8. Um den Text eines infizierten Dokuments wiederherzustellen:
    1. Wählen Sie das gesamte Dokument durch Drücken von STRG + A oder indem Sie im Menü Bearbeiten auf Alles auswählen klicken.
    2. Löschen Sie letzte Absatzmarke des Dokuments aus der Auswahl durch Drücken von UMSCHALT + nach-links.
    3. Klicken Sie im Menü <UITerm>Bearbeiten</UITerm> auf <UITerm>Kopieren</UITerm>.
    4. Klicken Sie auf im Menü Datei auf neu. Wählen Sie die Vorlage, die Sie verwenden möchten, und klicken Sie auf OK.
    5. Klicken Sie im Menü <UITerm>Bearbeiten</UITerm> auf <UITerm>Einfügen</UITerm>.
    6. Wiederholen Sie die Schritt 7, um sicherzustellen, dass der Virus mit Makros erneut repliziert wurden.
    7. Speichern Sie das Dokument.
  9. Wiederholen Sie diese Schritte für alle fehlerverdächtig Dokument einen Makrovirus enthalten.
Hinweis : Wenn diese Methode nicht funktioniert, versuchen Sie Methode 3.

Methode 3: Verwenden Sie organisieren, um vorübergehend Makroviren bereinigen

Verwenden Sie das Dialogfeld Organisieren, um den Makrovirus zu reinigen. Bedenken Sie, dass andere Dateien nach der infizierten Datei geöffnet wurden, Sie wahrscheinlich sowie infiziert werden.

So entfernen Sie den Virus aus der normale Vorlage

  1. Schließen Sie alle Dokumente. Wenn eine infizierte Dokument geöffnet ist, können Sie problemlos Normal.dot reinfect.
  2. Klicken Sie auf Vorlagen und Add-Ins, und klicken Sie auf Organisieren, im Menü Extras.
  3. Wählen Sie die Registerkarte Makroprojektelemente und Umbenennen Sie oder löschen Sie alle der folgenden Makros:
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    Befehl
    FileSaveAs
    Makros
    ToolsMacro
  4. Klicken Sie auf Schließen.
  5. Drücken Sie UMSCHALT, und klicken Sie im Menü Datei Alles speichern, um die Vorlage zu speichern.
Um den Virus aus infizierten Dokumenten zu entfernen:

Wenn eine Datei infiziert ist, verwenden Sie die gleiche Methode wie oben, aber entfernen Sie die Makros aus beiden normale Vorlage und auch aus dem infizierten Dokument (Vorlage), während im Dialogfeld Organisieren. Wenn Sie fertig sind, drücken Sie UMSCHALT und auf dem Menü Datei und klicken Sie auf Speichern Sie alles, und fahren Sie mit der nächsten Datei. Bedenken Sie, dass bei jedem eine infizierte Datei öffnen es Ihre normale Vorlage infizieren wird ständig benötigen Sie die Makros aus der normale Vorlage zu entfernen.

Methode 4: Fügen Sie es in ein neues Dokument

Mit dieser Methode müssen Sie "Normal.dot" umbenennen und klicken Sie im Menü Einfügen auf Datei, um die Makros vorübergehend zu entfernen. Diese Methode ist besonders nützlich, mit der Makrovirus bezeichnet "CLIENTZUGRIFFSPUNKT", die Sie im Menü Extras Makro und anpassen entfernt.

Hinweis : in diesem Fall der Befehl Vorlagen und Add-Ins im Menü Extras funktioniert möglicherweise nicht.

  1. Schließen Sie Word und benennen Sie die Datei "Normal.dot" in Name.dot.
  2. Öffnen Sie Word und ob Makro- und anpassen auf die Tools sind im Menü.
  3. Öffnen Sie ein neues Dokument, und klicken Sie im Menü Einfügen auf Datei.
  4. Navigieren Sie zu dem Ordner mit der betroffene Datei.
  5. Klicken Sie auf die betroffene Datei.
  6. Drücken Sie und halten die UMSCHALTTASTE gedrückt, und klicken Sie auf OK.

    Die UMSCHALTTASTE gedrückt halten weiter, bis die betroffene Datei in Word geöffnet ist.

    Hinweis : die UMSCHALTTASTE beim Öffnen einer Datei Holding verhindert Wörter automatische Makros ausgeführt.
  7. Wenn in das neue Dokument keine Makros sind (sollte nicht es alle aufgeführten), zeigen Sie im Menü Extras auf Makro, und klicken Sie auf Makros. Klicken Sie in der Liste Makros in auf "Alle aktiven Dokumentvorlagen und Dokumente." Unter Makroname sollte nicht es alle Makros aufgeführt sind. Klicken Sie auf Abbrechen.
  8. Speichern Sie die Datei mit einem anderen Dateinamen.
  9. Löschen Sie die infizierte Datei.

Weitere Informationen

Ein Makrovirus ist ein Programm, in der Makrosprache eines Programms, wie Word geschrieben. Es verbreitet sich selbst zwischen Datendateien und Betriebssystem Ihres Computers oder Ihrer Dateien beschädigen kann.

Word-Makroviren nicht kostenlos über das Internet oder anderen Medien übertragen; Sie können nur übertragen werden, wenn ein Benutzer ein Dokument oder eine Vorlage, die das Makro Virus enthält, öffnet.

Microsoft Internet-Assistent und Dokumente erstellt oder gelesen werden kann nicht durch solche Makros beeinflusst werden. Internet-Assistent blockiert standardmäßig den Mechanismus, der den Makrovirus verteilt.

Makroviren können nicht von WordMail übertragen werden, wenn eine betroffene Dokument in der e-Mail-Nachricht eingebettet ist und der Empfänger das Dokument öffnet.

Eigenschaften

Artikel-ID: 181079 - Geändert am: Montag, 22. Januar 2007 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Word 97 Standard Edition
Keywords: 
kbmt kbfaq kbinfo kbvirus KB181079 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 181079
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Disclaimer zu nicht mehr gepflegten KB-Inhalten
Dieser Artikel wurde für Produkte verfasst, für die Microsoft keinen Support mehr anbietet. Der Artikel wird deshalb in der vorliegenden Form bereitgestellt und nicht mehr weiter aktualisiert.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com