WD97: Qué hacer si tiene un virus de macro

Seleccione idioma Seleccione idioma
Id. de artículo: 181079 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

El primer virus de macro se descubrió en el verano de 1995. Desde ese momento, han aparecido otros virus de macro. En este artículo se describe cómo proceder si cree que tiene un virus de macro de Word o si desea evitar que sus documentos se infecten con uno.

A continuación se muestran algunos síntomas de un virus de macro de Word que se sabe que afectan a Word y a los documentos de Word:

  • Cuando intenta guardar un documento, Word sólo le deja guardar el documento como plantilla.
    -o bien -
  • El icono del archivo tiene el aspecto de una plantilla en lugar de un documento.
    -o bien -
  • Cuando abre un documento, aparece un cuadro de diálogo que muestra el número 1.
    -o bien -
  • No mostrar los comandos de macro y personalizar en las herramientas de menú.
    -o bien -
  • Nuevas macros aparecen en la lista de macros. Puede que también aparezcan las macros AutoOpen y FileSaveAs; si ya tenía macros con estos nombres, puede que el contenido haya sido modificado por el virus de macro.
    -o bien -
  • Aparecen mensajes extraños o inesperados cuando abre un documento o una plantilla de Word.
notas :

  • En Word 97 hay una opción de protección antivirus en macros (en el menú Herramientas, haga clic en Opciones y, haga clic en la ficha general) diseñado para avisarle si abre un archivo que contiene macros, independientemente de lo que las macros. Si desea una solución permanente, deberá utilizar software antivirus específicamente diseñado para detectar y evitar virus de macro.

  • Word no busca o quitar cualquier virus de macros de documentos existentes y plantillas. Simplemente le advierte si el documento que va a abrir contiene macros. Esta advertencia le permite abrir el documento con las macros activas o abrirlo con las macros deshabilitadas. No debería abrir un documento con las macros activas a menos que esté totalmente seguro de que el documento no contiene virus de macros que puedan dañar su equipo.
Para una solución a largo plazo a virus de macro, instalar software antivirus que está diseñado específicamente para detectar virus de macro. Para obtener información adicional acerca de proveedores terceros de software antivirus, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
49500Lista de proveedores de software antivirus

Solución

Utilice las siguientes soluciones de manera provisional únicamente.

Método 1: Presionar MAYÚS al abrir un archivo

Si no observa ninguno de los síntomas descritos en este artículo, pero no desea infectarse con un virus de macro, mantenga presionada la tecla MAYÚS cuando abra un archivo que podría estar infectado con un virus de macro. Si presiona MAYÚS evitará que se ejecuten las macros automáticas; si hay algún virus de macro presente, no se cargará.

Método 2: Eliminar la macro y recuperar el documento

Si ha observado los síntomas descritos en este artículo, o si sospecha que tiene un virus de macro que no se ha descrito aquí, siga los pasos indicados a continuación para quitar las macros infectadas y corregir los documentos afectados. (Recuerde que se trata únicamente de una solución temporal; debido a la continua creación de nuevas macros, puede que estos pasos no funcionen):

  1. Cierre Word y cambie el nombre del archivo normal.dot a nombre.dot.
  2. Realice una copia de seguridad de un archivo infectado.
  3. Abra Word y en el menú Archivo haga clic en Abrir.
  4. Explore la carpeta que contiene el archivo infectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y haga clic en Abrir.

    Continúe presionando la tecla MAYÚS hasta que el archivo infectado se abra en Word.

    Nota : la retención de la tecla MAYÚS mientras abre un archivo evita cualquiera de las macros automáticas palabras que se ejecute.
  7. Para quitar virus sospechosos que contienen macros, haga lo siguiente:
    1. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en macros.
    2. En la lista macros, haga clic en todas las plantillas activas y documentos.
    3. Seleccione la macro sospechosa y haga clic en <b>Eliminar</b>. Cuando se le pregunte si desea eliminar la macro, haga clic en Sí.
    4. Repita el paso c con todas las macros sospechosas.
    5. Haga clic en la x o en Cancelar para cerrar el cuadro de diálogo de macros.
  8. Para recuperar el texto de un documento infectado:
    1. Seleccione todo el documento presionando CTRL+E, o haciendo clic en Seleccionar todo en el menú Edición.
    2. Eliminar marca de párrafo final del documento de la selección presionando MAYÚS+flecha izquierda.
    3. En el menú Edición, haga clic en copiar.
    4. En el menú Archivo, haga clic en nuevo. Seleccione la plantilla que desea utilizar y haga clic en <b>Aceptar</b>.
    5. En el menú Edición, haga clic en Pegar.
    6. Repita el paso 7 para asegurarse de que no han replicado nuevo virus que contiene macros.
    7. Guarde el documento.
  9. Repita estos pasos para cualquier sospechosa de documento del que contiene un virus de macro.
Nota : si este método no funciona, pruebe el método 3.

Método 3: Utilizar el Organizador para limpiar temporalmente los virus de macro

Utilizar el Organizador para limpiar el virus de macro. Recuerde que si se han abierto otros archivos después del archivo infectado, probablemente también estarán infectados.

Para quitar el virus de la plantilla normal:

  1. Cierre todos los documentos. Si está abierto un documento infectado, lo puede reinfect fácilmente normal.dot.
  2. En el menú Herramientas, haga clic en plantillas y complementos y haga clic en el botón Organizador.
  3. Seleccione la ficha macros y cambiar el nombre o eliminar todas las macros siguientes:
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    ArchivoGuardar
    FileSaveAs
    Macros
    ToolsMacro
  4. Haga clic en Cerrar.
  5. Presione la tecla MAYÚS y, en el menú Archivo, haga clic en Guardar todo para guardar la plantilla.
Para quitar el virus de los documentos infectados:

Si un archivo está infectado, utilizar el mismo método como se indicó anteriormente, pero quitar las macros de ambos en la plantilla Normal y también desde el documento infectado (plantilla) mientras en el organizador. Cuando haya terminado, presione MAYÚS y en el menú archivo y haga clic en Guardar todo y continuar con el siguiente archivo. Tenga en cuenta que cada vez que abra un archivo infectado infectará su plantilla Normal, por lo que constantemente tiene que quitar las macros de la plantilla Normal.

Método 4: Insertar IT en un documento nuevo

Con este método, deberá cambiar el nombre de normal.dot y, en el menú Insertar, haga clic en archivo para quitar temporalmente las macros. Este método es particularmente útil con el virus de macro denominados "CAP", que quita macro y personalizar en el menú Herramientas.

Nota : en esta situación, el comando plantillas y complementos en el menú Herramientas no es posible que funcione.

  1. Cierre Word y cambie el nombre del archivo normal.dot a nombre.dot.
  2. Abra Word y compruebe que <B>Macro</B> y <B>Personalizar</B> se encuentran en el menú <B>Herramientas</B>.
  3. Abra un documento nuevo y en el menú Insertar, haga clic en archivo.
  4. Explore la carpeta que contiene el archivo infectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y haga clic en Aceptar.

    Continúe presionando la tecla MAYÚS hasta que el archivo infectado se abra en Word.

    Nota : la retención de la tecla MAYÚS mientras abre un archivo evita cualquiera de las macros automáticas palabras que se ejecute.
  7. Para ver si hay macros en el nuevo documento (no debería haber ninguna enumerados), elija Macro en el menú Herramientas y, a continuación, haga clic en macros. Haga clic en la lista macros, en todas las plantillas activas y documentos." En nombre de macro, no debería haber macros enumeradas. Haga clic en Cancelar.
  8. Guarde el archivo con un nombre distinto.
  9. Elimine el archivo infectado.

Más información

Un virus de macro es un programa escrito en el lenguaje de macros de un programa, como Word. Se propaga entre archivos de datos y puede dañar sus archivos o el sistema operativo del equipo.

Los virus de macro de Word no viajan libremente por Internet ni por otros medios; únicamente pueden transmitirse cuando un usuario abre un documento o una plantilla que contiene el virus de macro.

El Ayudante para Internet de Microsoft y los documentos que éste crea o lee no pueden infectarse con estas macros. El Ayudante para Internet, por su diseño, bloquea los mecanismos que distribuyen los virus de macro.

Los virus de macro no pueden transmitirse mediante WordMail a menos que un documento infectado esté incrustado en el mensaje de correo electrónico y el destinatario abra ese documento.

Propiedades

Id. de artículo: 181079 - Última revisión: lunes, 22 de enero de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Word 97 Standard Edition
Palabras clave: 
kbmt kbfaq kbinfo kbvirus KB181079 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 181079
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com