WD97 : Procédures à suivre en cas de virus de macro

Traductions disponibles Traductions disponibles
Numéro d'article: 181079 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F181079
Agrandir tout | Réduire tout

Sommaire

Symptômes

Le premier virus de macro a été découvert en 1995. D'autres virus de ce type ont été détectés depuis. Le présent article décrit la procédure à suivre si vous pensez que votre système est infecté par un virus de macro Word ou si vous voulez protéger vos documents de tout risque d'infection.

Les problèmes suivants indiquent que votre installation Microsoft Word ou vos documents Word sont infectés par un virus de macro Word :

  • Lorsque vous essayez d'enregistrer un document, Microsoft Word vous permet uniquement d'enregistrer celui-ci en tant que modèle.
    - ou -
  • L'icône du fichier a l'apparence d'un modèle et non d'un document.
    - ou -
  • Lorsque vous ouvrez un document, une boîte de dialogue contenant le chiffre 1 s'affiche.
    - ou -
  • Les commandes Macro et Personnaliser ne s'affichent plus dans le menu Outils.
    - ou -
  • De nouvelles macros s'affichent dans la liste des macros. Les macros AutoOpen et FileSaveAs peuvent également s'afficher ; si des macros portant ces noms existaient déjà, il est possible que leur contenu ait été modifié par le virus de macro.
    - ou -
  • Des messages insolites ou inattendus s'affichent lorsque vous ouvrez un modèle ou un document Microsoft Word.
REMARQUES :

  • Microsoft Word 97 offre l'option Activer l'alerte macro (dans le menu Outils, cliquez sur Options, puis sur l'onglet Général), qui affiche un avertissement à chaque fois que vous ouvrez un fichier contenant des macros, quelle que soit leurs fonctions. Si vous souhaitez disposer d'une solution permanente, utilisez un logiciel antivirus conçu spécialement pour la détection et la suppression des virus de macro.

  • Microsoft Word ne recherche pas et ne supprime pas les virus de macro dans les documents ou modèles existants. L'application se contente de vous avertir que le document que vous ouvrez contient des macros. Cet avertissement vous autorise à ouvrir le document en activant ou en désactivant les macros. Évitez d'ouvrir un document en activant les macros à moins que vous ne soyez absolument certain que celui-ci ne contient aucun virus macro nuisible.
Si vous souhaitez disposer d'une protection permanente contre les virus de macro, installez un antivirus conçu spécialement pour la détection des virus de macro. Pour plus d'informations sur les éditeurs de logiciels antivirus, y compris les logiciels de détection et de suppression des virus de macro, consultez l'article suivant dans la Base de connaissances :
49500 Éditeurs de logiciels antivirus

Contournement

Utilisez les solutions de contournement ci-dessous à titre provisoire seulement.

Méthode 1 : Appuyer sur la touche MAJ à l'ouverture d'un fichier

Bien que vous n'observiez aucun des indices décrits dans cet article, mais que vous souhaitez éviter toute infection par un virus de macro, maintenez la touche MAJ enfoncée tout en ouvrant un fichier susceptible d'être infecté par un virus de macro. Vous empêchez ainsi l'exécution de toute macro automatique ; si un virus de macro est présent, il ne sera pas chargé.

Méthode 2 : Supprimer la macro et récupérer le document

Si vous observez l'un des problèmes décrits dans cet article ou si vous soupçonnez la présence d'un virus de macro non décrit ici, procédez de la manière suivante pour supprimer les macros incriminées et nettoyer les documents infectés. (N'oubliez pas qu'il s'agit d'une solution provisoire ; étant donné que de nouvelles macros sont créées, il est possible que cette procédure ne soit pas efficace) :

  1. Fermez Microsoft Word et renommez le fichier Normal.dot en Name.dot.
  2. Effectuez une copie de sauvegarde d'un fichier infecté.
  3. Ouvrez Microsoft Word puis, dans le menu Fichier, cliquez sur Ouvrir.
  4. Placez-vous dans le dossier contenant le fichier infecté.
  5. Cliquez sur ce fichier pour le sélectionner.
  6. Appuyez sur la touche MAJ et, tout en la maintenant enfoncée, cliquez sur Ouvrir.

    Maintenez la touche MAJ enfoncée tant que le fichier infecté n'est pas ouvert dans Microsoft Word.

    REMARQUE : Maintenir la touche MAJ enfoncée pendant l'ouverture d'un fichier empêche l'exécution de toute macro automatique contenue dans ce fichier.
  7. Pour supprimer toute macro soupçonnée de contenir un virus, procédez de la manière suivante :
    1. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.
    2. Dans la liste Macros disponibles dans, cliquez sur Tous les modèles actifs.
    3. Sélectionnez la macro suspecte, puis cliquez sur Supprimer. Lorsque vous y êtes invité, cliquez sur Oui pour supprimer la macro.
    4. Répétez l'étape c pour toutes les macros suspectes.
    5. Cliquez sur Annuler ou sur X pour fermer la boîte de dialogue Macros.
  8. Pour récupérer le texte dans un document infecté :
    1. Sélectionnez l'ensemble du document en appuyant sur CTRL+A ou en cliquant sur Sélectionner tout dans le menu Edition.
    2. Supprimez de la sélection la marque de paragraphe final du document en appuyant sur MAJ+Flèche gauche.
    3. Dans le menu Edition, cliquez sur Copier.
    4. Dans le menu Fichier, cliquez sur Nouveau. Sélectionnez le modèle à utiliser, puis cliquez sur OK.
    5. Dans le menu Edition, cliquez sur Coller.
    6. Répétez l'étape 7 pour vous assurer que les macros contenant des virus n'ont pas été répliquées encore une fois.
    7. Enregistrez le document.
  9. Répétez ces étapes pour tout document soupçonné de contenir un virus de macro.
REMARQUE : Si cette méthode ne donne aucun résultat, essayez la méthode 3.

Méthode 3 : Supprimer provisoirement les virus de macro à l'aide de l'Organisateur

Supprimez les virus de macro à l'aide de l'Organisateur. N'oubliez pas que si d'autres fichiers ont été ouverts après le fichier infecté, il est fort probable qu'ils soient également infectés.

Pour supprimer les virus du modèle Normal :

  1. Fermez tous les documents. Si un document infecté est ouvert, il peut facilement réinfecter le modèle Normal.dot.
  2. Dans le menu Outils, cliquez sur Modèles et compléments, puis sur le bouton Organiser.
  3. Sélectionnez l'onglet Macros, puis renommez ou supprimez toutes les macros suivantes :
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    FileSave
    FileSaveAs
    Macros
    ToolsMacro
  4. Cliquez sur Fermer.
  5. Appuyez sur la touche MAJ puis, dans le menu Fichier, cliquez sur Enregistrer tout pour enregistrer le modèle.
Pour supprimer les virus des documents infectés :

Si un fichier est infecté, procédez de la même manière que ci-dessus mais supprimez les macros du modèle Normal et du document infecté (modèle) dans l'Organisateur. Une fois que vous avez terminé, appuyez sur la touche MAJ puis, dans le menu Fichier, cliquez sur Enregistrer tout. Passez alors au fichier suivant. N'oubliez pas que chaque fois que vous ouvrez un fichier infecté, votre modèle Normal sera également infecté. Par conséquent, vous devez systématiquement supprimer les macros du modèle Normal.

Méthode 4 : Insérer le fichier infecté dans un nouveau document

Cette méthode implique que vous renommiez le modèle Normal.dot puis, dans le menu Insertion, que vous cliquiez sur Fichier pour supprimer temporairement les macros. Cette méthode est particulièrement utile avec le virus de macro " CAP " qui supprime les options Macro et Personnaliser du menu Outils.

REMARQUE : Dans ce cas, il est possible que la commande Modèles et compléments, dans le menu Outils, ne fonctionne pas.

  1. Fermez Microsoft Word et renommez le fichier Normal.dot en Name.dot.
  2. Ouvrez Microsoft Word et vérifiez que les options Macro et Personnaliser figurent dans le menu Outils.
  3. Ouvrez un nouveau document puis, dans le menu Insertion, cliquez sur Fichier.
  4. Placez-vous dans le dossier contenant le fichier infecté.
  5. Cliquez sur celui-ci pour le sélectionner.
  6. Appuyez sur la touche MAJ et maintenez-la enfoncée tout en cliquant sur OK.

    Maintenez la touche MAJ enfoncée tant que le fichier infecté n'est pas ouvert dans Microsoft Word.

    REMARQUE : En maintenant la touche MAJ enfoncée pendant que vous ouvrez un fichier, vous empêchez l'exécution des macros automatiques Word.
  7. Pour voir si le nouveau document contient des macros éventuelles (il ne devrait en contenir aucune), pointez sur Macro dans le menu Outils, puis cliquez sur Macros. Dans la liste Macros disponibles dans, cliquez sur " Tous les modèles et documents actifs ". Le champ Nom de la macro ne doit contenir aucune macro. Cliquez sur Annuler.
  8. Enregistrez le fichier sous un autre nom.
  9. Supprimez le fichier infecté.

Plus d'informations

Un virus de macro est un programme écrit dans le langage macro d'un programme, comme Microsoft Word. Ce virus se propage aux fichiers de données et peut endommager vos fichiers ou le système d'exploitation installé sur votre ordinateur.

Les virus de macro Word ne sont pas librement transmis sur Internet ou sur un autre support. Ils sont transmis uniquement lorsqu'un utilisateur ouvre un document ou un modèle contenant le virus de macro.

L'Assistant Internet pour Microsoft et les documents créés ou lus par ce programme ne peuvent pas être affectés par de telles macros. L'Assistant Internet est conçu pour bloquer le mécanisme de distribution des virus de macro.

Les virus de macro ne peuvent pas être transmis par WordMail à moins qu'un document infecté ne soit incorporé dans le message électronique et que le destinataire ouvre le document.

Propriétés

Numéro d'article: 181079 - Dernière mise à jour: vendredi 1 septembre 2006 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 97 Standard Edition
Mots-clés : 
kbdta kbvirus KB181079
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com