WD97: Cosa fare se si dispone di un virus macro

Traduzione articoli Traduzione articoli
Identificativo articolo: 181079 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Il primo virus macro Ŕ stato rilevato nell'estate del 1995. Da allora, sono visualizzati altri virus macro. In questo articolo viene descritto che cosa fare se si ritiene che si dispone di un virus macro di Word, oppure se si desidera assicurarsi che i documenti non diventano infettati uno.

Di seguito sono alcuni sintomi di un virus macro di Word che influiscono su Word e in Word documenti:

  • Quando si tenta di salvare un documento, Word solo consente di salvare il documento come un modello.
    - oppure -
  • L'icona per il file apparirÓ come un modello anzichÚ di un documento.
    - oppure -
  • Quando si apre un documento, viene visualizzata una finestra di dialogo che mostra il numero 1.
    - oppure -
  • Non visualizzare i comandi di macro e personalizzare gli strumenti non Ŕ pi¨ menu.
    - oppure -
  • Nuove macro visualizzato nell'elenco di macro. AutoOpen e FileSaveAs macro anche possono seguire, se si dispone giÓ di macro da questi nomi, il contenuto potrebbe essere stato modificato dal virus macro.
    - oppure -
  • I messaggi inusuali o imprevisti vengono visualizzati quando si apre una parola documento o modello.
NOTES :

  • In Word 97 Ŕ disponibile un'opzione di protezione da virus macro (scegliere Opzioni dal menu, scegliere Opzioni e fare clic sulla scheda Generale) progettato per avvisare l'utente se si apre un file contenente macro, indipendentemente da cosa le macro. Per una soluzione permanente, Ŕ necessario utilizzare software antivirus, Ŕ progettato specificatamente per rilevare e prevenire i virus delle macro.

  • Word non cercare o rimuovere eventuali virus macro da documenti esistenti e modelli. Esso verrÓ semplicemente informare se il documento che si sta aprendo contiene delle macro. Il messaggio di avviso consente di aprire il documento con le macro attive o di aprirlo con le macro disattivate. Non Ŕ consigliabile aprire un documento con le macro attivo se non si Ŕ assolutamente certi che il documento non contenga alcun virus macro dannosi.
Per una soluzione a lungo termine per i virus delle macro, installare software antivirus progettato per rilevare i virus delle macro. Per ulteriori informazioni sui software antivirus disponibili presso fornitori terze parti, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
49500Elenco di fornitori di software antivirus

Workaround

Utilizzare le soluzioni alternative descritte di seguito come solo soluzioni provvisori.

Metodo 1: Premere MAIUSC quando si apre un file

Se non si dispone di uno dei sintomi descritti in questo articolo, ma non si desidera essere interessati da un virus macro, tenere premuto il tasto MAIUSC quando si apre un file che potrebbe essere interessato da un virus macro. Premendo MAIUSC impedirÓ qualsiasi macro automatiche in esecuzione, se un virus macro Ŕ presente, esso non verrÓ caricato.

Metodo 2: Elimina la macro e ripristino del documento

Se si sono verificato i sintomi elencati in questo articolo, oppure se si ritiene che sia di un virus macro che non Ŕ descritto di seguito, Ŕ possibile utilizzare la procedura seguente per rimuovere le macro che causano problemi e documenti interessati corretti. (Tenere presente che si tratta solo una soluzione temporanea, poichÚ vengono create nuove macro, questa procedura non funzionino):

  1. Chiudere Word e rinominare il file Normal.dot Name.dot.
  2. Creare una copia di backup di un file interessato.
  3. Aprire Word e dal menu file fare clic su Apri.
  4. Passare alla cartella contenente il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e scegliere Apri.

    Continuare a tenere premuto MAIUSC finchÚ non viene aperto il file interessato.

    Nota : esecuzione con il tasto MAIUSC durante l'apertura di un file mantiene le macro automatiche di parole.
  7. Per rimuovere virus sospetto contenente macro, effettuare le seguenti operazioni:
    1. Scegliere Macro dal menu Strumenti, quindi macro.
    2. Nell'elenco macro in, fare clic su tutti i modelli Active e documenti.
    3. Selezionare la macro sospetta e fare clic su Elimina. Scegliere Sý quando viene chiesto se si desidera eliminare la macro.
    4. Ripetere il passaggio c per tutte le macro sospette.
    5. Fare clic su Annulla o x per chiudere la finestra di dialogo macro.
  8. Per recuperare il testo di un documento contenente virus:
    1. Selezionare l'intero documento premendo CTRL+5 (Tn) oppure facendo clic su Seleziona tutto dal menu Modifica.
    2. Per eliminare segno di paragrafo finale del documento dalla selezione, premere MAIUSC+freccia sinistra.
    3. Scegliere Copia dal menu Modifica.
    4. Scegliere Nuovo dal menu file. Selezionare il modello che si desidera utilizzare e fare clic su OK.
    5. Scegliere Incolla dal menu Modifica.
    6. Ripetere il passaggio 7 per garantire che le macro contenenti virus non siano state replicate nuovamente.
    7. Salvare il documento.
  9. Ripetere questi passaggi per qualsiasi sospetto di documento di contenere un virus macro.
Nota : questo metodo non funziona, provare a 3.

Metodo 3: Utilizzare la libreria per eliminare temporaneamente i virus delle macro

Utilizzare la libreria per pulire il virus macro. Tenere presente che se altri file sono stati aperti dopo il file infetto, che probabilmente verranno essere infetti nonchÚ.

Per rimuovere il virus dal modello normale:

  1. Chiudere tutti i documenti. Se Ŕ aperto un documento di infetto, facilmente possibile reinfect Normal.dot.
  2. Dal menu Strumenti, fare clic su modelli e aggiunte e fare clic sul pulsante libreria.
  3. Scegliere la scheda macro e rinominare o eliminare tutte le macro seguenti:
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    FileSalva
    FileSaveAs
    Macro
    ToolsMacro
  4. Fare clic su Chiudi.
  5. Premere MAIUSC e dal menu file, fare clic su Salva tutto per salvare il modello.
Per rimuovere il virus da documenti contenenti virus:

Se Ŕ stato infettato da un file, utilizzare lo stesso metodo descritto in precedenza, ma rimuovere le macro da entrambi il modello Normal sia dal documento (modello), mentre nella libreria infetto. Al termine, premere MAIUSC e il menu file e fare clic su Salva tutto e passare il file successivo. Tenere presente che ogni volta che si apre un file infetto verrÓ infettare il modello Normal, costantemente Ŕ necessario rimuovere le macro al modello Normal.

Metodo 4: ╚ possibile inserire IT in un nuovo documento

Con questo metodo, sarÓ necessario rinominare il file Normal.dot e quindi dal menu Inserisci, scegliere file per rimuovere temporaneamente le macro. Questo metodo Ŕ particolarmente utile con il virus macro denominata "CAP", che rimuove la macro e Personalizza dal menu Strumenti.

Nota : in questo caso, il comando modelli e aggiunte dal menu Strumenti non funzionino.

  1. Chiudere Word e rinominare il file Normal.dot Name.dot.
  2. Aprire Word e verificare che siano macro e personalizzare scegliere Opzioni dal menu.
  3. Aprire un nuovo documento e nel menu Inserisci, fare clic su file.
  4. Passare alla cartella contenente il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e fare clic su OK.

    Continuare a tenere premuto MAIUSC finchÚ non viene aperto il file interessato.

    Nota : esecuzione con il tasto MAIUSC durante l'apertura di un file mantiene le macro automatiche di parole.
  7. Per verificare se vi sono tutte le macro nel nuovo documento (non devono essere tutti elencati), scegliere Macro dal menu Strumenti e quindi fare clic su macro. Nell'elenco macro in fare clic su "tutti i modelli attivi e documenti. In Nome Macro non devono essere tutte le macro elencate. Fare clic su Annulla.
  8. Salvare il file con un nome di file diverso.
  9. Eliminare il file infetto.

Informazioni

Un virus macro Ŕ un programma scritto nel linguaggio macro di un programma, come in Word. Si propaga automaticamente tra i file di dati e pu˛ danneggiare i file o del sistema operativo.

Virus macro in Word non viaggi liberamente attraverso Internet o qualsiasi altro supporto, pu˛ essere trasferiti solo quando un utente apre un documento o modello che contiene la macro virus.

Microsoft Internet Assistant e i documenti creati o lettura da esso non pu˛ essere interessato da tali macro. Internet Assistant, per impostazione predefinita, blocca il meccanismo che distribuisce il virus macro.

Virus macro possono essere trasferiti da WordMail, a meno che non un documento interessato Ŕ incorporato nel messaggio di posta elettronica e il destinatario apre il documento.

ProprietÓ

Identificativo articolo: 181079 - Ultima modifica: lunedý 22 gennaio 2007 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Word 97 Standard Edition
Chiavi:á
kbmt kbfaq kbinfo kbvirus KB181079 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 181079
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Dichiarazione di non responsabilitÓ per articoli della Microsoft Knowledge Base su prodotti non pi¨ supportati
Questo articolo Ŕ stato scritto sui prodotti per cui Microsoft non offre pi¨ supporto. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com