WD97: O que fazer se tiver um vírus em macros

Traduções de Artigos Traduções de Artigos
Artigo: 181079 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

O primeiro vírus em macros foi descoberto no Verão de 1995. Desde esse momento, foram apresentadas outros vírus em macros. Este artigo descreve o que fazer se achar que pode ter um vírus em macros do Word ou se pretender certificar-se de que os documentos nunca ficam infectados com um.

Seguem-se alguns sintomas de um vírus em macros do Word que afectam o Word e o Word documentos:

  • Quando tenta guardar um documento, o Word só permite guardar o documento como um modelo.
    - ou -
  • O ícone para o ficheiro assemelha-se um modelo em vez de um documento.
    - ou -
  • Quando abre um documento, aparece uma caixa de diálogo que mostra o número 1.
    - ou -
  • Não mostrar os comandos de macro e personalizar as ferramentas de menu.
    - ou -
  • Novas macros aparecem na lista de macros. AutoOpen FileSaveAs e também podem aparecer macros; se já teve macros com estes nomes, respectivo conteúdo poderá foram alterado por vírus em macros.
    - ou -
  • Aparecem mensagens invulgares ou inesperadas quando abre uma palavra documento ou modelo.
notas :

  • No Word 97 não existe uma opção de protecção contra vírus de macro (no ferramentas, clique em Opções e, clique no separador Geral) concebido para alertá-lo se abrir um ficheiro que contém macros, independentemente de o fazer as macros. Para obter uma solução permanente, tem de utilizar software antivírus especificamente concebido para detectar e prevenir vírus em macros.

  • O Word não procure ou remova quaisquer vírus em macros de documentos existentes e modelos. É simplesmente avisa-se o documento que está a abrir contém macros. O aviso permite-lhe a abrir o documento com as macros activas ou abri-lo com macros desactivadas. Não deverá abrir um documento com macros activo sem tem a certeza absoluta de que o documento contém sem vírus em macros prejudiciais.
Para obter uma solução a longo prazo para vírus em macros, instale software antivírus especificamente concebido para detectar vírus de macros. Para mais informações sobre software antivírus disponível outros fabricantes, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
49500Lista de fornecedores de software anti-vírus

Como contornar

Utilize as seguintes soluções como apenas soluções temporárias.

Método 1: Premir SHIFT quando abre um ficheiro

Se não tiver nenhum dos sintomas descritos neste artigo, mas não pretende ser afectado por um vírus de macro, mantenha premida a tecla SHIFT quando abrir um ficheiro que poderá ser afectado por um vírus em macros. Premindo a tecla SHIFT impedirão macros automaticamente a ser executado; se existir um vírus em macros, este não será carregado.

Método 2: Eliminar a macro e recuperar o documento

Se tenha detectado os sintomas listados neste artigo ou suspeite de que tem um vírus de macro que não esteja descrito aqui, utilize os seguintes passos para remover macros infractor e correctos documentos afectados. (Lembre-se de que esta é apenas uma solução temporária; porque estão a ser criadas novas macros, estes passos poderão não funcionar):

  1. Feche o Word e mude o nome do ficheiro Normal.dot para Name.dot.
  2. Efectue uma cópia cópias de um ficheiro afectado.
  3. Abra o Word e no menu Ficheiro clique em abrir.
  4. Navegue para a pasta que contém o ficheiro afectado.
  5. Clique para seleccionar o ficheiro afectado.
  6. Prima e mantenha premida a tecla SHIFT e clique em abrir.

    Continue a manter a tecla SHIFT até que o ficheiro afectado seja aberto no Word.

    Nota : holding a tecla SHIFT enquanto abre um ficheiro mantém das macros automáticas de palavras a execução.
  7. Para remover o vírus suspeita que contenha macros, efectue o seguinte:
    1. No menu Ferramentas, aponte para macro e, em seguida, clique em macros.
    2. Na lista de macros em, clique em todos os modelos de Active Directory e documentos.
    3. Seleccione a macro suspeita e clique em Eliminar. Clique em Sim quando lhe for perguntado se pretende eliminar a macro.
    4. Repita o passo c para todas as macros suspeitas.
    5. Clique em ' Cancelar ' ou o x para fechar a caixa de diálogo macros.
  8. Para recuperar o texto de um documento infectado:
    1. Seleccione todo o documento premindo CTRL+T, ou clicando em Seleccionar tudo no menu Editar.
    2. Elimine marca de parágrafo final do documento a partir da selecção premindo SHIFT+seta para a esquerda.
    3. No menu Editar, clique em copiar.
    4. No menu Ficheiro, clique em novo. Seleccione o modelo que pretende utilizar e clique em OK.
    5. No menu Editar, clique em Colar.
    6. Repita o passo 7 para garantir que os que contêm vírus em macros não foram replicadas novamente.
    7. Guarde o documento.
  9. Repita estes passos para qualquer suspeita de documento conter um vírus em macros.
Nota : Se este método não funcionar, tente o método 3.

Método 3: Utilizar o organizador para temporariamente limpar vírus em macros

Utilize o organizador para limpar o vírus em macros. Tenha em atenção que se outros ficheiros foram abertos depois do ficheiro infectado, provavelmente irá ser infectados bem.

Para remover o vírus do modelo normal:

  1. Feche todos os documentos. Se abrir um documento infectado, pode facilmente reinfect normal.dot.
  2. No menu Ferramentas, clique em modelos e suplementos e clique no botão organizador.
  3. Seleccione o separador de itens do projecto de macro e mudar o nome ou eliminar todas as macros seguintes:
    NewMacros
    AutoClose
    Execução automática
    AutoOpen
    FileExit
    FicheiroNovo
    FileOpen
    FileSave
    FileSaveAs
    Macros
    ToolsMacro
  4. Clique em Fechar.
  5. Prima a tecla SHIFT e, no menu Ficheiro, clique em Guardar tudo ' para guardar o modelo.
Para remover o vírus de documentos infectados:

Se um ficheiro infectado, utilize o mesmo método indicada acima, mas remover as macros do modelo normal e também do documento (modelo) enquanto o organizador infectado. Quando tiver terminado, prima SHIFT e no menu ficheiro e clique em Guardar tudo e avançar para o ficheiro seguinte. Tenha em consideração que sempre que abrir um ficheiro infectado-infectar o modelo normal, por isso constantemente tem de remover as macros do modelo normal.

Método 4: Inseri-lo num documento novo

Com este método, terá de mudar o nome de normal.dot e no menu Inserir, clique em ficheiro para remover temporariamente as macros. Este método é particularmente útil com o vírus em macros chamado "CAP", que remove a macro e personalizar no menu ' Ferramentas '.

Nota : nesta situação, o comando de modelos e suplementos no menu Ferramentas poderão não funcionar.

  1. Feche o Word e mude o nome do ficheiro Normal.dot para Name.dot.
  2. Abra o Word e verifique se macro e personalizar nas ferramentas do menu.
  3. Abra um novo documento e, no menu Inserir, clique em ficheiro.
  4. Navegue para a pasta que contém o ficheiro afectado.
  5. Clique para seleccionar o ficheiro afectado.
  6. Prima e mantenha premida a tecla SHIFT e clique em OK.

    Continue a manter a tecla SHIFT até que o ficheiro afectado seja aberto no Word.

    Nota : holding a tecla SHIFT enquanto abre um ficheiro mantém das macros automáticas de palavras a execução.
  7. Para ver se existem macros no novo documento (não deverá existir nenhuma listada), aponte para macro no menu Ferramentas e, em seguida, clique em macros. Na lista macros em, clique "Todos os modelos e documentos activos." Em nome de macro, não deverá existir quaisquer macros listadas. Clique em ' Cancelar '.
  8. Guarde o ficheiro com um nome de ficheiro diferente.
  9. Elimine o ficheiro infectado.

Mais Informação

Um vírus em macros é um programa escrito na linguagem de macros de um programa, tal como o Word. Este procedimento propaga-se automaticamente entre ficheiros de dados e pode danificar os ficheiros ou sistema operativo do computador.

Vírus em macros do Word não transmitidos livremente da Internet ou outro suporte; só podem ser transferidos quando um utilizador abre um documento ou modelo que contém a macro de vírus.

Assistente do Internet e documentos criados ou leitura por ele não é afectada por estas macros. Assistente de Internet, por predefinição, bloqueia o mecanismo que distribui o vírus em macros.

Vírus de macros não podem ser transferidos por WordMail a menos que um documento afectado estiver incorporado na mensagem de correio electrónico e o destinatário abre o documento.

Propriedades

Artigo: 181079 - Última revisão: 22 de janeiro de 2007 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Word 97 Standard Edition
Palavras-chave: 
kbmt kbfaq kbinfo kbvirus KB181079 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 181079
Exclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com