WD97: Que fazer se você tiver um vírus de macro

Traduções deste artigo Traduções deste artigo
ID do artigo: 181079 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

O primeiro vírus de macro foi descoberto no segundo semestre de 1995. Desde então, apareceu outros vírus de macro. Este artigo descreve o que fazer se você acha que talvez você tenha um vírus de macro do Word, ou se você deseja garantir que seus documentos nunca infectados com um.

A seguir estão alguns sintomas de um vírus de macro do Word que afetam o Word e o Word documentos:

  • Quando você tentar salvar um documento, Word somente permite que você salve o documento como um modelo.
    - ou -
  • O ícone para o arquivo se parece com um modelo em vez de um documento.
    - ou -
  • Quando você abre um documento, uma caixa de diálogo mostrando o número 1 é exibida.
    - ou -
  • Não mostrar os comandos de macro e personalizar as ferramentas de menu.
    - ou -
  • Novas macros aparecem na lista de macros. AutoOpen e FileSaveAs macros também podem aparecer; se você já tivesse macros por esses nomes, seu conteúdo pode ter sido alterado pelo vírus de macro.
    - ou -
  • Mensagens incomuns ou inesperadas aparecem quando você abre uma palavra documento ou modelo.
Observações :

  • No Word 97 há uma opção de proteção contra vírus de macro (no ferramentas do menu, clique em Opções e clique na guia Geral) projetado para alertá-lo se você abrir um arquivo que contém macros, independentemente do que fazer as macros. Para uma solução permanente, você deve usar software antivírus está especificamente projetado para detectar e impedir que vírus de macro.

  • Word não procure ou remova quaisquer vírus de macro do modelos e documentos existentes. Ele simplesmente avisará se o documento que você está abrindo contém macros. O aviso permite que você abrir o documento com as macros ativas ou abri-lo com as macros desativadas. Você não deve abrir um documento com macros ativa a menos que você seja absoluta certeza de que o documento não contém nenhum vírus de macro prejudiciais.
Há uma solução a longo prazo para vírus de macro, instale software antivírus que foi especificamente projetado para detectar vírus de macro. Para obter informações adicionais sobre softwares antivírus disponíveis de fornecedores de terceiros, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
49500Lista de fornecedores de software antivírus

Como Contornar

Use as seguintes soluções alternativas como somente soluções do provisórias.

Método 1: Pressione SHIFT ao abrir um arquivo

Se você não tem os sintomas descritos neste artigo, mas você não deseja ser afetado por um vírus de macro, mantenha pressionada a tecla SHIFT quando você abre um arquivo que pode ser afetado por um vírus de macro. Pressionar SHIFT impedirá qualquer macro automática que está sendo executado; se um vírus de macro estiver presente, ele não será carregado.

Método 2: Excluir a macro e recuperar o documento

Se você enfrentou os sintomas listados neste artigo, ou se você suspeitar de que você tenha um vírus de macro que não seja descrito aqui, use as seguintes etapas para remover as macros problemático e documentos afetados corretos. (Lembre-se de que isso é apenas uma solução temporária; como novas macros são sendo criadas, essas etapas podem não funcionar):

  1. Feche o Word e renomeie o arquivo normal.dot para Name.dot.
  2. Faça uma cópia backup de um arquivo afetado.
  3. Abra o Word e no menu Arquivo clique em Abrir.
  4. Navegue até a pasta que contém o arquivo afetado.
  5. Clique para selecionar o arquivo afetado.
  6. Mantenha a tecla SHIFT e clique em Abrir.

    Continue a mantenha pressionada a tecla SHIFT até que o arquivo afetado esteja aberto no Word.

    Observação : segurando a tecla SHIFT ao abrir um arquivo impede qualquer uma das palavras macros automáticas em execução.
  7. Para remover vírus suspeito que contenha macros, faça o seguinte:
    1. No menu Ferramentas, aponte para macro e, em seguida, clique em macros.
    2. Na lista macros em, clique em todos os modelos Active e documentos.
    3. Selecione a macro suspeita e clique em Excluir. Clique em Sim quando for perguntado se você deseja excluir a macro.
    4. Repita a etapa c para todas as macros suspeitas.
    5. Clique em Cancelar ou de x para fechar a caixa de diálogo macros.
  8. Para recuperar o texto de um documento infectado:
    1. Selecione o documento inteiro pressionando CTRL + A, ou clicando em Selecionar tudo no menu Editar.
    2. Exclua marca de parágrafo final do documento da seleção pressionando SHIFT+seta para esquerda.
    3. No menu Editar, clique em Copiar.
    4. No menu Arquivo, clique em novo. Selecione o modelo que deseja usar e clique em OK.
    5. No menu Editar, clique em Colar.
    6. Repita a etapa 7 para garantir que as macros que contêm vírus não foram replicadas novamente.
    7. Salve o documento.
  9. Repita essas etapas para qualquer documento suspeito de que contém um vírus de macro.
Observação : se esse método não funcionar, tente o método 3.

Método 3: Usar o organizador para limpar temporariamente vírus de macro

Use o organizador para limpar o vírus de macro. Tenha em mente que se outros arquivos foram abertos após o arquivo infectado, eles provavelmente serão infectados assim.

Para remover o vírus do modelo normal:

  1. Feche todos os documentos. Se um documento infectado estiver aberto, ele pode facilmente reinfect normal.dot.
  2. No menu Ferramentas, clique em modelos e suplementos e, clique no botão Gallery.
  3. Selecione a guia macros e renomear ou excluir todas as seguintes macros:
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    Abrir
    FileSave
    FileSaveAs
    Macros
    ToolsMacro
  4. Clique em Fechar.
  5. Pressione a tecla SHIFT e, no menu Arquivo, clique em Salvar tudo para salvar o modelo.
Para remover o vírus de documentos infectados:

Se um arquivo estiver infectado, usar o mesmo método como acima, mas remover as macros do modelo normal e também do documento infectado (modelo) enquanto no Gallery. Quando tiver terminado, pressione SHIFT e no menu Arquivo e clique em Salvar tudo e passar para o próximo arquivo. Tenha em mente que sempre que você abrir um arquivo infectado ele será infectar seu modelo normal, portanto, você constantemente precisará remover as macros do modelo Normal.

Método 4: Inserir IT em um novo documento

Com esse método, você precisará renomear o normal.dot e, em seguida, no menu Inserir, clique em arquivo para remover temporariamente as macros. Esse método é útil principalmente com o vírus de macro chamado "CAP", que remove a macro e personalizar no menu Ferramentas.

Observação : nessa situação, o comando de modelos e suplementos no menu Ferramentas pode não funcionar.

  1. Feche o Word e renomeie o arquivo normal.dot para Name.dot.
  2. Abra o Word e verifique se macro e personalizar estão no ferramentas do menu.
  3. Abra um novo documento e, no menu Inserir, clique em arquivo.
  4. Navegue até a pasta que contém o arquivo afetado.
  5. Clique para selecionar o arquivo afetado.
  6. Pressione e mantenha pressionada a tecla SHIFT e clique em OK.

    Continue a mantenha pressionada a tecla SHIFT até que o arquivo afetado esteja aberto no Word.

    Observação : segurando a tecla SHIFT ao abrir um arquivo impede qualquer uma das palavras macros automáticas em execução.
  7. Para ver se há quaisquer macros no novo documento (não deve haver qualquer listados), aponte para macro no menu Ferramentas e, em seguida, clique em macros. Na lista macros em, clique em "Todos os modelos ativos e documentos." Em nome da macro, não deve haver qualquer macro listada. Clique em Cancelar.
  8. Salve o arquivo com um nome de arquivo diferente.
  9. Exclua o arquivo infectado.

Mais Informações

Um vírus de macro é um programa escrito na linguagem macro de um programa, como o Word. Ele propaga próprio entre arquivos de dados e pode prejudicar o sistema operacional do seu computador ou seus arquivos.

Vírus de macro do Word não livremente viajar pela Internet ou qualquer outra mídia; eles podem ser transferidos somente quando um usuário abre um documento ou modelo que contém a macro de vírus.

Assistente de Internet da Microsoft e documentos criados ou leitura por ele não pode ser afetada por essas macros. Assistente de Internet, por design, bloqueia o mecanismo que distribui o vírus de macro.

Vírus de macro não podem ser transferidos por WordMail, a menos que um documento afetado é incorporado na mensagem de email e o destinatário abre o documento.

Propriedades

ID do artigo: 181079 - Última revisão: segunda-feira, 22 de janeiro de 2007 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Word 97 Standard Edition
Palavras-chave: 
kbmt kbfaq kbinfo kbvirus KB181079 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 181079
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com