Verwenden von SVERWEIS oder WVERWEIS zum Ermitteln einer genauen Übereinstimmung

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 181213 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D40869
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Die Funktionen SVERWEIS und WVERWEIS enthalten des Argument "Bereich_Verweis", mit dem Sie eine genaue Übereinstimmung Ihres Suchkriteriums ohne Sortieren der Nachschlagetabelle ermitteln können.

Hinweis Wenn Sie das Argument "Bereich_Verweis" korrekt verwenden, muss die Nachschlagetabelle nicht sortiert werden.

Weitere Informationen

Die Syntax dieser Funktionen ist folgendermaßen definiert.

Funktion SVERWEIS

   =SVERWEIS(Suchkriterium,Matrix,Spaltenindex,Bereich_Verweis)
				
Dabei gilt Folgendes:
   Argument     Definition des Arguments
   ---------------------------------------------------------------------

   Suchkriterium Der in der ersten Spalte der Matrix zu suchende Wert.

   Matrix  Die Tabelle mit Informationen, in der nach Daten gesucht wird.

   Spaltenindex Die Spaltennummer in der Matrix, für die der
                übereinstimmende Wert zurückgegeben werden soll.

   Bereich_Verweis Ist ein logischer Wert, der angibt, ob Sie
                eine genaue oder eine ungefähre Übereinstimmung ermitteln möchten.
                Bei WAHR oder weggelassenem Wert wird eine ungefähre Übereinstimmung zurückgegeben.
                Das heißt, wenn keine genaue Übereinstimmung gefunden wird, wird der
                nächstgrößere Wert zurückgegeben, der geringer ist als das
                Suchkriterium. Bei FALSCH findet SVERWEIS eine genaue Übereinstimmung. Wird keine
                genaue Übereinstimmung gefunden, wird der Fehlerwert #N/V zurückgegeben.
				
Hinweis Wenn "Bereich_Verweis" WAHR ist oder weggelassen wird (für eine ungefähre Übereinstimmung), müssen die Werte in der ersten Spalte von Matrix aufsteigend sortiert sein. Wenn "Bereich_Verweis" FALSCH ist (für eine genaue Übereinstimmung), muss Matrix nicht sortiert sein.

Beispiel, in dem FALSCH als "Bereich_Verweis"-Argument verwendet wird

Die folgende Liste enthält einige Früchte und deren Farben. Beachten Sie, dass die erste Spalte nicht sortiert ist:
   A1: Frucht    B1: Farbe  
   A2: Kiwi     B2: Grün 
   A3: Banane   B3: Gelb 
   A4: Trauben   B4: Violett  
   A5: Apfel      B5: Rot   
				
Die folgende Formel findet die Farbe (Rot), die der Frucht Apfel entspricht. Sie können die Formel in eine beliebige Zelle im Arbeitsblatt eingeben:
=SVERWEIS("Apfel",A2:B5,2,FALSE)
				
Wenn Sie das Argument "Bereich_Verweis" in WAHR ändern, gibt Excel den Fehler #N/V zurück, weil die erste Spalte nicht sortiert ist.

Funktion WVERWEIS

=WVERWEIS(Suchkriterium,Matrix,Zeilenindex,Bereich_Verweis)
				
Dabei gilt Folgendes:
   Argument     Definition des Arguments
   ---------------------------------------------------------------------

   Suchkriterium Der in der ersten Spalte der Matrix zu suchende Wert.

   Matrix  Die Tabelle mit Informationen, in der nach Daten gesucht wird.

   Zeilenindex   Die Zeilennummer in der Matrix, für die der
                übereinstimmende Wert zurückgegeben werden soll.

   Bereich_Verweis Ist ein logischer Wert, der angibt, ob Sie
                eine genaue oder eine ungefähre Übereinstimmung ermitteln möchten.
                Bei WAHR oder weggelassenem Wert wird eine ungefähre Übereinstimmung zurückgegeben.
                Das heißt, wenn keine genaue Übereinstimmung gefunden wird, wird der
                nächstgrößere Wert zurückgegeben, der geringer ist als das
                Suchkriterium. Bei FALSCH findet SVERWEIS eine genaue Übereinstimmung.
                Wird keine genaue Übereinstimmung gefunden, wird der Fehlerwert #NV
                zurückgegeben.
				
Hinweis Wenn "Bereich_Verweis" WAHR ist oder weggelassen wird (für eine ungefähre Übereinstimmung), müssen die Werte in der ersten Zeile von Matrix aufsteigend sortiert sein. Wenn "Bereich_Verweis" FALSCH ist (für eine genaue Übereinstimmung), muss Matrix nicht sortiert sein.

Beispiel, in dem FALSCH als "Bereich_Verweis"-Argument verwendet wird

Die folgende Liste enthält einige Früchte und deren Farben. Beachten Sie, dass die erste Spalte nicht sortiert ist:
   A1: Frucht    B1: Farbe
   A2: Kiwi     B2: Grün
   A3: Banane   B3: Gelb
   A4: Trauben   B4: Violett
   A5: Apfel      B5: Rot
				
Die folgende Formel findet die Spalte "Farbe" und gibt das dritte Element (-1) für den Eintrag "Gelb" zurück. Sie können die Formel in eine beliebige Zelle im Arbeitsblatt eingeben:
=WVERWEIS("Farbe",A1:B5,3,FALSE)
				
Wenn Sie das Argument "Bereich_Verweis" in WAHR ändern, gibt Excel den Fehler #N/V zurück, weil die erste Spalte nicht sortiert ist.

Informationsquellen

Weitere Informationen zur Verwendung der VERWEIS-Funktionen in Microsoft Excel finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
181212 XL: Durchführen einer Suche mit unsortierten Daten in Excel
214264 XL: Ausführen einer Suche unter Berücksichtigung der Groß-/Kleinschreibung
214069 XL: Zurückgeben der ersten oder letzten Übereinstimmung in einem Array
181201 XL: WVERWEIS, SVERWEIS und VERWEIS geben in Excel falsche Werte zurück
213476 XL: Unerwartete Ergebnisse mit gemischtem Text und Zahlen in der Nachschlagetabelle
280094 XL: Benutzerdefinierte Beispielfunktion zum Ausblenden von Formelfehlern in Excel
Weitere Informationen zur Funktion WVERWEIS erhalten Sie, wenn Sie im Menü ? auf Microsoft Excel-Hilfe klicken und im Office- oder Hilfe-Assistenten WVERWEIS Tabellenfunktion eingeben. Klicken Sie danach auf Suchen, um das Thema anzuzeigen.
Weitere Informationen zur Funktion SVERWEIS erhalten Sie, wenn Sie im Menü ? auf Microsoft Excel-Hilfe klicken und im Office- oder Hilfe-Assistenten SVERWEIS Tabellenfunktion eingeben. Klicken Sie danach auf Suchen, um das Thema anzuzeigen.
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen.

Eigenschaften

Artikel-ID: 181213 - Geändert am: Mittwoch, 22. Mai 2013 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft Office Excel 2003
  • Microsoft Excel 2010
  • Microsoft Office Excel 2007
Keywords: 
kbhowto KB181213
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com