Data Corruption Occurs with Record Locking on FPNW Server

Article translations Article translations
Article ID: 181311 - View products that this article applies to.
This article was previously published under Q181311
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

When you use Novell Client 32 on a computer running Windows 95 Client 32, data corruption can occur to a file that is open by multiple users when record locking is enabled on the File and Print Service for NetWare (FPNW) server. This problem only happens with Client 32 accesses the files on FPNW server. It does not happen with Client 32 accessing the files on the Novell server or a VLM client assessing the files on the FPNW Server.

CAUSE

The Novell Client 32 thinks the data files are marked shareable and, therefore, does more aggressive caching than it should.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed this to be a problem in File and Print Services for Windows NT. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 181311 - Last Review: February 21, 2014 - Revision: 2.2
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft File and Print Services for NetWare 4.0
  • Microsoft Windows 95
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbqfe KB181311

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com