OL98: (CW) How to Use the Inbox Repair Tool to Recover Messages

Article translations Article translations
Article ID: 181325 - View products that this article applies to.
This article was previously published under Q181325


NOTE: These procedures only apply if you have installed Outlook with the Corporate Workgroup/Other option. This option allows you to use Messaging Application Programming Interface (MAPI) services. To determine your installation type, on the Help Menu click About Microsoft Outlook. In About Microsoft Outlook you should see "Corporate" if you have the Corporate Workgroup installation.
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to use the Inbox Repair Tool to recover folders and items from a corrupted Personal Folders (.pst) file.

MORE INFORMATION

NOTE: The examples listed below refer to using the Inbox Repair Tool on a .pst file. The same procedures apply to an offline folder (.ost) file. To locate the offline folder (.ost) file, click to select Offline Folders (*.ost) in Select File to Scan.

The Inbox Repair Tool (Scanpst.exe) is a tool designed to help repair problems associated with Personal Folder (.pst) files. This tool can also repair offline folder (.ost) files.

The Inbox Repair Tool ships with Microsoft Windows 95, and is also on both the Microsoft Outlook 98 and Microsoft Office 2000 CD-ROM. It is installed automatically during setup. This utility is also installed with the Windows Messaging Service Setup on the Microsoft Windows 98 CD-ROM. You can find these programs in the following folder:
<CD drive>:\tools\oldwin95\message\us\wms.exe
In Windows 2000, you can locate these programs in the following folder:
<CD drive>:\Program Files\Common Files\System\Mapi\1033\NT\Scanpst.exe

Run the Inbox Repair Tool

  1. Click Start and point to Find, or Search, depending upon your operating system.
  2. In the Search for files or folders named box, type scanpst.exe.
  3. Type the path and file name of the pst file, or click Browse to locate the file using the windows file system.
  4. Click Start.

What the Inbox Repair Tool Does

When you run the Inbox Repair Tool on a Personal Folders (.pst) file, it does the following:
  • The Inbox Repair Tool analyses the Personal Folders (.pst) file directory structure and item headers to try and recover all folders and items.
  • If the Inbox Repair Tool recovers the Personal Folders (.pst) file, it means that the repair tool found problems, and repaired what it could.
  • The Inbox Repair Tool tries to turn any file into a Personal Folders (.pst) file. (For example, if you rename an executable file to "Something.pst," (without quotation marks) the tool changes the file to a mountable .pst file).

Recovered Personal Folders File

After you run the Inbox Repair Tool, start Outlook by using the profile that contains the Personal Folders (.pst) file that you tried to repair. On the View menu, click Folder List to turn on the Folder List view. In your Folder List, you should see the following recovered folders:
   Recovered Personal Folders

      Calendar
      Contacts
      Deleted Items
      Inbox
      Journal
      Notes
      Outbox
      Sent Items
      Tasks
				
These recovered folders are usually empty, because this is a rebuilt .pst file. You should also see a folder called "Lost And Found" (without quotation marks). This folder contains folders and items that the Inbox Repair Tool recovered. Items that are missing from the Lost and Found folder are beyond repair.

How to Recover Repaired Items

You should move as many of the items from the Lost And Found folder to a new Personal Folders (.pst) file in your profile. First, create a new Personal Folders (.pst) file entry in your profile and drag any recovered items from the Lost And Found folder to the appropriate location in your new Personal Folders (.pst) file.

How to Create a New Personal Folder (.pst) File in Your Profile

  1. Start Outlook with the profile that contains your recovered Personal Folder (.pst) files.
  2. On the File menu, click Data File Management.
  3. Click Add to open the New Outlook Data File dialog box.
  4. In the Types of storage box, click to select Personal Folders File (.pst), and then click OK.
  5. In the Create or Open Outlook Data File dialog box, click a directory and a file name for your new Personal Folders (.pst) file, and then click Open.
  6. Click OK.
You should have a new Personal Folders (.pst) file in your profile. Drag the recovered items from the Lost And Found folder to your new Personal Folders (.pst) file. When you have finished moving all items, you may remove the Recovered Personal Folders (.pst) file, including the Lost And Found folder, from your profile.

How to Recover Items from the Backup Personal Folders (.pst) File

NOTE: If you cannot open your original Personal Folders (.pst) file before you run Inbox Repair Tool, it is possible that the following procedures may not work. If you are able to open the original Personal Folders (.pst) file, then it is possible that the following procedures may allow you to recover additional items from your damaged Personal Folders (.pst) file.

When you run Inbox Repair Tool, the option to create a backup of the original Personal Folders (.pst) file is selected. This option creates a file on your hard disk called <file name>.bak, and is a copy of the original <file name>.pst file with a different extension. The .bak file resides in the directory of your original Personal Folders (.pst) file.

You may be able to recover items from the .bak file that Inbox Repair Tool could not. Make a copy of the .bak file, giving the file a new name with a .pst extension, for example "Newname.pst" (without quotation marks).

Open Outlook using the profile that contains the your new Personal Folders (.pst) file from step 4 in the "Recovering Repaired Items" section of this article, and try to import the "Newname.pst" folder by using the Import And Export Wizard. To do this:
  1. On the File menu, click Import And Export.
  2. Click Import from another program or file, and then click Next.
  3. Click to select Personal Folder File (.pst), and then click Next.
  4. Under File To Import, type your Newname.pst file. Under Options, click Do not import duplicates, and click Next.
  5. Under Select the folder to import from, click to select the Personal Folders (.pst) file, and click to select Include subfolders, click to select Import folders into the same folder in, click your new Personal Folders (.pst) file from step 4 in the "Recovering Repaired Items" section of this article, and then click Finish.
NOTE: Remember that the backup file was the original corrupted file, and you may find that you cannot recover anything other that what was recovered in the Lost And Found folder. If you are unable to import the Newname.pst file into Outlook, then you have lost all the information that is not in the Lost And Found folder.

If a file has approached the 2 GB size limit and the Inbox Repair Tool is not working, then you could try the PST/OST cropping tool
296088 Oversized PST and OST Crop Tool

Properties

Article ID: 181325 - Last Review: January 20, 2006 - Revision: 2.0
APPLIES TO
  • Microsoft Outlook 98 Standard Edition
Keywords: 
kbhowto KB181325
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com