Artigo: 181685 - Última revisão: segunda-feira, 22 de Janeiro de 2007 - Revisão: 2.2

OLEXP: Mensagem de erro: wab.exe está ligado em falta exportar Advapi32.dll

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta utilizar o Windows endereços Book (WAB) no Outlook Express, poderá receber a seguinte mensagem de erro:
Wab.exe está ligado à Advapi32.dll de exportação em falta

Causa

Este comportamento pode ocorrer quando o ficheiro Advapi32.dll é a versão incorrecta ou está danificado.

Resolução

Para resolver este problema, utilize o método adequado:

O Windows 95

Extraia uma nova cópia do ficheiro Advapi32.dll do Internet Explorer 4.0 ou 4.01 ficheiro CAB Ie4_s1.cab para a pasta Windows\System. Para o fazer, siga estes passos:

  1. Reinicie o Windows 95, prima a tecla F8 quando visualizar a mensagem "a iniciar o Windows 95" e, em seguida, seleccione apenas linha de comandos em modo de segurança no menu de arranque.
  2. Mude o ficheiro Advapi32.dll na pasta Windows\System para Advapi32.old escrevendo a seguinte linha e, em seguida, premindo ENTER

    ren <drive> <unidade>: \ <windows> \system\advapi32.dll advapi32.old

    <drive>onde <unidade> é a letra de unidade em que se encontra na pasta Windows e <windows> é o nome da pasta em que o Windows está instalado. Por exemplo:

    ren c:\windows\system\advapi32.dll advapi32.old

    NOTA: Este procedimento parte do princípio de que um ficheiro denominado Advapi32.old não é necessário. Se tiver um ficheiro com este nome, utilize uma extensão de nome ficheiro que não esteja actualmente a ser utilizado.
  3. Escreva a seguinte linha e, em seguida, prima ENTER

    extrair <drive><path> <unidade>: <caminho> ie4_s1.cab /l <drive2>:<path2>

    <drive><path>onde <unidade> é a letra de unidade onde o Internet Explorer 4.0 ou 4.01 ficheiros de programa de configuração estão localizados, <caminho> é o caminho para a pasta na qual o Internet Explorer 4.0 ou 4.01 ficheiros de programa de configuração estão localizados, <drive2><path2> é a letra da unidade onde pretende extrair o ficheiro Ie4_1.cab existente e <caminho2> é o caminho para a pasta onde pretende extrair o ficheiro Ie4_1.cab existente. Por exemplo:

    extrair c:\intern~1.0se\ie4_s1.cab /l c:\intern~1.0se
  4. Escreva a seguinte linha e, em seguida, prima ENTER

    extrair <drive><path> <unidade>: <caminho> advapi32.dll /l <drive2>: \ <windows> \system

    <drive><path>onde <unidade> é a letra da unidade na qual ficheiro Ie4_1.cab existente está localizado, <caminho> é o caminho para a pasta onde está localizado o ficheiro Ie4_1.cab existente, <drive2><path2> é a unidade em que o Windows está instalado e <caminho2> é a localização da pasta Windows\System. Por exemplo:

    extrair c:\intern~1.0se\ie4_1.cab advapi32.dll /l c:\windows\system
  5. Reinicie o computador.

Windows 95 OEM Service Release 2 (OSR2)

Extraia uma nova cópia do ficheiro Advapi32.dll a partir do seu-de ROM original do Windows 95 OEM Service Release 2 (OSR2) para a pasta Windows\System. O ficheiro Advapi32.dll está localizado no ficheiro CAB Win95_17.cab no CD-ROM do Windows 95 OSR2.

Para mais informações sobre como utilizar a ferramenta Extract, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:
129605  (http://support.microsoft.com/kb/129605/EN-US/ ) Como extrair ficheiros originais comprimidos do Windows

Windows 98

Extraia uma nova cópia do ficheiro Advapi32.dll utilizando a ferramenta Verificador de ficheiros de sistema. Para iniciar a ferramenta Verificador de ficheiros de sistema, clique em Iniciar, clique em executar, escreva "sfc.exe" (sem as aspas) na caixa Abrir e, em seguida, clique em OK.

Para obter informações sobre como utilizar a ferramenta Verificador de ficheiros de sistema para extrair um ficheiro, clique em Iniciar, clique em Ajuda, clique no separador Índice remissivo, escreva "ficheiro de sistema" (sem as aspas), clique duas vezes no tópico "Verificador de ficheiros de sistema", clique em "para extrair ficheiros de sistema a partir dos seus discos de instalação" e, em seguida, clique em Mostrar.

A informação contida neste artigo aplica-se a:
  • Microsoft Outlook Express 4.01
  • Microsoft Outlook Express 4.0
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbmt kberrmsg kbprb KB181685 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 181685  (http://support.microsoft.com/kb/181685/en-us/ )