REVISIÓN: Analizar problemas con archivos de registro abrir

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Síntomas

Analizar informes devuelve el siguiente error y si está ejecutando ANALYZE con -f, el modificador -d o ambos, se eliminan los archivos desde el data\ <a-z> directorio o destruido en la base de datos de SourceSafe.

Aquí es el error:
No se puede abrir archivo < nombre de archivo físico >
El archivo < nombre de archivo físico > ya está abierto.

Causa

Si un archivo de registro (un archivo sin extensión en uno de los data\ <a-z> carpetas) está abierto y bloqueado por un proceso diferente, como una utilidad copia de seguridad que se ejecutan simultáneamente con analizar, analizar considera el archivo huérfano.

Solución

La mejor solución es prevención. Debe ejecutar analizar sin ningún modificador antes de ejecutar con el modificador -d o el modificador -f. Si ANALYZE informa de que un archivo ya está abierto, pasos cualquiera que sea necesario cerrar ese archivo antes de utilizar los modificadores adicionales. Una vez se ha producido el problema, se determinará la resolución por una serie de factores, como los archivos que se han eliminado, cómo importante es mantener el histórico de su y si se vio afectado un archivo o proyecto. Si no está seguro de qué acción tomar, póngase en contacto con soporte técnico de Microsoft.

Estado

Microsoft ha confirmado que este es un error en analizar la versión proporcionada con Visual SourceSafe 5.0.
Este error se corrigió en la versión de analizar que se incluye con Visual SourceSafe 6.0 y la versión de analizar que está disponible en el Web.
Consulte la sección de referencias para obtener más información sobre descargar el archivo Analyze.exe.

Más información

Un archivo huérfano es aquel que la base de datos mediante el Explorador de SourceSafe o en la línea de comandos de SourceSafe se ha destruido y no está bifurcado a o desde un archivo que todavía existe en la base de datos. En el escenario descrito en la sección causa, analizar ve este archivo como huérfano, pero su par de archivo físico todavía existe en el data\ <a-z> carpeta. Analizar -d intenta eliminar el par de archivos. Pueden eliminar uno o ambos de los archivos, dependiendo de qué archivo está bloqueado al tiempo que intenta la eliminación. No se elimina un archivo bloqueado. Esto puede provocar errores de "Archivo < nombre de archivo de datos físicos > no encontrado".

Analizar -f difiere en proyectos y archivos como se describe a continuación:

  • Si el par de archivos representa un archivo, analizar destruye el archivo en la base de datos de SourceSafe. Cuando esto ocurre, el historial del proyecto principal muestra que el archivo se ha destruido por el usuario "RECONSTRUCCIÓN". El par de archivo físico de proyecto del principal del archivo se copia en la copia de seguridad de la carpeta, en su estado pre-analyzed.
  • Si el par de archivos representa un proyecto, analizar copia el par de archivo correspondiente en el directorio de copia de seguridad y intenta eliminar el par de archivos.
Analizar resultados de -f -d en ambas situaciones descritas anteriormente.

Pasos para reproducir este comportamiento

Nota: Reproducir este comportamiento provoca problemas con la base de datos de SourceSafe. No intente reproducir este en una base de datos activa. Utilice esto en una base de datos está configurado para las pruebas sólo propósitos.

Mediante una aplicación que los archivos de bloqueos que se abre, como Microsoft Word abre un archivo de registro en el directorio de datos de SourceSafe. Ejecute ANALYZE con cualquier combinación de f - y -d modificadores, para obtener información completa, utilice el v4 modificador.

Referencias

Para obtener información adicional, consulte en contacto con los artículos siguientes en Microsoft Knowledge Base:
EJEMPLO 190881: utilidad de Analyze6.exe para Visual SourceSafe
INFORMACIÓN 168634: al d - conmutador de analizar elimina archivos
167263<filename>PRB: <nombre_archivo> está ya abierto

Propiedades

Id. de artículo: 181717 - Última revisión: sábado, 22 de febrero de 2014 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Visual SourceSafe 5.0 Standard Edition
  • Microsoft Visual SourceSafe 6.0 Standard Edition
Palabras clave: 
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Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 181717

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