OL98: Field Mapping for Importing Not Available

Article translations Article translations
Article ID: 182728 - View products that this article applies to.
This article was previously published under Q182728
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Symptoms

You are importing data using the Import/Export feature of Microsoft Outlook 98. You want to map fields from your data source into the equivalent field in Outlook. The feature to allow field mapping is not available. This article describes techniques you may use to successfully import data into Outlook.

Cause

The custom field mapping feature that was included in Outlook 97 is not included in Outlook 98 due to problems with the conversion technology. The field mapping functionality is licensed from DataViz, Inc. and, in its current state, is no longer available to Microsoft for use in Outlook 98.

Microsoft now provides an Importer Field Mapping Patch for Outlook 98 that includes the field mapping functionality previously found in Outlook 97.

Resolution

To successfully map fields from personal information manager files or other data sources, you have two options. The first and preferred option is to download and install the Importer Field Mapping Patch for Outlook 98 from the Microsoft Office Update Web site. The second and less preferred option is to manually match the original fields to the internal name that Outlook uses for the fields.

This article outlines the circumstances pertinent to the field mapping issue and offers suggestions for successfully importing data to Outlook. The following topics are discussed:

  • Importer Field Mapping Patch for Outlook 98
  • Manual Field Mapping
  • Generating a Sample of Outlook Fields
  • Automatic Mapping of Files

More information

Importer Field Mapping Patch for Outlook 98

The easiest way to import data using the Import/Export feature of Outlook 98, and map fields from your data source, such as a spreadsheet or database file, into the equivalent fields in Outlook is by downloading and installing the Importer Field Mapping Patch for Outlook 98. The patch is available at the following Internet address:
http://office.microsoft.com/downloads/9798/field98.aspx
After installing the patch:

  1. Choose the Import and Export command on Outlook's File menu.
  2. Choose the type of file you want to import from the list, typically Import from another program or file.
  3. Choose the specific file type you want to import from.
  4. Choose the file to import from.
  5. When you reach the dialog with the Map Custom Fields button, click that button or the Help button for more information on mapping custom fields.

Manual Field Mapping

Outlook items use specific field names to organize the data. When you import information to an Outlook folder, the field names from the source file must exactly match those in the Outlook target item. If these fields do not match, the fields that you expect to be populated with data will be blank. Mapping of data from various sources requires you to inspect and, if necessary, manually edit the field names. In addition, there must be a header row that defines the information in each column. This is different from Outlook 97, which gives you the option to map fields without a header row.

In order to manually map fields when doing an import from Comma Separated Values (CSV) and Tab Separated Values (TSV) files, the field values in the header record must be edited to exactly match the corresponding Outlook field. The header record of a data file is the first line of the file, and contains the field names of the data to be imported. For example, a field name, "F_Name" in a data source may refer to individual first names. Such a field name would be changed for mapping in Outlook import to "First Name," since Outlook uses First Name for its internal naming of that field. For information on generating samples of Outlook field labels, see the section, "Generating a Sample of Outlook Fields."

Additionally, data files created by Microsoft programs such as Microsoft Excel, Microsoft Word, Microsoft Access and Microsoft Fox Pro will also need to be edited so that fields in the header record exactly match the standard Outlook fields.

Open Database Connectivity ODBC drivers are required to import files created with these programs. These drivers are installed by running Setup from the Dataacc.exe file included with the Valupack furnished with Outlook. Users who do not have Office 97 or an Outlook 98 compact disc may download Dataacc.exe from the Outlook Enhancements Web by following these steps:

  1. On the Help menu, point to Microsoft on the Web, and then click Free Stuff.
  2. Click Microsoft Data Access Pack and follow the download instructions.

    NOTE: Fox Pro limits field labels to 10 characters. A majority of Outlook field labels exceed 10 characters. To prepare the Fox Pro file for import into Outlook, you must first export the file to either a TSV or CSV file, edit the field labels in the header record, and then use that CSV file as your data source.

    If a text or ODBC file contains a name that is not an internal Outlook name, no data will be imported. Also, each Outlook object has required either one or two fields. If these fields are not present in the imported file, an error dialog appears listing the required fields for that object type. The required fields are:
       Calendar folder:   Subject, Start Date
       Contacts folder:   None
       Journal folder:    Start Date, Journal Type
       Mail folder:       Subject
       Notes folder:      Body
       Tasks folder:      Subject
    					

Generating a Sample of Outlook Fields

Before editing your data source, it may be helpful to generate a sample of the fields used in Outlook. To generate the sample fields, follow these steps:
  1. If present, remove the current binary mapping file named, "Comma Separated Values (Windows).ADR" located in the Windows folder. This procedure will rebuild this file.
  2. On the View menu, click Folder List if it is not already displayed.
  3. In the Folder List, right-click the Outlook folder for which you wish to generate a sample and on the Shortcut menu, and then click New Folder.

    NOTE: Each Outlook folder has a distinctly different required set of fields. For example, the required set of fields for Outlook Contacts will include fields that are not used with the Calendar.
  4. Give this temporary folder a name. You may delete this folder once the sample fields file is created.
  5. On the File menu, click Import And Export. Click Export to a File, and then click Next.
  6. In Create a file of Type, click to select Comma Separated Values (Windows), and then click Next.
  7. In Select folder to export from, click to select the folder you created in Step 2, and then click Next.
  8. In Save exported file as, type a name for the file and click Browse to select the folder in which you wish to save the file. Click OK to save the exported file, click Next, and then click Finish.
The resulting comma separated values file contains the fields that Outlook uses for the folder you selected. Repeat this step as necessary for each type of data you want to import. While familiarizing yourself with the Outlook field labels, note that precise spelling is necessary. For example, when defining electronic mail addresses, Outlook uses the spelling, "e-mail."

Automatic Mapping of Files

If you use any of the following personal information management (PIM) software products, the Import and Export Wizard includes the ability to automatically assign corresponding field names to closely matching Outlook field names.

  • ACT! 2.0 Contact Manager for Windows
  • ACT! 3.0 Contact Manager for Windows
  • dBase
  • ECCO 2.0, 3.0, 4.0
  • Lotus Organizer 1.0, 1.1
  • Lotus Organizer 2.1
  • Lotus Organizer 97
  • Schedule+ 1.0
  • Schedule+ 7.0
  • Sidekick 95
  • SideKick for Windows 2.0
If you are importing data files that are generated by one of the above-mentioned sources, you need to install the PIM Converters using Outlook Maintenance Setup. This set of converters may not be installed with your initial Outlook Setup option. The steps to add these converters are included in the Outlook Help file. To access this entry see the Reference section.

References

For more information on importing and exporting data files, please see the following article(s) in the Microsoft Knowledge Base:
Article-ID: 189181
Title : OL98: How to Map Imported Files into Outlook Using Excel

Article-ID: 180315
Title : OL98: Importing from Microsoft Excel Requires Named Range

Article-ID: 185418
Title : OL98: Data Missing When Importing and Exporting


For more information about adding new components to your Outlook installation, in the Office Assistant, type add components, click Search, and then click to view Setup or remove individual components.

DataViz, Inc., and the distributors of the various products listed above are vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these product's performance or reliability.

Properties

Article ID: 182728 - Last Review: October 26, 2013 - Revision: 2.0
Applies to
  • Microsoft Outlook 98 Standard Edition
Keywords: 
kbnosurvey kbarchive kbdownload kb3rdparty kbexport kbhowto kbimport kbmigrate KB182728

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com