用于导入没有可用的 OL98: 域映射

文章翻译 文章翻译
文章编号: 182728 - 查看本文应用于的产品
本文已归档。它按“原样”提供,并且不再更新。
展开全部 | 关闭全部

本文内容

症状

要使用的 Microsoft Outlook 98 导入/导出功能的数据导入。要将您的数据源中的字段映射到在 Outlook 中等效的字段。该功能以允许字段映射不可用。本文介绍了您可能会用来成功地将数据导入到 Outlook 的方法。

原因

不包括在 Outlook 98 中的转换技术因中包含在 Outlook 97 中的自定义字段映射功能。字段映射功能都由 DataViz,Inc.授权,并在其当前状态中不再是可向 Microsoft 在 Outlook 98 中使用。

Microsoft 现在提供了用于包括字段映射功能在 Outlook 97 以前找到的 Outlook 98 一个导入程序字段映射修补程序。

解决方案

若要成功地将映射的个人信息管理器文件或其他数据源中的字段,您有两个选项。第一个和首选选项是下载并安装修补导入程序字段映射程序的 Outlook 98 从 Microsoft Office 更新网站。第二个和较低首选选项是手动匹配该内部名称,Outlook 将使用的字段,将原始域。

本文概括介绍了相关字段映射问题的情况下,并提供了成功地将数据导入到 Outlook 的建议。讨论以下主题:

  • 导入程序字段映射为 Outlook 98 的修补程序
  • 手动字段映射
  • 生成 Outlook 字段的示例
  • 自动映射的文件

更多信息

导入程序字段映射为 Outlook 98 的修补程序

要使用的 Outlook 98 导入/导出功能导入数据并将您如电子表格或数据库的文件的数据源中的字段映射到等效的字段,在 Outlook 中,最简单的方法是通过下载和安装该导入程序字段映射用于修补程序 Outlook 98。此修补程序,请访问下面的 Internet 地址:
http://office.microsoft.com/downloads/9798/field98.aspx
后安装修补程序:

  1. 选择在 Outlook 的文件菜单上的导入和导出命令。
  2. 选择您想要从列表导入,通常从其他程序或文件导入的文件的类型。
  3. 选择您要从导入特定文件类型。
  4. 选择要从中导入文件。
  5. 当到达与映射自定义域按钮对话框时, 单击该按钮或帮助按钮的映射自定义字段的详细信息。

手动字段映射

outlook 项目使用特定的字段名称来组织数据。当您导入到 Outlook 文件夹信息时,源文件中的字段名必须完全匹配那些在 Outlook 的目标项。如果这些字段不匹配,您希望用数据填充该字段将为空。来自各种源的数据的映射将要求您检查,并如有必要,手动编辑字段名称。此外,必须有一个标题行定义中的每一列的信息。这是不同于为您提供选项以映射域,而不是标题行的 Outlook 97。

若要执行的导入操作中的逗号分隔值 (CSV) 和制表符分隔值 (TSV) 文件时,手动将域映射,必须完全匹配相应的 Outlook 字段编辑域名记录中的字段值。域名记录的数据文件的文件,第一行,并且包含要导入数据的字段名称。例如对于一个字段名 F_Name 数据源中的可能引用单个的名字。这样的字段名称将发生更改为 Outlook 导入中的映射到名"因为 Outlook 会使用其内部的命名字段的名字。有关生成的 Outlook 字段标志的示例,请参阅部分"生成示例的 Outlook 字段。

此外,由 Microsoft 程序 (如 Microsoft Excel、 Microsoft Word、 Microsoft Access 和 Microsoft Fox 专业创建的数据文件也要进行编辑,以便在域名记录中的字段与标准的 Outlook 字段完全匹配。

开放式数据库连接(ODBC) ODBC 驱动程序才能使用这些程序创建的文件导入。 从包含在使用 Outlook 提供了 Valupack Dataacc.exe 文件运行安装程序来安装这些驱动程序。不具有 Office 97 或一个 Outlook 98 光盘的用户可能会从 Outlook 增强网站下载 Dataacc.exe,按照以下步骤:

  1. 帮助 菜单上指向 在 Web 上的 Microsoft,然后单击 免费资料
  2. 单击 Microsoft 数据访问包,请按照下载指令。

    : Fox Pro 限制字段标签以 10 个字符。大部分 Outlook 字段标签超过 10 个字符。若要准备用于导入到 Outlook Fox 专业文件,您必须首先将文件导出到一个 TSV 或 CSV 文件、 编辑页眉记录中的字段标签,然后使用作为您的数据源的该 CSV 文件。

    如果文本或 ODBC 文件中包含的不是内部的 Outlook 名称名称,则没有任何数据都将被导入。此外,Outlook 中的每个对象具有所需的一个或两个字段。如果这些字段不出现在 $ 导入的文件中,此时将显示一个错误对话框,其中列出了为该对象类型所需的字段。必须填写的字段包括:
       Calendar folder:   Subject, Start Date
       Contacts folder:   None
       Journal folder:    Start Date, Journal Type
       Mail folder:       Subject
       Notes folder:      Body
       Tasks folder:      Subject
    					

生成 Outlook 字段的示例

在编辑您的数据源之前,它可能有助于生成在 Outlook 中使用该字段的示例。若要生成示例字段,请按照下列步骤操作:
  1. 如果存在,删除名为当前的二进制映射文件、"逗号分隔值 (Windows).ADR"位于 Windows 文件夹中。此过程将重新生成此文件。
  2. 如果尚未显示,请在 视图 菜单上单击 文件夹列表
  3. 文件夹列表 中用鼠标右键单击 Outlook 文件夹中的为您要生成示例并在 快捷方式 菜单上,然后单击 新建 文件夹。

    : 每个 Outlook 文件夹具有差别显著所需的一组字段。例如对于 Outlook 联系人所需的字段集将包括与日历中未使用的字段。
  4. 为此临时文件夹指定一个名称。创建示例字段文件后,您可以删除此文件夹。
  5. 文件 菜单上单击 导入和导出。单击 导出到文件,然后单击 下一步
  6. 创建文件的类型 框中,单击以选中 逗号分隔值 (Windows),然后单击 下一步
  7. 选择导出文件夹的位置,单击以选中您在步骤 2 中创建该文件夹,然后单击 下一步
  8. 将导出文件另存为,中键入文件的名称,然后单击 浏览 选择您要在其中保存文件文件夹。单击 确定 以保存导出的文件,单击 下一步,然后单击 完成
生成的逗号分隔的值文件包含字段的 Outlook 用于所选的文件夹。重复此步骤,根据需要为每个您想要导入的数据类型。同时 familiarizing 自己 Outlook 字段标签,请注意精确拼写是必要的。例如对于在定义电子邮件地址时 Outlook 将使用进行拼写"电子邮件。

自动映射的文件

如果您使用以下个人信息管理 (PIM) 软件产品的任何,导入和导出向导中包括能够自动将相应的字段名称指定为紧密匹配的 Outlook 字段名称。

  • ACT! 2.0 为 Windows 联系人管理器
  • ACT! 3.0 为 Windows 联系人管理器
  • dBase
  • ECCO 2.0,3.0、 4.0
  • 莲花管理器 1.0 1.1
  • 莲花管理器 2.1
  • 莲花管理器 97
  • schedule + 1.0
  • schedule + 7.0
  • sidekick 95
  • 对于 Windows 2.0 sideKick
如果您要导入数据文件生成的上面提到的资源之一,则需要安装使用 Outlook 维护安装的 PIM 转换器。此组转换器可能没有安装与您最初的 Outlook 安装选项。若要添加这些转换器步骤包括 Outlook 帮助文件中。要访问此项,请参见参考部分。

参考

有关导入和导出数据文件的详细信息,请参阅下列文章 Microsoft 知识库中相应:
文章 ID: 189181
标题: OL98: 如何映射到 Outlook 使用 Excel 中导入文件

文章 ID: 180315
标题: OL98: Microsoft Excel 中导入需要命名范围

文章 ID: 185418
标题: OL98: 数据丢失时导入和导出


有关在 Outlook 安装 Office 助手中添加新组件的详细信息键入 添加组件,单击 搜索,然后单击查看 安装或删除单个组件

DataViz,Inc.和 $ 上面列出的各种产品的分发服务器是独立于 Microsoft 的供应商 ; 我们不保证,或暗示或其他方式,这些产品的性能或可靠性。

属性

文章编号: 182728 - 最后修改: 2013年10月7日 - 修订: 1.2
这篇文章中的信息适用于:
  • Microsoft Outlook 98 标准版
关键字:?
kbnosurvey kbarchive kbmt kbdownload kb3rdparty kbexport kbhowto kbimport kbmigrate KB182728 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 182728
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com