OL98: 欄位無法使用的 [匯入對應

文章翻譯 文章翻譯
文章編號: 182728 - 檢視此文章適用的產品。
本文已封存。本文係以「現狀」提供且不會再更新。
全部展開 | 全部摺疊

在此頁中

徵狀

您要匯入使用 Microsoft Outlook 98 的 「 匯入/匯出功能的資料。您想要將來自資料來源的欄位對應到在 Outlook 中對等的欄位。若要允許欄位對應功能不適用。本文將告訴您,您可能會使用成功地將資料匯入 Outlook 技巧。

發生的原因

包含在 Outlook 97 中的自訂欄位對應功能並不包含在 Outlook 98 因為要轉換技術的問題。欄位對應功能從 DataViz,Inc.授權,並以其目前的狀態已經無法使用到 Microsoft 以用於 Outlook 98。

Microsoft 現在提供包含先前在 Outlook 97 中找到的欄位對應功能的 Outlook 98 的匯入工具欄位對應補充程式。

解決方案

成功地對應從個人資訊管理員檔案或其他資料來源的欄位,您有兩個選項。第一個也是慣用的選項是下載並安裝補充匯入工具欄位對應程式供 Outlook 98 從 Microsoft Office 更新網站。第二個也是較偏好的選項是手動將原始欄位對應到內部 Outlook 使用欄位的名稱。

本文概述相關欄位對應問題情況下,並提供建議已順利匯入資料到 Outlook。討論下列主題:

  • Outlook 98 的匯入工具欄位對應補充程式
  • 手動欄位對應
  • 產生 Outlook 欄位的範例
  • 自動對應的檔案

其他相關資訊

Outlook 98 的匯入工具欄位對應補充程式

使用 Outlook 98 的 「 匯入/匯出功能匯入資料,並將您例如,試算表或資料庫的檔案的資料來源的欄位對應到在 Outlook 中對等欄位容易的方法是藉由下載,安裝補充匯入工具欄位對應程式供 Outlook 98。補充程式會在下列的網際網路位址:
http://office.microsoft.com/downloads/9798/field98.aspx
在安裝補充程式:

  1. 選擇 Outlook 的 [檔案] 功能表上的 [匯入及匯出] 命令。
  2. 選擇您想要從清單匯入、 通常從其他程式或檔案匯入的檔案類型。
  3. 選擇您想要從匯入的特定檔案類型。
  4. 選擇要從匯入檔案。
  5. 當您到達 [具有 [對應自訂欄位] 對話方塊時按一下該按鈕] 或 [如需對應自訂欄位的相關資訊的 [說明] 按鈕。

手動欄位對應

Outlook 項目使用特定的欄位名稱來組織資料。當您將資訊匯入到 Outlook 資料夾時,從原始程式檔的欄位名稱必須完全符合那些在 Outlook 的目標項目。如果這些欄位不相符,您預期要填入資料的欄位將為空白。對應來自各種來源的資料會要求您檢查及必要時,以手動方式編輯欄位名稱。在另外必須要有定義該資訊中的每個資料行的標題列。這是不同的提供選項對應欄位,而標頭資料列不可以讓您的 Outlook 97。

為了要進行匯入從逗點分隔值 (CSV) 與定位點分隔值 (TSV) 檔案時,手動將欄位對應,標頭記錄中的欄位值必須完全符合對應的 [Outlook] 欄位進行編輯。欄位名稱記錄的資料檔是該檔案的第一行,並包含要匯入資料的欄位名稱。例如欄位名稱"F_Name"資料來源中的可以參考個別的第一個名稱。欄位名稱會變更為 Outlook 匯入中的對應為 [第一名稱] 因為 Outlook 會使用名為該欄位及其內部命名。產生的 Outlook 欄位標籤的範例資訊,請參閱區段產生 Outlook 欄位的範例。

此外,由 Microsoft 程式 (如 Microsoft Excel]、 [Microsoft Word]、 [Microsoft Access] 及 [Microsoft Fox 專業人員所建立的資料檔案也需要進行編輯,使標頭記錄中的欄位,完全符合標準 Outlook 欄位。

開啟資料庫連接 ODBC 驅動程式需要匯入這些程式所建立的檔案。 從 Dataacc.exe 檔案隨附 Valupack 與 Outlook 提供執行安裝程式來安裝這些驅動程式。使用者沒有 Office 97 或 Outlook 98 光碟片可能從 Outlook 增強功能] 網頁下載 Dataacc.exe 依照下列步驟執行:

  1. 在 [說明] 功能表上指向 [在 Web 上的 Microsoft,然後按一下 [自由專區]。
  2. 按一下 [Microsoft 資料存取組件],再遵循下載指示。

    注意: Fox 專業人員限制欄位標籤以 10 個字元。大部份的 Outlook 欄位標籤超過 10 個字元。若要準備 Fox 專業人員的檔案,匯入 Outlook 您必須先將檔案匯出 TSV 或 CSV 檔案、 編輯欄位標籤,在標頭的記錄,然後使用做為資料來源的 [該 CSV 檔案。

    如果文字或 ODBC 檔案包含不是內部的 Outlook 名稱的名稱,沒有資料會匯入。而且,每個 Outlook 物件擁有所需的一或兩個欄位。如果匯入檔案中沒有這些欄位就會出現錯誤對話方塊列出該物件型別的必要的欄位。必要的欄位是:
       Calendar folder:   Subject, Start Date
       Contacts folder:   None
       Journal folder:    Start Date, Journal Type
       Mail folder:       Subject
       Notes folder:      Body
       Tasks folder:      Subject
    					

產生 Outlook 欄位的範例

在編輯資料來源之前可能會產生在 Outlook 中使用欄位的範例會很有幫助。若要產生範例欄位,請依照下列步驟執行:
  1. 如果有的話,移除名為目前的二進位對應檔案,位於 [Windows] 資料夾中 「 逗點 Separated 值.ADR Windows"。此程序將會重建這個檔案。
  2. 如果已經沒有顯示,請在 [檢視] 功能表上按一下 [資料夾清單]。
  3. 資料夾清單] 中 針對您想要產生一個範例會和 [捷徑] 功能表中的 [Outlook] 資料夾上按一下滑鼠右鍵,然後按一下 [新增 資料夾]。

    注意: 每一個 Outlook 資料夾都有一欄位確定不同必要的組。比方說的 Outlook 連絡人必要的欄位集合會包含不會使用與行事曆的欄位。
  4. 請指定名稱給此暫存資料夾。一旦建立範例欄位檔案,您可能會刪除這個資料夾。
  5. 在 [檔案] 功能表上按一下 [匯入及匯出]。按一下 [匯出到檔案,然後按一下 [下一步]。
  6. 在 [要建立類型的檔案,按一下以選取 [逗點分隔值 (Windows),然後按一下 [下一步]。
  7. 在 [請 選取要匯出從資料夾,按一下以選取您在步驟 2 中建立的資料夾,然後按一下 [下一步]。
  8. 在 [另存匯出檔案為,輸入檔案的名稱,然後按一下以選取您要將檔案儲存的資料夾的 [瀏覽]。按一下 [確定] 以儲存匯出的檔案,再按 [下一步],然後按一下 [完成]。
產生的逗點分隔的值檔案包含 Outlook 為您所選取的資料夾使用的欄位。重複此步驟視每一種您想要匯入的資料。同時 Outlook 欄位標籤 familiarizing 自行項,請注意精確拼字是必要的。比方說在定義電子郵件地址時 Outlook 使用拼字 」 電子郵件。

自動對應的檔案

如果使用下列的個人資訊管理 (PIM) 軟體產品的任何匯入及匯出精靈會包括自動將對應的欄位名稱指派給密切符合 Outlook 欄位名稱能力。

  • ACT! 2.0 連絡 Windows 的管理員
  • ACT! 3.0 連絡 Windows 的管理員
  • dBase
  • ECCO 2.0,3.0、 4.0
  • Lotus 藝廊 1.0 1.1
  • Lotus 藝廊 2.1
  • Lotus 藝廊 97
  • Schedule + 1.0
  • Schedule + 7.0
  • sidekick 95
  • Windows 2.0 的 sideKick
如果您要匯入由上述來源之一所產生的資料檔案,您需要安裝使用 Outlook 維護設定的 PIM 轉換程式。初始的 Outlook 設定選項可能無法安裝轉換程式這組。步驟來新增這些轉換程式都包含在 Outlook 的 [說明] 檔案中。若要存取這個項目,請參閱 < 參考 > 章節。

?考

如需有關匯入及匯出資料檔的詳細資訊,請參閱下列的發行項 「 Microsoft 知識庫 」 中:
發行項識別碼: 189181
標題: OL98: 如何對應到 Outlook 使用 Excel 的匯入的檔案

發行項識別碼: 180315
標題: OL98: 從 Microsoft Excel 中匯入需要已命名的範圍

發行項識別碼: 185418
標題: OL98: 遺漏匯入和匯出時的資料


如需有關將新元件加入至您在 [Office 小幫手的 Outlook 安裝輸入 新增元件]、 按一下 [搜尋],] 然後按一下 [若要檢視 安裝或移除個別的元件

DataViz,Inc.和上面所列的各種產品的供應商是廠商與 Microsoft 無關 ; 我們不以暗示或其他方式,提供與這些產品的效能或可靠性有關的保證。

屬性

文章編號: 182728 - 上次校閱: 2013年10月7日 - 版次: 1.2
這篇文章中的資訊適用於:
  • Microsoft Outlook 98 Standard Edition
關鍵字:?
kbnosurvey kbarchive kbmt kbdownload kb3rdparty kbexport kbhowto kbimport kbmigrate KB182728 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:182728
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com