Copia de seguridad del registro no aparece enumerada en la herramienta Comprobador del registro

Seleccione idioma Seleccione idioma
Id. de artículo: 182841 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando utiliza la herramienta Comprobador del registro (Scanreg.exe) para restaurar una copia de seguridad del registro, la copia de seguridad desde la que desea restaurar el registro puede no aparecer.

Causa

Este comportamiento puede producirse si la herramienta Comprobador del registro está configurada para mantener más de cinco copias de seguridad del registro.

Solución

Para solucionar este comportamiento, siga cualquiera de los métodos que se muestran a continuación:

Nota: Como se puede restaurar las copias de seguridad del registro sólo desde un símbolo del sistema, estos métodos supone que ya está en el símbolo del sistema.

Método 1

Configurar la herramienta Comprobador del registro para que sólo las copias de seguridad del cinco últimos registro se almacenan en la carpeta Windows\Sysbckup. Para ello, siga estos pasos:
  1. En el símbolo del sistema, escriba las líneas siguientes y presione ENTRAR al final de cada una:

    cd \windows
    Editar scanreg.ini
  2. Busque el "MaxBackupCopies =" línea.
  3. Cambie la línea de la siguiente forma:

    MaxBackupCopies = 5
  4. Presione ALT+A, presione G (para guardar), presione ALT+A y, a continuación, presione S (para salir).

Método 2

Si está intentando restaurar una copia de seguridad del registro posterior de los cinco enumerados en la herramienta Comprobador del registro, cambie el nombre anteriores copias de seguridad del registro hasta que la copia de seguridad desde la que desea restaurar el registro uno de los cinco enumerados. Para ello, escriba los siguientes comandos en un símbolo de sistema y, tras cada comando, presione ENTRAR

cd\windows\sysbckup
ren rb0 <nn>.cab rb0 <nn>.xxx


donde <nn> es un número entre 00 y 99.

Nota: La copia de seguridad del registro numeradas menor no puede ser la primera. Para determinar la primera copia de seguridad del registro, compruebe la fecha de la RB <nnn> archivo .cab.

Por ejemplo, la carpeta Windows\Sysbckup contiene siete copias de seguridad del registro numeradas Rb000.cab - Rb006.cab, con Rb000.cab es la primera copia de seguridad del registro y Rb006.cab siendo la más reciente. Para hacer que la herramienta Comprobador del registro que enumere las cinco copias de seguridad más recientes, escriba los comandos siguientes:

ren rb000.cab rb000.xxx
ren rb001.cab rb001.xxx

Más información

El "MaxBackupCopies =" línea en el archivo Scanreg.ini determina el número de copias de seguridad del registro mantenidas en la carpeta Windows\Sysbckup. Si el "MaxBackupCopies =" línea se establece a seis o superior (cinco es el valor predeterminado), el número correcto de las copias de seguridad del registro se mantiene en la carpeta Windows\Sysbckup, pero la herramienta Comprobador del registro sólo puede mostrar las cinco copias de seguridad más antiguas.

Para obtener información adicional acerca de cómo utilizar la herramienta Comprobador del registro, haga clic en Inicio, haga clic en Ayuda, haga clic en la ficha Índice, escriba el registro y, a continuación, haga doble clic en el tema "Comprobador de registro".

Propiedades

Id. de artículo: 182841 - Última revisión: lunes, 22 de enero de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Windows 98 Standard Edition
Palabras clave: 
kbmt kbenv kbprb KB182841 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 182841

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com