Ensoniq PCI Sound Card Experiences Static When Disk Is Accessed

Article translations Article translations
Article ID: 183069 - View products that this article applies to.
This article was previously published under Q183069
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

You have an EIDE/ATA hard drive and you have applied the fix mentioned in the following Knowledge Base article:

ARTICLE-ID: 153296
TITLE : Write Cache on IDE/ATAPI Disks Is Not Flushed on Shut Down


Your Ensoniq PCI Soundcard is experiencing static when the hard disk drive is accessed.

CAUSE

This problem is caused by a regression introduced in the fix mentioned in the above article. That hotfix includes two modifications to Atapi.sys. The first modification was to flush the write cache on the disk when the system is being shut down and the second added periodic flushes of the write cache by the file system. It is this second change that is causing the problem with the sound card. Because these flushes were being done synchronously, this was tying up the PCI bus long enough to prevent the Ensoniq driver from updating the synthesizer regularly. The fix to this problem was to make the flushes asynchronous, so they would not interfere with other drivers.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

This fix is a replacement for the fix described in the following Knowledge Base article and should be used in its place:

ARTICLE-ID: 153296
TITLE : Write Cache on IDE/ATAPI Disks Is Not Flushed on Shut Down

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 183069 - Last Review: October 7, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbqfe KB183069

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com