Article ID: 183237 - Last Review: October 31, 2006 - Revision: 1.1

Windows NT 4.0 Fails to Start on a Uniprocessor Compaq

This article was previously published under Q183237
Expand all | Collapse all

SYMPTOMS

After you install a post-Service Pack 3 (SP3) hotfix Ntoskrnl.exe dated 11/20/97 or later, the system fails to restart. The system will stop responding (hang) at the Blue screen listing the Windows NT version and service pack information. The personal computer is a uni-processor Compaq running Compaq's System Manager driver, Sysmgmt.sys.

CAUSE

Newer Ntoskrnl.exe code has been redesigned because of the Pentium errata bug. This new behavior conflicts with Compaq's Sysmgmt.sys driver, causing the driver to fail to load, which stops the system from starting.

RESOLUTION

Rename Sysmgmt.sys or get the latest driver from Compaq which resolves this problem.

Sysmgmt.sys is manufactured by Compaq Corp., a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

STATUS

This behavior is by design.

REFERENCES

For more information on the Pentium errata bug, please see the following Microsoft Knowledge Base article:

ARTICLE-ID: 163852  (http://support.microsoft.com/kb/163852/EN-US/ )
TITLE : Invalid Operand with Locked CMPXCHG8B Instruction



APPLIES TO
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbfaq kbprb KB183237
 

Article Translations