Help and Support

Error Message: Warning: Page Has Expired: The Page You Requested...

Article ID:183763
Last Review:November 4, 2003
Revision:3.0
This article was previously published under Q183763

SYMPTOMS

When you click Back to return to a Web page, you may receive the following error message:
Warning: Page has Expired
The page you requested was created using information you submitted in a form. This page is no longer available. As a security precaution, Internet Explorer does not automatically resubmit your information for you.

To resubmit your information and view this Web page, click the Refresh button.

Back to the top

CAUSE



This problem can occur for either of the following reasons:
You have the "Do not save encrypted pages to disk" option enabled in Internet Explorer Advanced Settings.
You are connected to an Active Server Page (.asp) Web page on a Microsoft Internet Information Server (IIS) version 4.0 server, and the Web page uses the "cache-control: private" tag in the header.
NOTE: This problem only occurs on HTTP/1.1-compliant servers. Cache- control directives are not supported on HTTP/1.0 servers.

Back to the top

RESOLUTION

To resolve this problem, either disable the "Do not save encrypted pages to disk" option, or obtain and install the latest version of Internet Explorer. You can obtain the latest version of Internet Explorer from the following Microsoft Web site:
http://www.microsoft.com/windows/ie/ (http://www.microsoft.com/windows/ie/)
To work around this behavior, have the administrator for the Web page place the following tag in the header of the .asp Web page:
<%Response.CacheControl="Public"%>
				

Back to the top

STATUS

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer versions 4.0 and 4.01 for Windows 95.

Back to the top

MORE INFORMATION

The behavior described in this article can occur if an .asp Web page uses the METHOD=POST attribute in the Form Submit tag, but not if the page uses the METHOD=GET attribute.

IIS 4.0 servers use the "cache-control: private" tag by default.

Back to the top


APPLIES TO
Microsoft Internet Explorer 4.01 128-Bit Edition
Microsoft Internet Explorer 4.0 128-Bit Edition

Back to the top

Keywords: 
kbenv kbprb KB183763

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.