Numéro d'article: 184291 - Dernière mise à jour: lundi 10 juillet 2006 - Version: 7.1

PROBLÈME : Les objets COM ne peuvent pas lancer d'impression lorsqu'ils sont appelés à partir d'ASP.

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.
Ancien nº de publication de cet article : F184291
Agrandir tout | Réduire tout

Symptômes

Une impression lancée par un objet COM échoue lorsque ce dernier est appelé depuis l'Active Server Pages (ASP). Cependant, elle est correctement effectuée si l'objet COM est appelé à partir d'une application interactive. Cet objet COM peut être un produit commercial, une application de Microsoft Office par exemple, ou un objet personnalisé d'un autre fabricant. Voici un message d'erreur qui apparaîtra fréquemment : " ClassName error '800a01e2' Printer error ".

Cause

Les API standard dont se servent la plupart des objets pour lancer une impression dépendant des entrées du Registre qui se trouvent sous HKEY_CURRENT_USER. Cette ruche est dynamique. Des informations différentes y seront chargées selon le contexte utilisateur dans lequel s'exécute le processus. Les pages ASP sont exécutées sous IIS qui s'exécute avec le compte SYSTEME. Si vous créez une occurrence d'un objet COM dans ce code ASP, elle s'exécutera aussi avec le compte SYSTEME. Aucune imprimante, par défaut, n'est configurée dans le Registre du compte SYSTEME.

Résolution

Pour résoudre ce problème, vous pouvez installer des imprimantes pour le compte SYSTÈME. pour cela, procédez comme suit :

Pour appliquer cette méthode, vous devez modifier le Registre à l'aide de l'Éditeur du Registre.

AVERTISSEMENT : Une utilisation incorrecte de l'Éditeur du Registre peut provoquer de graves problèmes susceptibles de s'étendre à tout le système : vous pourriez avoir besoin de réinstaller Windows pour les corriger. Microsoft ne garantit pas que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre pourront être résolus. Vous utilisez cet outil sous votre entière responsabilité.
  1. Assurez-vous que les imprimantes que vous souhaitez utiliser sont installées sur le compte utilisateur par lequel vous êtes connecté au serveur.
  2. Lancez l'Éditeur du Registre (Regedit.exe).
  3. Sélectionnez la clé suivante :
     HKEY_CURRENT_USER
        \Software\Microsoft\Windows NT\Current Version\Devices
    
  4. À partir du menu du Registre, cliquez sur Exporter fichier Registre.
  5. Dans la zone Nom du fichier, tapez c:\Devices.reg.
  6. Sélectionnez la clé suivante :
     HKEY_CURRENT_USER
        \Software\Microsoft\Windows NT\Current Version\PrinterPorts
    
  7. À partir du menu du Registre, cliquez sur Exporter fichier Registre.
  8. Dans la zone Nom du fichier, tapez c:\PrinterPorts.reg.
  9. Sélectionnez la clé suivante :
     HKEY_CURRENT_USER
        \Software\Microsoft\Windows NT\Current Version\Windows
    
  10. À partir du menu du Registre, cliquez sur Exporter fichier Registre.
  11. Dans la zone Nom du fichier, tapez c:\Windows.reg.
  12. À partir du bouton Démarrer, sélectionnez Exécuter. Ouvrez le fichier Devices.reg dans le bloc-notes en tapant Notepad Devices.reg dans la boîte de dialogue Exécuter.
  13. Remplacez le texte HKEY_CURRENT_USER par HKEY_USERS\.DEFAULT
  14. Enregistrez le fichier. Ensuite, importez-le dans le Registre en double-cliquant sur le fichier dans l'Explorateur Windows.
  15. Répétez les étapes 13 à 15 pour les fichiers PrinterPorts.reg et Windows.reg.

Références

Pour consulter les derniers articles de la Base de connaissances et accéder à d'autres informations sur Visual InterDev et Active Server Pages, consultez la page suivante du site Internet du Support technique de Microsoft :
http://support.microsoft.com/search/default.aspx?qu=vinterdev (http://support.microsoft.com/search/default.aspx?qu=vinterdev)




(c) Microsoft Corporation 1998, Tous droits réservés.
Contributions de John Lewis, Microsoft Corporation.


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Active Server Pages 4.0
  • Microsoft Internet Information Server 4.0
  • Microsoft Internet Information Services 5.0
Mots-clés : 
kbaspobj kbcodesnippet kbcomt kbdsi kberrmsg kbgrpasp kbregistry kbsecurity KB184291
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.