NetWare API Log Logical Record may Incorrectly Succeed

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Article ID: 185142 - View products that this article applies to.
This article was previously published under Q185142
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SYMPTOMS

When running an application on a Windows NT computer with Client Services for NetWare (CSNW) or Gateway Services for NetWare (GSNW) installed, the NetWare API Log Logical Record may have succeeded even though another client computer already owned the lock. Additionally, if a Windows NT computer owned the lock, other client requests for the same lock may have succeeded even though they should failed.

CAUSE

Incorrect data is being sent to the NetWare (or compatible) server in the Log Logical Record request by the Windows NT client. This causes the server to return a success to the log call with a different lock being logged. Thus, the call is succeeding even though the lock is already owned.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

NOTE: This hotfix supersedes the fix referred to in the following articles in the Microsoft Knowledge Base:

ARTICLE-ID: 185137
TITLE : Log Logical Record Request May Be Sent to Wrong Server

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 185142 - Last Review: October 7, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbqfe KB185142

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