Article ID: 185740 - Last Review: February 24, 2004 - Revision: 5.0

Unable to Add/Remove SBS Components with Renamed Admin Account

This article was previously published under Q185740
Expand all | Collapse all

SYMPTOMS

When you use the Control Panel Add/Remove Programs tool to reinstall Microsoft BackOffice Small Business Server components, the following error message may be displayed:
Invalid User Login
Only the Domainname Administrator is supposed to run this program, where Domainname is the domain name of the Small Business Server. The same error message occurs by running the Startsam.exe program.

CAUSE

Access to the Small Business Server installer is restricted to the Windows NT Administrator account. Only the Administrator account can reinstall Small Business Server components. The user is not logged on to the server with the account named Administrator.

RESOLUTION

Log on to the Small Business Server with the account named Administrator. If the account has been renamed, temporarily rename it back to Administrator, and then run the installer program. When the program is finished, you may rename the account again.

STATUS

Microsoft has confirmed this to be a problem in Microsoft BackOffice Small Business Edition. We are researching this bug and will post new information here in the Microsoft Knowledge Base as it becomes available.

APPLIES TO
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.0
Keywords: 
kbbug kbnofix KB185740
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations