XADM: Cannot Run ISINTEG -PATCH on Cluster Server Computer

Article translations Article translations
Article ID: 185942 - View products that this article applies to.
This article was previously published under Q185942
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

After you run the Microsoft Exchange Information Store Integrity Checker (Isinteg.exe) with the -PATCH option on an Exchange Server computer on which Microsoft Cluster Server is installed, you may be unable to start the information store. When you attempt to do so, you may receive an error message indicating that the information store and directory databases are inconsistent and that you need to run the ISINTEG -PATCH command again.

Note that this problem occurs even when you properly set the _CLUSTER_NETWORK_NAME_ environment variable before you run Isinteg.exe with the -PATCH option.

CAUSE

When you run Isinteg.exe with the -PATCH option, it modifies the base GUID (generated unique ID or globally unique identifier) used by the information store, but it does not notify Microsoft Cluster Server that the change has taken place. This causes Microsoft Cluster Server to overwrite the new base GUID, because it thinks the GUID is invalid.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.5. This problem has been corrected in the latest U.S. service pack for Microsoft Exchange Server version 5.5. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K

MORE INFORMATION

For additional information about setting the _CLUSTER_NETWORK_NAME_ environment variable before you run Isinteg.exe with the -PATCH option, please see the following article in the Microsoft Knowledge Base:
178311 XADM: Error Running ISINTEG on a Cluster Server

Properties

Article ID: 185942 - Last Review: October 8, 2013 - Revision: 3.4
APPLIES TO
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB185942

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com