PRB:錯誤訊息:403.7 禁止: 需要用戶端憑證

文章翻譯 文章翻譯
文章編號: 186812 - 檢視此文章適用的產品。
Microsoft 強烈建議所有使用者升級為在 Microsoft Windows Server 2008 上執行的 Microsoft Internet Information Services (IIS) 7.0 版。IIS 7.0 能夠大幅提升網頁基礎結構的安全性。如需有關 IIS 安全性主題的詳細資訊,請造訪下列 Microsoft 網站:
http://technet.microsoft.com/zh-tw/library/dd450371(WS.10).aspx (英文)
如需有關 IIS 7.0 的詳細資訊,請造訪下列 Microsoft 網站:
http://www.iis.net/default.aspx?tabid=1
全部展開 | 全部摺疊

徵狀

當您嘗試與需要用戶端驗證的網站建立通訊時,可能會收到下列錯誤訊息:
HTTP 錯誤 403
403.7 禁止: 需要用戶端憑證

發生的原因

當您嘗試存取的資源需要您的瀏覽器具備伺服器可識別的用戶端安全通訊端層 (SSL) 憑證時,就會發生這個錯誤。這用來驗證您是資源的有效使用者。請連絡網頁伺服器的系統管理員,以取得有效的用戶端憑證。

出現此問題有幾種可能原因:
  • 執行 IIS 的電腦上未安裝用戶端憑證發出伺服器的根憑證 (憑證授權單位的憑證)。

    - 或 -
  • 用戶端憑證已過期或尚未達到有效期限。

    - 或 -
  • 用戶端憑證已被撤銷。

解決方案

根據您問題的原因,請嘗試下列解決方法:
  • 在伺服器電腦的瀏覽器中下載伺服器根憑證。執行位於 Inetsrv 目錄中的 Iisca.exe 命令列公用程式。
  • 檢查用戶端憑證的有效日期,確定該日期和時間在有效範圍內。檢查過期日,確定憑證尚未過期。
  • 連絡您的憑證授權單位,查看您的憑證是否過期。

其他相關資訊

Microsoft Internet Explorer 4.0 和 IIS 4.0 將其根憑證儲存在不同的登錄位置。Iisca.exe 公用程式會同步處理兩個根憑證存放區。

屬性

文章編號: 186812 - 上次校閱: 2013年12月2日 - 版次: 7.0
這篇文章中的資訊適用於:
  • Microsoft Internet Information Server 3.0
關鍵字:?
kbprb kbprod2web KB186812
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com