Kontrola databázy Registry pokračuje na zistenie poškodení databázy Registry

Preklady článku Preklady článku
ID článku: 186909
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri spustení systému Windows, nástroj Kontrola databázy Registry môže zobraziť nasledovné Správa:
Databázu registry systému Windows je poškodený. Systém Windows reštartovať a pokúsiť sa opraviť problém.

Kliknutím na tlačidlo OK sa môže zobraziť rovnaké hlásenie po reštartovaní systému Windows.

Všimnite si, že beží reálneho režimu verzia kontrola databázy Registry (Scanreg.exe) na príkaz príkazový riadok nerozpozná poškodení databázy registry, a Windows Millenium Edition nepodporuje reálneho režimu Scanreg.exe.

PRICINA

Tento problém sa môže vyskytnúť, ak je chybná pamäť v počítači. A chybný pamäťový čip môže poškodiť databázy registry v pamäti. Systémom Windows (alebo chránený režim) verzia sken databázy Registry Checker (Scanregw.exe) databáza Registry v pamäti za škodu.

Ak sa tento problém vyskytne, Scanregw.exe zistí, že databázy registry je poškodená v pamäti a značky registru ako poškodené, tak že pre reálny režim Scanreg.exe je spustený ďalší čas spustení počítača. Scanreg.exe môže nemožno zistiť akékoľvek poškodenie ak chybné pamäte sa nepoužije v reálnom režime, a môžu umožniť Windows spustiť normálne.

RIESENIE

Existujú dva spôsoby, ktoré môžete použiť na identifikáciu či chybné pamäte čipy sú príčinou problému:

Postup č. 1

Odstrániť alebo nahradiť pamäťové čipy v počítači, či problém vyriešil.

Metóda 2

Pokúste sa obmedzí množstvo pamäte, ktorú systém Windows používa. Ak obmedzenie množstvo pamäte, ktorú systém Windows používa vyrieši problém, problém je v chybný pamäťový čip. Obmedziť veľkosť pamäte používa systém Windows, postupujte nasledovne:
  1. Reštartujte systém Windows v núdzovom režime. Chcete tak urobiť, reštartujte počítač, stlačte a podržte kláves CTRL, kým sa neobjaví ponuka spustenia systému Windows 98, a potom vyberte núdzovom režime.
  2. Kliknite na tlačidlo Štart, ukážte na položku programy, ukážte na položku Príslušenstvo, ukážte na systém Nástroje a potom kliknite na položku Systémové informácie.
  3. V ponuke Nástroje kliknite na položku Pomôcka konfigurácie systému.
  4. Na karte Všeobecné kliknite na tlačidlo Spresniť.
  5. Kliknutím vyberte Limit pamäte na <n>MB políčko a nastavte hodnotu teda 16 megabajtov (MB). <b00></b00></n>

    Poznámka: Obmedzenie na menej než 16 MB pamäte môže zabrániť systému Windows z zaťaženie. Ak ste schopný spúšťať systém Windows normálne, systém Windows spustiť v Núdzovom režime a potom vypnúť túto možnosť stlačením a podržaním Kláves SHIFT počas spustenia.
  6. Kliknite na tlačidlo OK a potom kliknite na tlačidlo OK.
  7. Reštartujte počítač normálne.


Ďalšie informácie o riešení problémov s pamäťou, prosím pozrite nasledujúce články v databáze Microsoft Knowledge Base:
ID ČLÁNKU: 134503
Názov: Parita chybové hlásenia môže naznačovať, zlé pamäti

ID ČLÁNKU: 142546
Názov: Ako používať jednotku RAM na riešenie problémov s pamäťou

STAV

Toto správanie je predvolené.

DALSIE INFORMACIE

Kontrola databázy Registry môžete vypnúť tak, že sa na nespustí automaticky pri spustení. Ak chcete vypnúť kontrola databázy Registry, použite nasledujúce kroky.

Upozornenie: Spoločnosť Microsoft neodporúča vypnutie kontrola databázy Registry. Tento nástroj automaticky stráže proti problémom, ktoré môžu spôsobiť, že počítač nepoužiteľný. Symptóm opísané v tomto článku môžu zdokladovať väčší problém, že by mali identifikovať a riešiť.
  1. Reštartujte systém Windows v núdzovom režime. Chcete tak urobiť, reštartujte počítač, stlačte a podržte kláves CTRL, kým sa neobjaví ponuka spustenia systému Windows 98, a potom vyberte núdzovom režime.
  2. Kliknite na tlačidlo Štart, ukážte na položku programy, ukážte na položku Príslušenstvo, ukážte na systém Nástroje a potom kliknite na položku Systémové informácie.
  3. V ponuke Nástroje kliknite na položku Pomôcka konfigurácie systému.
  4. Kliknite na kartu spustenie.
  5. Kliknutím zrušte začiarknutie políčka ScanRegistry.
  6. Kliknite na tlačidlo OK.
  7. Reštartujte systém Windows normálne.
Kontrola databázy Registry pozostáva z oboch systémom Windows (chránený režim) a MS-DOS-založené (reálneho režimu) verzia nástroja. Verziu založenú na systéme Windows (Scanregw.exe) prehľadáva registry pre škody a prázdne dátových štruktúr (klávesy označené ako odstránené), a raz zálohuje konfiguračné súbory pri spustení každý deň. Ak je zistený poškodení databázy registry, nástroj nastaví vlajkou škody v databázy registry na vyvolanie nástroja reálneho režimu, a vy sa výzva na reštartovanie počítač. Ak databáza registry obsahuje viac ako 500 KB prázdne údajov štruktúry, optimalizácia vlajky je nastavený v databáze registry a pre reálny režim nástroj sa vyvolá ďalšom spustení počítača na optimalizáciu databáza Registry.

Keď registry príznak spustíte nástroj vo reálny režim (Scanreg.exe) pri štarte je nastavená na poškodenie alebo optimalizácia. Ak je nastavený príznak škody, Scanreg.exe prehľadáva registry pre škody a potom automaticky obnoví naposledy uložené zálohovacej množiny. Zálohovanie sa extrahuje na dočasné súborov a pred nahradí aktuálne súbory skontrolovať škody. Ak Zálohovanie je poškodený, ďalšie posledné zálohovanie sa obnoví. Ak žiadne zálohovanie zostávajú, Scanreg.exe pokusy o opravu škody opätovným zostavením databázy registry bez chyby alebo prázdne dátových štruktúr. Ak je nastavený príznak optimalizácia, Register je komprimovaný odstránením všetkých ale 4 KB zástupný symbol pre každého prázdne dátové štruktúry. Databázy registry nie je prestavanými keď je optimalizovaný; 4 KB zostáva slúžiť ako zástupný symbol v rámci aktuálnej databázy registry.

Ďalšie informácie o nástroji Kontrola databázy Registry nájdete v nasledujúce články v databáze Microsoft Knowledge Base:
ID ČLÁNKU: 183887
Názov: Opis nástroj Checker Registry systému Windows (Scanreg.exe)

ID ČLÁNKU: 183603
Názov: Ako prispôsobiť nastavenia databázy Registry pre nástroj Kontrola

ID ČLÁNKU: 184023
Názov: Prepínače príkazového riadka pre nástroj databázy Registry Checker
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Vlastnosti

ID článku: 186909 - Posledná kontrola: 19. októbra 2011 - Revízia: 2.0
Kľúčové slová: 
kbhardware kbprb kbmt KB186909 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:186909

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com