Fórmulas para contar las repeticiones de texto, caracteres o palabras en Excel para Mac

Seleccione idioma Seleccione idioma
Id. de artículo: 187667 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Este artículo contiene fórmulas que calculan lo siguiente:
  • El número de repeticiones de una cadena de texto en un rango de celdas.
  • El número de repeticiones de un carácter en una celda.
  • El número de repeticiones de un carácter en un rango de celdas.
  • El número de palabras (o cadenas de texto) separadas por un carácter en una celda.

Más información

Fórmula para contar el número de repeticiones de una cadena de texto en un rango

Para contar el número de repeticiones de una cadena de texto en un rango, utilice la siguiente fórmula:
=SUM(LARGO(<rango>)-LARGO(SUSTITUIR(<rango>,"texto","")))/LARGO("texto")
donde <rango> es el rango de celdas en cuestión y "texto" se sustituye por la cadena de texto específico que desea contar.

Nota: la fórmula anterior se debe insertar como una fórmula de matriz. Para insertar una fórmula como fórmula de matriz, presione COMANDO+RETORNO.

La fórmula se puede dividir entre la longitud de la cadena de texto dado que la suma de la longitud de caracteres del rango disminuye en un múltiplo de cada repetición de la cadena de texto. Esta fórmula puede sustituir a todas las fórmulas anteriores que se describen en este artículo, excepto a la que cuenta el número de palabras de una celda.

Ejemplo 1: Recuento del número de repeticiones de una cadena de texto en un rango

  1. Inicie Microsoft Excel y abra un nuevo libro.
  2. En la Hoja1, escriba lo siguiente:
          A1: fruta
          A2: manzana,manzana
          A3: naranja
          A4: manzana,naranja
          A5: uva
          A6: naranja,uva
          A7: uva, manzana
          A8: =SUMA(LARGO(A2:A7)-LARGO(SUSTITUIR(A2:A7,"manzana","")))/LARGO("manzana")
    						
    NOTA: la fórmula anterior se debe insertar como una fórmula de matriz. Para insertar una fórmula como fórmula de matriz, presione COMANDO+RETORNO.
El valor de la celda A8 es 4 porque el texto "manzana" aparece cuatro veces en el rango.

Fórmula para contar el número de repeticiones de un único carácter en una celda

Si le preocupa la búsqueda de un solo carácter en una celda, la fórmula se simplifica a:
=LARGO(<rango>)-LARGO(SUSTITUIR(<rango>,"a",""))
donde <rango> es el rango de celdas en cuestión y "a" se sustituye por el carácter que desea contar.

NOTA: Esta fórmula no es necesario que se inserte como una fórmula de matriz.

Ejemplo 2: Recuento del número de repeticiones de un carácter en una celda

Utilice los mismos datos del ejemplo anterior; suponga que desea contar el número de repeticiones o el carácter "p" en A7. Escriba la fórmula siguiente en la celda A9:
A9: =LARGO(A7)-LARGO(SUSTITUIR(A7,"p",""))
El valor de la celda A9 es 3 porque el carácter "p" aparece tres veces en A7.

Fórmula para contar el número de repeticiones de un solo carácter en un rango

Si le preocupa la búsqueda de un solo carácter en un rango, la fórmula se simplifica a:
=SUMA(LEN(rango)-LARGO(SUSTITUIR(rango,"a","")))
donde <rango> es el rango de celdas en cuestión y "a" se sustituye por el carácter que desea contar.

Nota: la fórmula anterior se debe insertar como una fórmula de matriz. Para insertar una fórmula como fórmula de matriz, presione COMANDO+RETORNO.

Ejemplo 3: Recuento del número de repeticiones de un carácter en un rango

Utilice los mismos datos del ejemplo anterior; suponga que desea contar el número de repeticiones o el carácter "p" en A2:A7. Escriba la siguiente fórmula siguiente en la celda A10:
A10: =SUMA(LARGO(A2:A7)-LARGO(SUSTITUIR(A2:A7,"p","")))
NOTA: la fórmula anterior se debe insertar como una fórmula de matriz. Para insertar una fórmula como fórmula de matriz, presione COMANDO+RETORNO.

El valor de la celda A10 es 11 porque el carácter "p" aparece once veces en A2:A7.

Fórmula para contar el número de palabras separadas por un carácter en una celda

La fórmula siguiente cuenta el número de palabras de una celda que están separadas por un carácter específico:
=SI(LARGO(ESPACIOS(<ref_celda>))=0,0,LARGO(<ref_celda>)- LARGO(SUSTITUIR(<ref_celda>,<char>,""))+1)
donde <ref_celda> es la referencia a la celda y <char> es el carácter que separa las palabras.

Nota: no hay ningún espacio en la fórmula anterior; se utilizan varias líneas para adaptar la fórmula a este documento. No incluya espacios en blanco cuando escriba en la celda. Esta fórmula no es necesario que se inserte como una fórmula de matriz.

Ejemplo 4: Recuento del número de palabras separadas por un espacio en una celda

Para contar el número de palabras de una celda donde las palabras están separadas por un carácter de espacio, siga estos pasos:
  1. Inicie Microsoft Excel y abra un nuevo libro.
  2. En la Hoja1, escriba lo siguiente:
         A1: El coche iba rápido
         A2: =SI(LARGO(ESPACIOS(A1))=0,0,LARGO(ESPACIOS(A1))-LARGO(SUSTITUTO (A1," ",""))+1)
La fórmula de la celda A2 devuelve un valor de 4 para reflejar que la cadena contiene cuatro palabras deparadas por espacios. No importa si las palabras están separadas por varios espacios o si las palabras comienzan o finalizan con un espacio. La función ESPACIOS quita los caracteres de espacio adicionales y los caracteres de espacio de inicio y finalización del texto de la celda.

En Microsoft Excel, también puede utilizar una macro para contar las repeticiones de un carácter específico en una celda o rango de celdas. Para obtener información adicional al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
89794 Cómo usar Visual Basic para Aplicaciones para contar las repeticiones de un carácter en una selección en Excel

Propiedades

Id. de artículo: 187667 - Última revisión: viernes, 30 de agosto de 2013 - Versión: 8.0
La información de este artículo se refiere a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Macintosh
  • Microsoft Excel 98 para Macintosh
Palabras clave: 
kbhowto KB187667

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com