Help and Support
 

powered byLive Search

[IIS] ErrMsg: CoGetClassObject, 0x80080005 サーバーの実行に失敗しました

文書番号:187710
最終更新日:2004年5月18日
リビジョン:4.1
この記事は、以前は次の ID で公開されていました: JP187710

現象

Windows NT Option Pack の Setup プログラムを起動すると、次のエラー メッセージが表示されることがあります。
CoGetClassObject 0x80080005 サーバーの実行に失敗しました。

また、イベント ビューアには次のようなログが記録されることがあります。
Service Control Manager. イベント ID 7003
IIS Admin Serviceは次の存在しないサービスに依存します :
Protected Storage

DCOM Event ID 10005
サーバ:{A9E89610-B80D-11D0-B9B9-00A0C922E750}を実行するために
IISADMIN(引数"")を起動しようとしたときに、DCOMでエラー " 依存
関係サービスが存在しないか、または削除の対象としてマークされていま
す。 " が発生しました。

先頭へ戻る

原因

この問題は、Protected Storage、RPC Configuration、または Windows NT LM Security Support Provider サービスが開始されていない、インストールされていない、または破損している場合に発生することがあります。

先頭へ戻る

解決方法

問題を解決するには、次のいずれかの方法を実行してください。
? 開始されていないサービスを開始します。
1. コントロールパネルの [サービス] を起動します。
2. Remote Procedure Call (RPC) サービスを開始します。


または
? 壊れているサービスを削除し、再インストールします。
1. コントロールパネルの [ネットワーク] を起動し、[サービス] タブを表示します。
2. [サービス] タブで "RPC 構成" サービスを追加します。注 : この手順を実行する際、Windows NT 4.0 コンパクト ディスクを要求されます。
3. 現行または最新のサービスパックを再適用します。


注意 : Protected Storage サービスは、Internet Explorer 4.01 によりインストールされます。Internet Explorer 4.01 を再インストールする前に、Internet Information Server (IIS)、Proxy Server、Site Server など、Internet Explorer に依存するサービスに必要なバックアップを作成してください。Internet Explorer の再インストール後、Internet Explorer に依存するサービスを再インストールします。

関連情報については、Microsoft Knowledge Base の次の資料を参照してください。
187870 (http://support.microsoft.com/kb/187870/EN-US/) : How to Remove and Reinstall the Windows NT 4.0 Option Pack

先頭へ戻る

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 187710 (http://support.microsoft.com/kb/187710/EN-US/) (最終更新日 2000-10-27) をもとに作成したものです。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Windows NT version 4.0 Option Pack
?Microsoft Internet Information Server 4.0

先頭へ戻る

キーワード:?
kbprb KB187710

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.