Article ID: 187868 - Last Review: October 28, 2006 - Revision: 3.5

XADM: Downloading Messages Using Outlook Express Crashes Store

This article was previously published under Q187868
Expand all | Collapse all

SYMPTOMS

A Dr. Watson error occurs with the Store.exe process when you are downloading messages using a POP3 client, such as Outlook Express.

CAUSE

A full-fidelity download of a multipart/alternative type message is failing, where the text/plain alternative type is a tag without a content- type header, which causes the crash. The information store does not convert the message properly when using Outlook Express build 4.72.2106.4(Internet Explorer 4.01).

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For more information, please see the following article in the Microsoft Knowledge Base:
191014  (http://support.microsoft.com/kb/191014/EN-US/ ) XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

WORKAROUND

This is not an issue using the Outlook 98 client.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 5.0 and 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 2.

MORE INFORMATION

The issue was resolved by changing the inbound text converter, so that if the content-type header is missing, the converter sets the media type for the node to TEXT/PLAIN, so that cvtrLookup does not see a NULL string.

APPLIES TO
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbqfe KB187868
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations