Random Stop 0x50 Errors on Cirrus Video Adapters

Article translations Article translations
Article ID: 188303 - View products that this article applies to.
This article was previously published under Q188303
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

On systems with some Cirrus-compatible video adapters, Windows NT may randomly and infrequently stop responding (hang) and report the following blue screen error message:

STOP 0x00000050 error
PAGE_FAULT_IN_NONPAGED_AREA.

CAUSE

The GDI in Windows NT requires 8-byte alignment on the bitmaps it is expected to draw on. Cirrus's driver provides 4-byte alignment instead of 8. This may cause problems on some video adapters where output requests are delivered to GDI.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 188303 - Last Review: October 9, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbqfe KB188303

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com