Article ID: 188715 - Last Review: July 7, 2008 - Revision: 8.1 Global ASA Not Firing When Visual InterDev Made IIS 4.0 ApplicationThis article was previously published under Q188715 We strongly recommend that all users upgrade to Microsoft Internet Information Services (IIS) version 7.0 running on Microsoft Windows Server 2008. IIS 7.0 significantly increases Web infrastructure security. For more information about IIS security-related topics, visit the following Microsoft Web site: http://www.microsoft.com/technet/security/prodtech/IIS.mspx
(http://www.microsoft.com/technet/security/prodtech/IIS.mspx)
For more information about IIS 7.0, visit the following Microsoft Web site: http://www.iis.net/default.aspx?tabid=1
(http://www.iis.net/default.aspx?tabid=1)
SYMPTOMS
After creating a new application with Visual InterDev on Internet
Information Server 4.0 (IIS), the code in the Global.asa for this
application does not execute. A common symptom is while an administrator
is logged into the IIS 4.0 computer, applications are created successfully,
and when an administrator is not logged into the IIS computer, projects
are not created as applications.
CAUSE
If the virtual directory that contains the Global.asa is not set as an
Application Root, the code in the Global.asa will not be executed. Visual
InterDev will be unable to create an application root if the Microsoft
Transaction Server (MTS) system package logon identity is set to
"Interactive user - the current logged on user" and no one is currently
logged on or the current logged on does not have the proper permissions to
create an MTS package.
RESOLUTION
During the installation of Internet Information Server 4.0, a user can
specify the account for MTS sessions to run under. By default, the
Interactive User is specified. What this means is that when there is no
Interactive User (for example, an administrator is not logged onto the Web
server), administrative operations that require authentication, such as
creating an Application Root, fail.
Use the following steps to resolve existing problems:
Follow these steps to use the user manager:
REFERENCES
For more information about application settings, see the "Configuring
Applications" topic in the Windows NT 4.0 Option Pack online
documentation.
For the latest Knowledge Base articles and other support information on Visual InterDev and Active Server Pages, see the following page on the Microsoft Technical Support site:
http://support.microsoft.com/search/default.aspx?qu=vinterdev
(http://support.microsoft.com/search/default.aspx?qu=vinterdev)
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