Globální ASA nelze aktivaci při Visual InterDev provedených IIS 4.0 aplikace

Překlady článku Překlady článku
ID článku: 188715 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Důrazně doporučujeme, aby všichni uživatelé upgradovat Internetová informační služba (IIS) verze 7.0 systémem Microsoft Windows Server 2008. IIS 7.0 výrazně zvyšuje zabezpečení webové infrastruktury. Další informace o tématech souvisejících se zabezpečením Internetové informační služby naleznete na následujícím webu společnosti Microsoft:
http://www.microsoft.com/technet/security/prodtech/IIS.mspx
Další informace o službě IIS 7.0 naleznete na následujícím webu:
http://www.iis.net/default.aspx?tabid=1
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Po vytvoření nové aplikace Visual InterDev na Internet Information Server 4.0 (IIS) se nespustí kód Global.asa této aplikace. Běžné příznaku je během přihlášen správce počítače IIS 4.0 úspěšně vytvořen aplikací a když do počítače IIS není přihlášen správce, projekty nejsou vytvořeny jako aplikace.

Příčina

Pokud virtuální adresář obsahuje Global.asa není nastavena jako kořen aplikací, kód Global.asa provedeny. Visual InterDev nelze vytvořit kořenový adresář aplikace, pokud je identita přihlášení balíček systému Microsoft Transaction Server (MTS) nastavena na "Interaktivní uživatel – aktuálně přihlášený uživatel" a nikdo je aktuálně přihlášen nebo aktuálně přihlášený nemá správná oprávnění k vytvoření balíčku MTS.

Řešení

Během instalace Internet Information Server 4.0 může uživatel určit účet pro MTS relací pro spuštění pod. Ve výchozím nastavení je určeno interaktivní uživatel. To znamená je, že po žádné interaktivní uživatel (například správce není přihlášen na webový server), selhání operace správy, které vyžadují ověření, například vytváření kořen aplikací.

Vyřešit existující potíže pomocí následujících kroků:
  1. Vyvolat konzola Microsoft Management Console (MMC).
  2. Klepněte pravým tlačítkem myši na adresář obsahující Global.asa je aktivaci a vyberte "vlastnosti"
  3. Vyberte kartu adresář nebo virtuální adresář.
  4. Klepněte na tlačítko Vytvořit navázat tento adresář jako kořenový adresář aplikace.
Zatímco výše uvedených kroků bude vyřešit existující potíže, můžete zabránit budoucím problémům následující kroky:
  1. Vyvolat MMC serveru.
  2. Rozbalte "Server MTS.
  3. Rozbalte uzel "Počítače"
  4. Rozbalte "Můj počítač."
  5. Rozbalte "Packages Installed."
  6. Klepněte pravým tlačítkem myši "System" a vyvolat stránka vlastnosti.
  7. Na kartě Identita změnit z interaktivního uživatele uživatele je správce * v počítači.
  8. Zavřete stránku vlastností.
  9. Restartujte počítač.
* Postup vytvoření účtu pro balíček MTS System jsou následující:

Takto pomocí Správce uživatelů:
  1. Vytvořte novou místní skupinu s názvem Správci MTS.
  2. Vytvořit nového uživatele a název Správce MTS.
  3. Vytvořit nového uživatele členem obou Administrators skupiny a skupiny MTS Administrators
  4. Nový uživatel udělit upřesňující uživatelské právo přihlásit se jako služba.
Další informace, jak nakonfigurovat účet balíček systému naleznete v dokumentaci k produktu Internet Information Server 4.0 pod Getting Started poznámky verzi pro serveru

Odkazy

Další informace o nastavení aplikací naleznete v tématu "Konfigurace aplikací" v online dokumentaci k systému Windows NT 4.0 Option Pack.

Nejnovější články databáze Knowledge Base a další informace o odborné pomoci na Visual InterDev a ASP naleznete na následující stránce na webu Microsoft odbornou pomoc:
http://support.microsoft.com/search/default.aspx?qu=vinterdev

Vlastnosti

ID článku: 188715 - Poslední aktualizace: 1. března 2014 - Revize: 8.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Information Server 4.0
  • Microsoft Visual InterDev 1.0 Standard Edition
  • Microsoft Visual InterDev 6.0 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbprb KB188715 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:188715

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com