Internet Explorer를 사용하면 "내부 오류가 발생했습니다" 오류 메시지가 나타난다

기술 자료 번역 기술 자료 번역
기술 자료: 188952 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR188952
중요: 이 문서에서는 레지스트리 편집 방법을 설명합니다. 레지스트리를 편집하려면 문제가 발생한 경우 복원하는 방법을 알고 있어야 합니다. 복원 방법에 대한 자세한 내용은 Regedit.exe의 "레지스트리 복원" 도움말 항목 또는 Regedt32.exe의 "레지스트리 키 복원" 도움말 항목을 참조하십시오.
모두 확대 | 모두 축소

이 페이지에서

현상

전화 접속 연결을 한 상태에서 Internet Explorer를 사용하여 웹 사이트를 보려고 하면 다음과 같은 오류 메시지가 나타날 수 있습니다.
site name 인터넷 사이트를 열 수 없습니다. Windows 인터넷 확장 프로그램에서 내부 오류가 발생했습니다.
확인을 누르면 Internet Explorer에서 "탐색 취소" 페이지가 나타납니다.

원인

이 문제는 다음과 같은 이유로 발생할 수 있습니다.
  • 전화 접속 연결을 한 후 Internet Explorer를 시작하기 전에 VitalSigns Software의 Net.Medic 1.x를 시작하였습니다.
  • 컴퓨터에 잘못된 버전의 Wsock32.dll 파일이 설치되어 있습니다.
  • Wsock32.dll 파일의 두 번째 복사본이 루트 폴더에 있습니다.
  • Winsock 2.0 업데이트가 컴퓨터에 제대로 설치되지 않았습니다.
  • 레지스트리의 Winsock2 키가 손상되었습니다.
  • 컴퓨터에 Winsock.dll 파일의 복사본이 여러 개 있습니다.
  • TCP/IP가 설치되어 있지 않습니다.

해결 방법

경고: 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용하여 발생하는 문제에 대한 해결을 보증하지 않습니다. 레지스트리 편집기의 사용에 따른 모든 책임은 사용자에게 있습니다.

레지스트리를 편집하는 방법에 대한 자세한 내용은 레지스트리 편집기(Regedit.exe)의 "키 또는 값 변경"(Windows 98)이나 "키와 값 변경"(Windows Me/2000/XP) 도움말 항목 또는 Regedt32.exe의 "레지스트리의 정보 추가와 삭제" 및 "레지스트리 정보 편집" 도움말 항목을 참조하십시오. 레지스트리를 편집하기 전에 먼저 백업해야 합니다. 또한 Windows NT나 Windows 2000을 실행하는 경우 ERD(응급 복구 디스크)를 업데이트해야 합니다.

이 문제를 해결하려면 다음 방법을 사용하십시오.

Net.Medic 사용

  1. 컴퓨터를 다시 시작합니다. Windows 95 또는 Windows 98 시작 화면이 나타나면 Windows가 시작되는 동안 계속 Shift 키를 누릅니다.
  2. 시작하는 동안 사용자 이름과 암호를 묻는 메시지가 나타나면 Shift 키를 놓고 로그온 정보를 입력합니다. 확인을 누르기 전에 다시 한 번 Shift 키를 계속 누릅니다.
  3. Net.Medic가 아직 시작되지 않았다면 인터넷에 연결하여 다음 주소의 VitalSigns Software 웹 사이트에서 업데이트를 다운로드합니다.

    http://www.vitalsigns.com/techsupport/indexes/nm_upgrades98_index.html

잘못된 버전의 Wsock32.dll 파일이 설치되어 있는 경우

  1. 시작을 누르고 시스템 종료를 누르고 "MS-DOS 모드에서 시스템 다시 시작"을 누른 다음 확인을 누릅니다.
  2. MS-DOS 프롬프트에서 다음 명령을 입력하고 Enter 키를 누릅니다.
    drive:
    여기서 drive:는 Windows가 설치되어 있는 드라이브의 문자입니다. 예를 들어 Windows가 C 드라이브에 설치되어 있으면 c:를 입력합니다.
  3. 다음 명령을 입력하고 각 명령 끝에서 Enter 키를 누릅니다.
    cd\windows\system

    ren wsock32.dll wsock32.old

    exit
  4. Wsock32.dll 파일의 새 복사본을 Windows\System 폴더로 추출합니다. Windows 95를 사용 중인 경우에는 다음 위치의 Wsock32.dll 파일을 추출할 수 있습니다.

    • Windows 95 CD-ROM의 Win95_11.cab 캐비닛 파일
    • 원본 Windows 95 DMF 디스크의 Win95_12.cab 캐비닛 파일
    • 원본 Windows 95 비 DMF 디스크의 Win95_19.cab 캐비닛 파일
    • Windows 95 OEM 서비스 릴리스 2 CD-ROM의 Win95_18.cab 캐비닛 파일
    Extract 도구를 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.

    129605 압축된 원본 Windows 파일을 해제하는 방법
    Windows 98을 사용 중인 경우에는 시스템 파일 검사기 도구를 사용하여 Wsock32.dll 파일을 추출할 수 있습니다. 시스템 파일 검사기 도구에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서의 "System File Checker Tool" 사용 부분을 참조하십시오.

    129605 압축된 원본 Windows 파일을 해제하는 방법
  5. 컴퓨터를 정상적으로 다시 시작합니다.

Wsock32.dll의 두 번째 복사본이 루트 폴더에 있는 경우

이 문제를 해결하려면 루트 폴더에 있는 Wsock32.dll 파일의 이름을 Wsock32.old로 바꾼 다음 컴퓨터를 다시 시작하십시오. 파일 이름 바꾸기에 대한 자세한 내용을 보려면 시작을 누르고 도움말을 누른 다음 색인 탭을 누르고 이름 바꾸기를 입력한 다음 "파일 이름 바꾸기" 항목을 두 번 누르십시오.

Winsock 2.0 업데이트가 적절히 설치되지 않은 경우

Ws2bakup.bat 파일을 사용하여 Winsock 업데이트를 제거하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
191064 TCP/IP 기반 유틸리티나 프로그램을 실행하면 오류 메시지가 나타난다

레지스트리의 Winsock2 키가 손상된 경우

  1. 전화 접속 네트워킹을 제거합니다.
  2. Regedit를 사용하여 다음 키를 제거합니다.
    HKEY_Local_Machine\System\CurrentControlSet\Services\Winsock2
  3. 키를 제거한 후 전화 접속 네트워킹을 다시 설치합니다.

컴퓨터에 Winsock.dll 파일의 복사본이 여러 개 있는 경우

  1. 시작을 누르고 찾기를 가리킨 다음 파일 또는 폴더를 누릅니다.
  2. 이름 상자에 winsock.dll을 입력합니다.
  3. 위치 상자에서 로컬 하드 드라이브를 누릅니다.
  4. 지금 찾기를 누릅니다.
  5. Windows 폴더에 없는 Winsock.dll 파일을 마우스 오른쪽 단추로 누른 다음 삭제를 누릅니다. Windows 폴더에 없는 그 밖의 다른 Winsock.dll 파일 사본에 대해 각각 위의 작업을 반복합니다.

TCP/IP가 설치되어 있지 않은 경우

다음과 같이 TCP/IP를 설치하십시오.
  1. 시작을 누르고 설정을 가리킨 다음 제어판을 누릅니다.
  2. 네트워크를 두 번 누릅니다.
  3. 추가를 누르고 프로토콜을 누른 다음 추가를 누릅니다.
  4. 제조업체 상자에서 Microsoft를 누릅니다. 네트워크 프로토콜 상자에서 TCP/IP를 누른 다음 확인을 누릅니다.
  5. 확인을 누른 다음 컴퓨터를 다시 시작할 것인지 묻는 메시지가 나타나면 를 누릅니다.

현재 상태

VitalSigns Software는 Net.Medic 버전 1.x에서 이 문제를 확인했습니다.

추가 정보

본 문서에서 언급한 다른 공급업체 제품은 Microsoft와 무관한 공급업체가 제조하는 것으로서 Microsoft는 이러한 제품의 성능과 신뢰성에 대해 어떠한 보증도 하지 않습니다.

본 문서에 포함된 다른 공급업체의 연락처 정보는 필요한 기술 지원을 받는 데 도움을 주기 위한 것입니다. 이 연락처 정보는 예고 없이 변경될 수 있습니다. Microsoft는 이들 다른 공급업체 연락처 정보의 정확성을 보증하지 않습니다.

속성

기술 자료: 188952 - 마지막 검토: 2003년 11월 12일 수요일 - 수정: 3.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 98 Standard Edition
키워드:?
kb3rdparty kberrmsg kbprb msiew95 win98 KB188952
더 이상 지원되지 않는 제품의 KB 내용에 대한 고지 사항
이 문서에서는 Microsoft에서 더 이상 지원하지 않는 제품에 대해 설명합니다. 따라서 이 문서는 "있는 그대로" 제공되며 업데이트되지 않습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com