"Erro interno" mensagem de erro com o Internet Explorer

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Sintomas

Quando estiver a utilizar Internet Explorer através de uma ligação de acesso telefónico, poderá ser apresentada a seguinte mensagem de erro quando tenta visualizar um Web site:
Internet Explorer não consegue abrir o site de Internet site name. Ocorreu um erro interno nas extensões da Internet do Windows.
Quando clica em OK , a página "Navegação cancelada" é apresentada no Internet Explorer.

Causa

Este comportamento pode ocorrer uma das seguintes razões:
  • Se iniciar Net.Medic 1.x por Software VitalSigns depois de estabelecer uma ligação de acesso telefónico mas antes de iniciar o Internet Explorer.
  • Se está instalada a versão incorrecta do ficheiro Wsock32.dll no computador.
  • Existe uma segunda cópia do ficheiro Wsock32.dll na pasta raiz.
  • A actualização do Winsock 2.0 não está correctamente instalada no computador.
  • A chave Winsock2 no registo está danificada.
  • Existem várias cópias do ficheiro Winsock.dll no computador.
  • O TCP/IP não está instalado.

Resolução

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows

Para resolver este problema, utilize o método adequado:

Utilizar Net.Medic

  1. Reinicie o computador. Quando vir o ecrã de arranque do Windows 95 ou Windows 98, prima e mantenha premida a tecla SHIFT para a duração de arranque do Windows.
  2. Se lhe for pedido um nome de utilizador e palavra-passe durante o arranque, liberte a tecla SHIFT e introduza as informações de início de sessão normalmente. Antes de clicar em OK , prima e mantenha premida a tecla SHIFT novamente.
  3. Depois de ter verificado que Net.Medic não foi iniciado, ligar à Internet e transfira a actualização a partir do site VitalSigns Software.

Versão incorrecta do ficheiro Wsock32.dll

  1. Clique em Iniciar , clique em Encerrar , clique em " reiniciar o computador em MS-DOS modo ," e, em seguida, clique em Sim ou OK .
  2. Na linha de comandos da MS-DOS, escreva o seguinte comando e, em seguida, prima ENTER
    unidade:
    onde unidade: é a letra da unidade em que o Windows está instalado. Por exemplo, se o Windows está instalado na unidade C, escreva c: .
  3. Escreva os seguintes comandos, premindo ENTER após cada comando:
    cd\windows\system

    ren wsock32.dll wsock32.old

    sair
  4. Extraia uma nova cópia do ficheiro Wsock32.dll para a Windows\System pasta. Se estiver a utilizar o Windows 95, pode extrair o ficheiro Wsock32.dll a partir das seguintes localizações:

    • O ficheiro CAB Win95_11.cab no CD-ROM do Windows 95
    • O ficheiro CAB Win95_12.cab nos discos originais DMF do Windows 95
    • O ficheiro CAB Win95_19.cab não DMF discos originais do Windows 95
    • O Win95_18.cab cab ficheiro CD-Windows 95 OEM Service Release 2 ROM do
    Para informações sobre como utilizar a ferramenta Extract, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:

    129605 como extrair ficheiros originais comprimidos do Windows
    Se estiver a utilizar Windows 98, pode extrair o ficheiro Wsock32.dll utilizando a ferramenta Verificador de ficheiros de sistema. Para mais informações sobre como utilizar a ferramenta Verificador de ficheiros de sistema, consulte "System File Checker Tool" secção do seguinte artigo na base de dados de conhecimento da Microsoft:

    129605 como extrair ficheiros originais comprimidos do Windows
  5. Reinicie o computador normalmente.

Segunda cópia do ficheiro Wsock32.dll na pasta raiz

Para resolver este problema, mude o nome do ficheiro Wsock32.dll na pasta raiz para Wsock32.old e, em seguida, reinicie o computador. Para obter informações sobre como mudar o nome de um ficheiro, clique em Iniciar , clique em Ajuda , clique no separador índice remissivo , escreva Mudar o nome e faça duplo clique no tópico " Mudar o nome de ficheiros ".

O Winsock 2.0 actualização não está correctamente instalada

Remova a actualização Winsock utilizando o ficheiro Ws2bakup.bat. Para obter informações adicionais, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:
191064 mensagens de erro ao executar o TCP/IP-based utilitários ou programas

A chave Winsock2 do registo está danificada

  1. Desinstale rede Dial-up.
  2. Utilizando Regedit, remova a seguinte chave:
    HKEY_Local_Machine\System\CurrentControlSet\Services\Winsock2
  3. Depois de remover a chave, reinstale o acesso à rede Dial-up.

Várias cópias do ficheiro Winsock.dll no computador

  1. Clique em Iniciar , aponte para Localizar e, em seguida, clique em ficheiros ou pastas .
  2. Na caixa com o nome , escreva winsock.dll .
  3. Na caixa Procurar em , clique em unidades de disco rígido locais .
  4. Clique em Localizar agora .
  5. Com o botão direito do rato num ficheiro Winsock.dll que não esteja na pasta do Windows e, em seguida, clique em Eliminar . Repita para cada cópia extra do ficheiro Winsock.dll que não está na pasta Windows.

TCP/IP não estiver instalado

Instale TCP/IP:
  1. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  2. Clique duas vezes em rede .
  3. Clique em Adicionar , clique em protocolo e, em seguida, clique em Adicionar .
  4. Na caixa fabricantes , clique em Microsoft . Na caixa Protocolos de rede , clique em TCP/IP e, em seguida, clique em OK .
  5. Clique em OK e, em seguida, clique em Sim quando lhe for pedido para reiniciar o computador.

Ponto Da Situação

VitalSigns Software confirmou que este seja um problema com Net.Medic versão 1.x.

Mais Informação

O produto de terceiros referido neste artigo é fabricado por um fornecedor independente da Microsoft; a Microsoft oferece nenhuma garantia, expressa ou implícita, relativa ao desempenho ou fiabilidade deste produto.

As informações de contactos de outros fabricantes incluídas neste artigo são fornecidas para ajudar a localizar o suporte técnico que necessita. Estas informações de contacto estão sujeitas a alterações sem aviso prévio. A Microsoft não garante a precisão destas informações contactos outros fabricantes.

Propriedades

Artigo: 188952 - Última revisão: 23 de janeiro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 1.0
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 3.2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 188952
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