Chybové hlásenie „vyskytla sa vnútorná chyba"pri používaní programu Internet Explorer

Preklady článku Preklady článku
ID článku: 188952 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Ak používate program Internet Explorer cez telefonické pripojenie, nasledujúce chybové hlásenie môže zobraziť pri pokuse zobraziť webovú lokalitu:
Program Internet Explorer nemôže otvoriť internetovú lokalitu názov lokality. V internetové rozšírenia systému Windows sa vyskytla vnútorná chyba.
Po kliknutí na tlačidlo ok, v programe Internet Explorer sa zobrazí stránka „Navigácia zrušená".

PRICINA

Toto správanie sa môže vyskytnúť z niektorého z nasledujúcich dôvodov:
  • Ak začnete 1.x Net.Medic pomocou VitalSigns softvéru po vytvorení telefonické pripojenie, ale skôr, ako začnete programu Internet Explorer.
  • Ak nesprávna verzia súbor Wsock32.dll nie je nainštalovaná na vašom počítač.
  • Existuje druhá kópia Wsock32.dll nie je súbor v koreňovom priečinku.
  • Winsock 2.0 Update nie je správne nainštalovaný na vašom počítači.
  • V databáze registry kľúč Winsock2 poškodený.
  • Existujú viaceré kópie súboru Winsock.dll v počítači.
  • Nie je nainštalovaný protokol TCP/IP.

RIESENIE

Dôležité upozornenie Tento oddiel, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je vhodné pred úpravou databázu Registry zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry nájdete v nasledujúcom článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy Registry v systéme Windows

Na odstránenie tohto problému použite vhodnú metódu:

Pomocou Net.Medic

  1. Reštartujte počítač. Keď uvidíte obrazovku pri spustení systému Windows 95 alebo Windows 98, stlačte a podržte stlačený kláves SHIFT počas trvania štarte Windows.
  2. Ak sa zobrazí výzva na zadanie mena používateľa a hesla počas spustenia, uvoľnite kláves SHIFT a zadajte prihlasovacie informácie bežne. Pred kliknete na tlačidlo ok, stlačte a podržte kláves SHIFT opäť.
  3. Akonáhle ste si neoverili, že Net.Medic sa nespustil, pripojte k Internet a prevziať aktualizáciu z webovej lokality VitalSigns softvér.

Nesprávna verzia súboru Wsock32.dll nie je

  1. Kliknite na položku Štart, kliknite na tlačidlo vypnúťkliknite na tlačidlo "Reštartujte počítač v systéme MS-DOS režim"a potom kliknite na tlačidlo Yes alebo ok.
  2. Riadku systému MS-DOS zadajte nasledovný príkaz a stlačte kláves ENTER
    pohon:
    kde pohon: je písmeno jednotky, na ktorej je nainštalovaný systém Windows. Napríklad, ak systém Windows je nainštalovaný na jednotke C, zadajte c:.
  3. Zadajte nasledovné príkazy a po každom príkaze kláves ENTER:
    cd\windows\system

    ren Wsock32.dll nie je wsock32.old

    exit
  4. Extrahovanie novej kópie súboru Wsock32.dll nie je na Windows\System priečinok. Ak používate systém Windows 95, môžete extrahovať súbor Wsock32.dll nie je z nasledovných miestach:

    • Súbor typu kabinet Win95_11.cab na disku CD-ROM Windows 95
    • Súbor typu kabinet Win95_12.cab na pôvodné Windows 95 DMF diskoch
    • Súbor typu kabinet Win95_19.cab na pôvodné Windows 95 non-DMF disky
    • Súbor typu kabinet Win95_18.cab na disku Windows 95 OEM Service Release 2 CD-ROM
    Informácie o používaní nástroja extraktu nájdete nasledujúce článok v databáze Microsoft Knowledge Base:

    129605 Ako extrahovať pôvodné súbory komprimované Windows
    Ak používate systém Windows 98, môžete extrahovať súbor pomocou Wsock32.dll nie je nástroj System File Checker. Ďalšie informácie o používaní nástroja System File Checker prosím pozri "System File Checker nástroj" oddiel článok v Microsoft Knowledge Base:

    129605 Ako extrahovať pôvodné súbory komprimované Windows
  5. Reštartujte počítač normálne.

Druhá kópia Wsock32.dll nie je v koreňovom priečinku

Ak chcete tento problém odstrániť, premenujte súbor Wsock32.dll nie je v hlavnom priečinku, čím Wsock32.old, a potom reštartujte počítač. Informácie o premenovaním súboru, kliknite na tlačidlo Štart, kliknite na tlačidlo Pomocník, kliknite na tlačidlo Index na karte typ Premenovaniea potom dvakrát kliknite na "Premenovanie súborov"tému.

Winsock 2.0 Update nie je správne nainštalovaný

Odstrániť aktualizáciu Winsock pomocou súboru Ws2bakup.bat. Pre ďalšie informácie pozri článok v databáze Microsoft Knowledge Base:
191064 Chybové hlásenia pri spustení, TCP/IP-Based utility alebo programy

V databáze Registry kľúč Winsock2 poškodený

  1. Odinštalujte telefonické.
  2. Pomocou Regedit, odstráňte nasledujúci kľúč:
    HKEY_Local_Machine\System\CurrentControlSet\Services\Winsock2
  3. Po vytiahnutí kľúča, preinštalujte program Telefonické pripojenie siete.

Viacero kópií Winsock.dll súbor na počítači

  1. Kliknite na položku Štart, ukážte na Nájsť, a potom kliknite na tlačidlo Súbory alebo priečinky.
  2. V S názvom zadajte Winsock.dll.
  3. V Pozrite sa kliknite na tlačidlo Lokálne pevné disky.
  4. Kliknite na položku Nájsť teraz.
  5. Kliknite pravým tlačidlom na súbor Winsock.dll, ktorý nie je v priečinku systému Windows a potom kliknite na tlačidlo Odstrániť. Zopakujte pre každú kópiu súboru Winsock.dll, ktorý nie je v priečinku systému Windows.

Nie je nainštalovaný protokol TCP/IP

Inštalácia TCP/IP:
  1. Kliknite na položku Štart, ukážte na Nastavenie, a potom kliknite na tlačidlo Ovládací Panel.
  2. Dvakrát kliknite na Sieť.
  3. Kliknite na položku Pridať, kliknite na tlačidlo Protokol, a potom kliknite na tlačidlo Pridať.
  4. V Výrobcovia kliknite na tlačidlo Microsoft. V Sieťové protokoly kliknite na tlačidlo TCP/IP, a potom kliknite na tlačidlo ok.
  5. Kliknite na položku ok, a potom kliknite na tlačidlo Yes keď sa zobrazí výzva na reštartovanie počítača.

STAV

VitalSigns softvér potvrdila tento problém s Net.Medic verzia 1.x.

DALSIE INFORMACIE

Tretej strany produkt popísaných v tomto článku je vyrábaná Predajca nezávislé od spoločnosti Microsoft; robíme žiadnu záruku, implikovaných alebo inak, pokiaľ ide o tento výrobok výkon a spoľahlivosť.

Kontaktné údaje tretích strán zahrnuté v tomto článku sú uvedené ktoré vám pomôžu nájsť technickú podporu, ktorú potrebujete. Toto kontaktné informácie podliehajú zmenám bez predchádzajúceho upozornenia. Microsoft v žiadnom prípade záruk presnosť tejto tretej strany kontaktné informácie.

Vlastnosti

ID článku: 188952 - Posledná kontrola: 19. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows 98 Standard Edition
Kľúčové slová: 
kb3rdparty kberrmsg kbprb kbmt KB188952 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:188952
Upozornenie na neaktuálny obsah článku databázy KB
Tento článok obsahuje informácie o produktoch, pre ktoré spoločnosť Microsoft už neposkytuje technickú podporu. Z tohto dôvodu je tento článok publikovaný ako nezmenený a už nebude aktualizovaný.

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com