Repeated Regsavekey/Regrestorekey Actions Corrupt Registry Hive

Article translations Article translations
Article ID: 189061 - View products that this article applies to.
This article was previously published under Q189061
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

When you repeatedly save and restore a registry key in Windows NT, the registry hive may eventually become corrupted.

CAUSE

If you save a registry key to disk, and then later restore it over another key where the key name length is different (that is, longer than the original key name), it causes the actual allocated storage for the key to grow. If you repeat this process enough times, eventually the storage assigned to this key becomes so large that the registry check code declares the hive corrupted.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Microsoft has confirmed this to be a problem in Windows NT version 3.1, 3.5, and 3.51. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Properties

Article ID: 189061 - Last Review: February 28, 2014 - Revision: 3.1
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix KB189061

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com