Artikel-ID: 189119 - Geändert am: Freitag, 9. Dezember 2005 - Version: 5.1

Benutzerumgebung meldet beschädigtes Profil bei allen Fehlern einschließlich Überschreitung der maximalen Registrierungsgröße

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
189119  (http://support.microsoft.com/kb/189119/EN-US/ ) UserEnv Returns Corrupted Profile for All Failures Including RSL Exceeded
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Wenn Sie sich bei einem Windows NT 4.0-Computer anmelden, wird möglicherweise die folgende Fehlermeldung im Dialogfeld Benutzerumgebung angezeigt:

Das Betriebssystem konnte das lokal gespeicherte Profil nicht laden. Es wird ein neues lokales Profil erstellt (1009).

Es kann außerdem die folgende Meldung angezeigt werden:

Ihr Profil konnte nicht erfolgreich geladen werden, Sie wurden mit dem standardmäßigen Systemprofil angemeldet. Beheben Sie das Problem, und melden Sie sich ab
(18).

Ihre Profileinstellungen (Desktopsymbole, Anwendungseinstellungen etc.) werden auf den Standard zurückgesetzt. Wenn Sie im Ordner "%SystemRoot%\Profiles" nachsehen, sollten Sie feststellen, dass Ihr Profilverzeichnis in "%SystemRoot%\Profiles\Benutzername.bak" umbenannt und ein neues Standardprofil in "%SystemRoot%\Profiles\Benutzername" gespeichert wurde. Dies soll einem Benutzer die erfolgreiche Anmeldung ermöglichen, wenn das Profil beschädigt wurde oder aus einem anderen Grund nicht geladen wird.

Wenn die maximale Größe der Registrierungsdatenbank (Registry Size Limit, RSL) überschritten wurde, wird der Benutzer bei seinem ersten Anmeldeversuch, bei dem dies auftritt, vom System mit einer Meldung darüber informiert. Die folgende Meldung wird angezeigt:

Systemprozess - Kleine Registrierungsquote: Die maximale Größe für die Registrierung wurde fast erreicht. Klicken Sie in der Systemsteuerung auf das Symbol "System". Klicken Sie dann im Dialogfeld "System" auf "Virtueller Speicher", um die maximale Größe zu erhöhen.

Während nachfolgenden Anmeldeversuchen treten Profil-Ladefehler auf, und die folgenden Anwendungsereignisse werden protokolliert:

   Ereignis-ID 1000 userenv RegLoadKey ist mit dem Fehler 1009 für C:\WINNT\Profiles\Benutzername\ntuser.dat gescheitert.

   Ereignis-ID 1000 userenv Das Betriebssystem konnte das lokal gespeicherte Profil nicht laden.  Es wird ein neues lokales Profil erstellt. (1009)
				


Hinweis: Wenn ein Benutzer gewöhnlich den Computer sperrt, anstatt sich abzumelden, wurde der ursprüngliche RSL-Fehler möglicherweise vergessen oder befindet sich nicht mehr im Ereignisprotokoll, wenn ein nachfolgender Anmeldeversuch stattfindet und das Profil nicht geladen werden kann.

Bei Windows 2000 Terminal Server SP4-Clients schlägt die Verbindung zum Terminalserver mit den folgenden Fehlermeldungen fehl:
Typ: Fehler Quelle: Userenv Ereignis-ID: 1000 Datum: 06.01.2004 Uhrzeit: 10:33:41 Benutzer: NT-AUTORITÄT\SYSTEM Computer: SRV-TS01 Beschreibung: Abbruch in RegLoadKey. Rückgabewert Nicht genügend Systemressourcen, um den angeforderten Dienst für C:\Dokumente und Einstellungen\jj35678\ntuser.dat auszuführen. Typ: Fehler Quelle: Userenv Ereignis-ID: 1000 Datum: 06.01.2004 Uhrzeit: 10:33:47 Benutzer: NT-AUTORITÄT\SYSTEM Computer: SRV-TS01 Beschreibung: Ihr Benutzerprofil konnte nicht geladen werden. Vergrößern Sie die Registrierungsgröße, und starten Sie den Computer neu.

Typ: Fehler Quelle: Userenv Ereignis-ID: 1000 Datum: 06.01.2004 Uhrzeit: 10:33:48 Benutzer: NT-AUTORITÄT\SYSTEM Computer: SRV-TS01 Beschreibung: Sie konnten nicht angemeldet werden, weil das Profil nicht geladen werden kann. Wenden Sie sich an den Netzwerkadministrator. Detail - Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.

Ursache

Auch wenn es verschiedene Gründe haben kann, dass die Registrierungsschlüssel für das Benutzerprofil nicht geladen werden, wird immer ein Statuscode zurückgegeben, der besagt, dass das Profil beschädigt ist. Möglicherweise wurde die maximale Größe der Registrierung (RSL) überschritten. Diese maximale Größe ist ein benutzerdefinierter oberer Grenzwert, der festlegt, auf welche Größe die Registrierung maximal anwachsen kann. Wenn dieser Grenzwert fast erreicht ist, wird der Benutzer durch eine Meldung im Dialogfeld Anwendungspopup darüber informiert. Da das Laden eines Benutzerprofils (in "Ntuser.dat" gespeichert) Registrierungsgröße beansprucht, kann dieser Vorgang dazu beitragen, dass diese Ressource erschöpft wird.

Lösung

Ein Benutzerprofil wird nicht geladen, wenn die RSL überschritten wurde. Es handelt sich hierbei um ein beabsichtigtes Verhalten. Die RSL kann erhöht werden, um dieses Problem zu umgehen. Gehen Sie hierzu folgendermaßen vor:
  1. Doppelklicken Sie in der Systemsteuerung auf System.
  2. Klicken Sie auf der Registerkarte Leistung im Abschnitt Virtueller Speicher auf Ändern.
  3. Im Dialogfeld Virtueller Speicher werden im Abschnitt Größe der Registrierungsdatenbank die aktuelle und die maximale Größe der Registrierungsdatenbank angezeigt. Ändern Sie in diesem Abschnitt die aktuelle RSL.
Microsoft empfiehlt, die RSL nur soweit zu erhöhen, dass es für die aktuelle Registrierung und eine geringe Zunahme ausreicht. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

176083  (http://support.microsoft.com/kb/176083/DE/ )
Maximale Größe der Registrierung fast erreicht
In Windows NT 4.0, Terminal Server Edition, basiert die RSL auf dem Auslagerungsspeicher. Die maximale Größe des Auslagerungsspeichers beträgt 192 MB. Die maximale Größe der Registrierung kann 80 Prozent des Auslagerungsspeichers, also 153,6 MB, erreichen. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
124594  (http://support.microsoft.com/kb/124594/DE/ ) Die maximale Registrierungsgröße (Registry Size Limit = RSL) - Basiswissen und Konfiguration

Windows NT 4.0

Wenn das Profil infolge der Überschreitung der RSL in "Benutzername.bak" umbenannt wurde, ist es möglich, die ursprünglichen Profileinstellungen wiederherzustellen.
  1. Melden Sie sich als Administrator am Computer an.
  2. Benennen Sie den Profilordner "%SystemRoot%\Profiles\Benutzername um, oder löschen Sie ihn.
  3. Benennen Sie den Profilordner "%SystemRoot%\Profiles\Benutzername.bak" in Benutzername um.
  4. Melden Sie sich als Administrator ab und anschließend als Benutzername an.

Windows 2000

Windows 2000 enthält eine Erweiterung der Benutzerumgebung, die dafür sorgt, dass das Benutzerprofil nicht gelöscht wird, wenn es nicht beschädigt ist. Es wird eine Meldung angezeigt, die auf unzureichende Ressourcen hinweist. Der Benutzer wird dann abgemeldet, wenn er keine lokalen Administratorrechte hat, oder der Benutzer wird angemeldet, wenn Administratorrechte identifiziert werden. Der Administrator kann dann die maximale Registrierungsgröße erhöhen und sich erneut anmelden. Das vor dem Auftreten des Problems verwendete Benutzerprofil wird dennoch auf dem lokalen Computer gespeichert, sofern es nicht gerade kopiert wurde.

Hinweis: Nach der Erhöhung der RSL über die Systemsteuerung oder durch Bearbeitung der Registrierung muss der Computer neu gestartet werden, da diese Änderung nicht dynamisch übernommen wird und immer noch das folgende Ereignis auftreten kann:

Typ: Fehler
Quelle: Userenv
Kategorie: Keine
Ereignis-ID: 1000
Datum: Datum
Uhrzeit: Uhrzeit
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: Computername
Beschreibung: Abbruch in RegLoadKey.
Rückgabewert: Nicht genügend Systemressourcen, um den angeforderten Dienst für C:\Dokumente und Einstellungen\ntuser.dat auszuführen.



Windows 2000 Terminal Server SP4-Clients

Achtung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.
  1. Gehen Sie zum folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  2. Implementieren Sie die folgenden Registrierungseinstellungen:
    PoolUsageMaximum=dword:00000030
    PagedPoolSize=dword:ffffffff
  3. Starten Sie den Computer neu.
Versuchen Sie folgendermaßen, die Größe der Registrierung auf betroffenen Windows 2000 Professional-Computern zu verringern:
  1. Klicken Sie auf Start, auf Ausführen, geben Sie ntbackup ein, und klicken Sie auf OK. Klicken Sie auf Notfalldiskette.
  2. Klicken Sie auf OK, wenn die folgende Meldung angezeigt wird:
    Legen Sie eine leere, formatierte Diskette in Laufwerk A: ein, und klicken Sie auf "OK". Die Registrierung im Wiederherstellungsverzeichnis sichern. Diese Sicherung kann verwendet werden, um das System wiederherzustellen, wenn die Registrierung beschädigt ist.


    Wenn Sie auf OK klicken, können Sie die folgende Fehlermeldung ignorieren:
    Der Vorgang ist fehlgeschlagen. Das Laufwerk ist nicht bereit, oder die Diskette wurde nicht ordnungsgemäß eingelegt.
  3. Erstellen Sie einen neuen Ordner "Regback" in "c:\winnt\repair". Beenden Sie Windows NT Backup, und starten Sie den Registrierungseditor.
  4. Klicken Sie auf HKEY_LOCAL_MACHINE und anschließend im Menü Datei auf Struktur laden.
  5. Öffnen Sie den Ordner "c:\winnt\repair\regback", klicken Sie auf Software und anschließend auf Öffnen.
  6. Geben Sie in das Feld Schlüsselname den Begriff software.good ein, und klicken Sie auf OK.
  7. Klicken Sie im Menü Registrierung auf Schlüssel speichern.
  8. Starten Sie den Computer mit der Windows 2000 CD-ROM in Ihrem CD-ROM-Laufwerk neu, sodass Sie von der Windows 2000-CD starten können.
  9. Starten Sie die Wiederherstellungskonsole, und geben Sie die folgenden Befehle ein. Drücken Sie nach jedem Befehl die [EINGABETASTE]:
    cd\winnt\system32\config
    rename software Software.bad
    rename Software.good software
  10. Starten Sie den Computer neu. Weitere Informationen zur Wiederherstellungskonsole finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    229716  (http://support.microsoft.com/kb/229716/DE/ ) Beschreibung der Windows 2000-Wiederherstellungskonsole
Installieren Sie das neueste Service Pack für Windows NT 4.0 oder Windows NT Server 4.0, Terminal Server Edition, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
152734  (http://support.microsoft.com/kb/152734/DE/ ) Bezugsquellen für das aktuelle Windows NT 4.0 Service Pack

Status

Microsoft hat bestätigt, dass es sich dabei um ein Problem bei Windows NT 4.0 und Windows NT Server 4.0, Terminal Server Edition, handelt. Dieses Problem wurde erstmals in Windows NT 4.0, Service Pack 4.0 und Windows NT Server 4.0, Terminal Server Edition, Service Pack 4 behoben.

Weitere Informationen

Der Fehlercode 1009 wird immer als NtStatus-Code für die Windows-API MyRegLoadkey zurückgegeben. Dieser Code besagt, dass die Datenbank der Konfigurationsregistrierung beschädigt ist: ERROR_BADDB oder STATUS_REGISTRY_CORRUPT. Diese Information ist irreführend, wenn das Laden der Registrierungsstruktur aufgrund von anderen Ursachen fehlgeschlagen ist. Wenn die RSL überschritten ist, lautet der korrekte NtStatus-Code 1450. Er besagt, dass nicht genügend Systemressourcen vorhanden sind, um den angeforderten Dienst auszuführen: ERROR_NO_SYSTEM_RESOURCES oder STATUS_INSUFFICIENT_RESOURCES.

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

185198  (http://support.microsoft.com/kb/185198/DE/ ) 1000 Fehler und Benutzerprofil

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows NT Server 4.0 Terminal Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
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