Najít příkaz nefunguje přes Excel pro Mac listy ve skupině

Překlady článku Překlady článku
ID článku: 189629 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při použití dialogového okna Najít vyhledat konkrétní informace uzavřený pro Mac vyhledá pouze výskyty hodnotu na aktivním listu (i Pokud jste vybrali více listů, které obsahují tyto informace).

Pokud není na aktivním listu informace, ale je umístěn na jiném listu ve skupině Excel pro Mac může vyhledání výskytu na poslední list ve skupině s hodnotou; však jej není prohledá všechny seskupené listů mezi.

Poznámka: Toto není problém při použití příkazu Nahradit. Tento problém projevuje pouze příkaz Najít.

Příčina

K tomuto problému dochází, protože příkaz Najít nefunguje přes seskupených listech. Excel pro Mac Nápověda uvádí, že pokud je vybrána skupinu listů, příkaz Najít prohledá všechny listy v skupiny kromě modulů jazyka. Toto je skutečné chování. Při výběru více listů a pomocí příkazu Hledat vyhledávání informací na listu, pouze první výskyt hodnoty nalezen.

Jak potíže obejít

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci, bez žádné záruky výslovně uvedené nebo odvozené,. včetně, bez omezení, odvozených záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele. Chcete-li tento problém vyřešit, můžete použít Microsoft Visual Basic pro Applications makro (procedura Sub) k vyhledávání každého listu, který je vybrán v režimu skupiny. Chcete-li vytvořit makro, postupujte takto:
  1. Uložte a zavřete všechny otevřené sešity a vytvořte nový sešit.
  2. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz Editor jazyka.
  3. V nabídce Vložit klepněte na modul.
  4. V modulu zadejte následující kód:
    Sub FindData()
    
       ' This Sub prompts you for a value and searches each worksheet
       ' that is selected in group mode. If it finds the search value,
       ' the routine prompts you to continue the search on the sheet.
       ' If it does not find the value on the sheet, it goes to the
       ' next sheet. You can cancel the search on the sheet by
       ' answering No to "Look for another value..." and then
       ' answering Yes to "Cancel the search ...".
       '
       ' WARNING: When this macro ends, the workbook will no longer be
       ' in group mode.
    
       testValue = InputBox("Enter the value to search for : ")
       For Each x In ActiveWindow.SelectedSheets
          x.Select
          Set foundcell = ActiveSheet.Cells.Find(testValue)
           If foundcell Is Nothing Then
               MsgBox "The word was not found"
           Else
               MsgBox "The word was found in cell " & foundcell.Address
               Range(foundcell.Address).Select
    
        LookAgain:
               response = MsgBox _
                   ("Look for another value on this sheet?", vbYesNo)
    
               ' If response = 6, we will not continue searching on
               ' this sheet.
               If response = 6 Then
    
                   ' Part2
                   Set foundcell = _
                       ActiveSheet.Cells.FindNext(after:=ActiveCell)
                   Range(foundcell.Address).Select
                   GoTo LookAgain
               End If
    
               If response = 7 Then
                   response = MsgBox("Cancel search ? ", vbYesNo)
                   If response = 6 Then End
                   GoTo NextSheet
               End If
           End If
    
      NextSheet:
          Next x
          MsgBox "Search is complete ....."
    
    End Sub
    					
  5. V nabídce File (nebo v nabídce v Microsoft Excel X pro Mac Excel) klepněte na tlačítko Zavřít a návrat do aplikace Excel.
  6. Vyberte listy (režim skupiny), které chcete hledat. Použijte příslušnou metodu pro danou situaci:
    • Pokud chcete vybrat dva nebo více sousedících listů, klepněte na kartu první list a podržte klávesu SHIFT a klepněte na ouško posledního listu.

      Nebo
    • Pokud chcete vybrat dva nebo více nesousedících listů, klepněte na kartu první list a podržte klávesu COMMAND a klepněte na karty jiných listech.

      Nebo
    • Pokud chcete vybrat všechny listy v sešitu, podržte klávesu CTRL a klepněte na ouško listu a v místní nabídce klepněte na příkaz Vybrat všechny listy.
  7. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
  8. Klepněte na makro FindData a potom klepněte na příkaz Spustit. Postupujte podle pokynů v dialogových oknech, která se zobrazují.

Odkazy

Další informace o příkazu Najít v nabídce Nápověda klepněte na položku Microsoft Excel pro Mac Nápověda zadejte Najít nebo nahradit data v Pomocníkovi Office nebo průvodce a klepněte na tlačítko Hledat zobrazte vrácená témata.

Vlastnosti

ID článku: 189629 - Poslední aktualizace: 23. ledna 2007 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X pro počítače Macintosh
  • Microsoft Excel 2001 pro počítače Macintosh
  • Microsoft Excel 98 pro počítače Macintosh
Klíčová slova: 
kbmt kbdtacode kbprb KB189629 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:189629

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com