Localizar o comando não funciona em Excel para Mac planilhas no grupo

Traduções deste artigo Traduções deste artigo
ID do artigo: 189629 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você usa a caixa de diálogo Localizar para localizar informações específicas, o Microsoft Excel para Mac localiza apenas ocorrências do valor na planilha ativa (mesmo se você tiver selecionado várias planilhas que contêm essas informações).

Se as informações não está na planilha ativa, mas estão localizadas em outra planilha no grupo, Excel para Mac pode localizar a ocorrência da última planilha no grupo com esse valor; no entanto, ele não pesquisará qualquer planilhas agrupadas entre.

Observação : isso não é um problema quando você usa o comando Substituir . Somente o comando Localizar apresenta esse problema.

Causa

Esse problema ocorre porque o comando Localizar não funciona em planilhas agrupadas. Excel para Mac ajuda informa que se um grupo de planilhas estiver marcado, o comando Localizar procura todas as planilhas no grupo, exceto os módulos do Visual Basic. Isso não é o comportamento real. Quando você selecionar várias planilhas, e use o comando Localizar para procurar informações em uma planilha, somente a primeira ocorrência do valor é encontrada.

Como Contornar

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades. Para contornar esse problema, você pode usar um Microsoft Visual Basic para aplicativos macro (procedimento sub ) para pesquisar cada planilha que está selecionada no modo de grupo. Para criar a macro, siga estas etapas:
  1. Salvar e fechar qualquer abrir pastas de trabalho e, em seguida, crie uma nova pasta de trabalho.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. No menu Inserir , clique em módulo .
  4. Digite o seguinte código no módulo:
    Sub FindData()
    
       ' This Sub prompts you for a value and searches each worksheet
       ' that is selected in group mode. If it finds the search value,
       ' the routine prompts you to continue the search on the sheet.
       ' If it does not find the value on the sheet, it goes to the
       ' next sheet. You can cancel the search on the sheet by
       ' answering No to "Look for another value..." and then
       ' answering Yes to "Cancel the search ...".
       '
       ' WARNING: When this macro ends, the workbook will no longer be
       ' in group mode.
    
       testValue = InputBox("Enter the value to search for : ")
       For Each x In ActiveWindow.SelectedSheets
          x.Select
          Set foundcell = ActiveSheet.Cells.Find(testValue)
           If foundcell Is Nothing Then
               MsgBox "The word was not found"
           Else
               MsgBox "The word was found in cell " & foundcell.Address
               Range(foundcell.Address).Select
    
        LookAgain:
               response = MsgBox _
                   ("Look for another value on this sheet?", vbYesNo)
    
               ' If response = 6, we will not continue searching on
               ' this sheet.
               If response = 6 Then
    
                   ' Part2
                   Set foundcell = _
                       ActiveSheet.Cells.FindNext(after:=ActiveCell)
                   Range(foundcell.Address).Select
                   GoTo LookAgain
               End If
    
               If response = 7 Then
                   response = MsgBox("Cancel search ? ", vbYesNo)
                   If response = 6 Then End
                   GoTo NextSheet
               End If
           End If
    
      NextSheet:
          Next x
          MsgBox "Search is complete ....."
    
    End Sub
    					
  5. No arquivo menu (ou menu Excel no Microsoft Excel X para Mac), clique em Fechar e voltar para Microsoft Excel .
  6. Selecione as planilhas (modo de grupo) que você deseja pesquisar. Use o método apropriado para sua situação:
    • Se você desejar selecionar dois ou mais planilhas adjacentes, clique na guia da primeira planilha e em seguida, mantenha pressionada a tecla SHIFT e clique na guia da última planilha.

      - ou -
    • Se você deseja selecionar duas ou mais planilhas não adjacentes, clique na guia da primeira planilha e, em seguida, mantenha pressionada COMMAND e clique nas guias das outras planilhas.

      - ou -
    • Se você deseja selecionar todas as planilhas na pasta de trabalho, mantenha o controle e clique na guia planilha e, em seguida, clique em Selecionar todas as planilhas no menu de atalho.
  7. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  8. Clique na macro FindData e, em seguida, clique em Executar . Siga as instruções nas caixas de diálogo que aparecem.

Referências

Para obter mais informações sobre o comando Localizar, clique em Microsoft Excel para Mac ajuda no menu Ajuda , digite Localizar ou substituir dados no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Propriedades

ID do artigo: 189629 - Última revisão: terça-feira, 23 de janeiro de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Mac
  • Microsoft Excel 98 for Macintosh
Palavras-chave: 
kbmt kbdtacode kbprb KB189629 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 189629

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com