Artigo: 190059 - Última revisão: quinta-feira, 28 de Junho de 2001 - Revisão: 1.0

PROBLEMA: O Certificate Server não consegue iniciar após a instalação automática

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante: Este artigo contém informações sobre como editar o registo. Antes de editar o registo, certifique-se de que compreende como o restaurar se ocorrer um problema. Para obter informações sobre como efectuar este procedimento, consulte o tópico de ajuda "Restaurar o registo" no Regedit.exe ou o tópico de ajuda "Restaurar uma chave de registo" no Regedt32.exe.
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Sintomas

Após uma instalação automática do Windows NT 4.0 Option Pack, incluindo o Certificate Server versão 1.0, o serviço autoridade de certificação não for iniciado. É gerada a seguinte entrada de aplicação do registo de eventos:
Origem: CertSvc
ID do evento: 17
Descrição: "O servidor de certificados não se iniciou: não é possível inicializar a ligação de base de dados para AC nomedocomputador. O código de erro é 0xffffffff."
Aviso: A utilização incorrecta do Editor de registo pode provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.

Para obter informações sobre como editar o registo, consulte o tópico de ajuda "Alterar chaves e valores" no Editor de registo (Regedit.exe) ou os tópicos de ajuda "Adicionar e eliminar informações no registo" e "Editar dados do registo" do Regedt32.exe. Nota efectuar uma que deve cópia de segurança do registo antes de o editar. Se estiver a executar Windows NT, deverá também actualizar o disco de reparação de emergência (ERD, Emergency Repair Disk).

Para contornar este problema, execute o seguinte script REGEDIT ou REGINI para criar o "CertSrv" ODBC depois de concluída a configuração automática e tiver reiniciado o servidor da origem de dados.

Tenha em atenção que o caminho especificado nos movimentos de "Driver" e "DBQ" tem de ser ajustado consoante a configuração actual.

Ficheiro de script REGEDIT (CERTSRV.REG):

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\CertSrv]
"Driver"="C:\\WINNT\\System32\\odbcjt32.dll"
"DBQ"="C:\\WINNT\\System32\\CertLog\\certsrv.mdb"
"DriverId" = dword:00000019
"SafeTransactions" = DWORD: 00000000
"UID"="Admin"

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\CertSrv\Engines\Jet]
"ImplicitCommitSync"="Sim"
"Tópicos" = dword:00000003
"UserCommitSync"="Sim"

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\ODBC origens de dados]
"CertSrv"="o Microsoft Access Driver (*.mdb)"

O utilitário do Regedit.exe incluída no Windows NT Server 4.0. Pode ser executado no modo silencioso utilizando a opção da linha de comandos /S. Uma linha de comandos de exemplo é:
REGEDIT /S C:\CERTSRV.REG
Ficheiro de script REGINI:
\Registry\Machine\SOFTWARE\ODBC\odbc.ini
CertSrv
Controlador = C:\WINNT\System32\odbcjt32.dll
DBQ = C:\WINNT\System32\CertLog\certsrv.mdb
DriverId = REG_DWORD 0x00000019
SafeTransactions = REG_DWORD 0 x 00000000
UID = Admin
Motores
Jet
ImplicitCommitSync = Yes
Threads = REG_DWORD 0 x 00000003
UserCommitSync = Yes
Origens de dados ODBC
CertSrv = Driver do Microsoft Access (*.mdb)
Regini.exe é um utilitário para manipular o registo local ou remotamente utilizando um ficheiro de script. Este utilitário está incluído no Windows NT Server Resource Kit.

Causa

O problema é causado pelo programa de configuração automático não adicionar a origem de dados ODBC necessária para a base de dados do Certificate Server.

Ponto Da Situação

Microsoft confirmou que este problema existe no servidor de certificados versão 1.0.

A informação contida neste artigo aplica-se a:
  • Microsoft Certificate Server 1.0
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